]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 47.0.2526.69
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_without  system_ffmpeg   # system ffmpeg
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32 %bcond_with     system_protobuf # system protobuf
33 %bcond_without  system_re2              # system re2
34 %bcond_without  system_snappy   # system snappy
35 %bcond_without  system_speex    # system speex
36 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
37 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
38 %bcond_with             system_v8               # system v8
39 %bcond_with     system_libvpx   # system libvpx, http://crbug.com/494939
40 %bcond_without  system_yasm             # system yasm
41 %bcond_without  system_zlib             # system zlib
42 %bcond_with     tcmalloc                # use tcmalloc
43 %bcond_without  verbose                 # verbose build (V=1)
44
45 %ifarch %{ix86}
46 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47 %undefine       with_system_mesa
48
49 # unable build with debuginfo on 32bit build systems
50 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51 %undefine       with_debuginfo
52 %endif
53
54 %ifarch %{x8664}
55 # x86_64 systems fail with debugedit crashing
56 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
57 %undefine       with_debuginfo
58 %endif
59
60 # TODO
61 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
62 # - use_system_skia
63 # - use_system_ssl (use_openssl: http://crbug.com/62803)
64 # - use_system_stlport (android specific)
65
66 # NOTES:
67 # - mute BEEP mixer if you do not want to hear horrible system bell when
68 #   pressing home/end in url bar or more ^F search results on page.
69 # - space considerations:
70 #   - unpacked sources: ~490MiB
71 #   - built code: ~1.1GiB (x86_64/i686)
72 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
73 # - to look for new tarball, use update-source.sh script
74
75 %define         branch          47.0.2526
76 %define         basever         69
77 #define         patchver        130
78 %define         gyp_rev 1014
79 Summary:        A WebKit powered web browser
80 Name:           chromium-browser
81 %if "%{?patchver}" != ""
82 Version:        %{branch}.%{patchver}
83 %else
84 Version:        %{branch}.%{basever}
85 %endif
86 Release:        1
87 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
88 Group:          X11/Applications/Networking
89 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.gz
90 # Source0-md5:  fd02450421899fb410fa70352a611c31
91 %if "%{?patchver}" != ""
92 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
93 # Patch0-md5:   02973b87b9564ed36220497b4bf83109
94 %endif
95 Source1:        %{name}.default
96 Source2:        %{name}.sh
97 Source3:        %{name}.desktop
98 Source5:        find-lang.sh
99 Source6:        update-source.sh
100 Source7:        clean-source.sh
101 Source8:        get-source.sh
102 Source9:        master_preferences.json
103 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
104 Patch2:         enable-video-decode-accel.patch
105 Patch7:         dlopen_sonamed_gl.patch
106 Patch8:         chromium_useragent.patch.in
107 # https://bugs.gentoo.org/show_bug.cgi?id=393471
108 # libjpeg-turbo >= 1.1.90 supports that feature
109 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
110 Patch15:        nacl-build-irt.patch
111 Patch16:        nacl-linkingfix.patch
112 Patch18:        nacl-no-untar.patch
113 Patch24:        nacl-verbose.patch
114 Patch25:        gnome3-volume-control.patch
115 Patch26:        master-prefs-path.patch
116 Patch28:        system-mesa.patch
117 Patch31:        system-jinja.patch
118 Patch32:        remove_bundled_libraries-stale.patch
119 Patch35:        etc-dir.patch
120 Patch36:        angle.patch
121 Patch37:        %{name}-build.patch
122 Patch38:        vaapi_include.patch
123 Patch39:        libsecret.patch
124 Patch40:        ffmpeg-generate-errors.patch
125 Patch41:        ffmpeg-generate.patch
126 Patch42:        system-ffmpeg.patch
127 URL:            http://www.chromium.org/Home
128 %{?with_gconf:BuildRequires:    GConf2-devel}
129 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
130 BuildRequires:  Mesa-libGLES-devel >= 9.1
131 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
132 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
133 BuildRequires:  alsa-lib-devel
134 BuildRequires:  atk-devel
135 BuildRequires:  bison
136 BuildRequires:  bzip2-devel
137 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
138 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
139 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
140 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
141 %{?with_cups:BuildRequires:     cups-devel}
142 BuildRequires:  elfutils-devel
143 BuildRequires:  expat-devel
144 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.7.2}
145 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
146 BuildRequires:  fontconfig-devel
147 BuildRequires:  glib2-devel
148 BuildRequires:  gperf
149 %{?with_gps:BuildRequires:      gpsd-devel}
150 BuildRequires:  gtest-devel
151 BuildRequires:  gtk+2-devel
152 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
153 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
154 %{?with_kerberos:BuildRequires: heimdal-devel}
155 BuildRequires:  hicolor-icon-theme
156 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
157 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
158 BuildRequires:  libevent-devel
159 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
160 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
161 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
162 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
163 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
164 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
165 BuildRequires:  libpng-devel
166 BuildRequires:  libsecret-devel
167 %{?with_selinux:BuildRequires:  libselinux-devel}
168 BuildRequires:  libstdc++-devel
169 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
170 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.5.0}
171 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
172 BuildRequires:  libxml2-devel
173 BuildRequires:  libxslt-devel
174 BuildRequires:  man-db
175 %{?with_system_minizip:BuildRequires:   minizip-devel}
176 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
177 BuildRequires:  nspr-devel
178 BuildRequires:  nss-devel >= 1:3.12.3
179 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
180 BuildRequires:  pam-devel
181 BuildRequires:  pango-devel
182 BuildRequires:  pciutils-devel
183 BuildRequires:  perl-JSON
184 BuildRequires:  perl-modules
185 BuildRequires:  pkgconfig
186 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
187 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
188 BuildRequires:  python
189 BuildRequires:  python-BeautifulSoup
190 #BuildRequires: python-gyp >= 1-%{gyp_rev}
191 BuildRequires:  python-html5lib
192 BuildRequires:  python-jinja2 >= 2.7
193 BuildRequires:  python-modules
194 BuildRequires:  python-ply >= 3.4
195 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
196 BuildRequires:  rpm >= 4.4.9-56
197 BuildRequires:  rpmbuild(macros) >= 1.453
198 %{?with_system_snappy:BuildRequires:    snappy-devel}
199 BuildRequires:  speech-dispatcher-devel >= 0.8
200 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
201 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
202 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
203 BuildRequires:  tar >= 1:1.22
204 BuildRequires:  udev-devel
205 BuildRequires:  usbutils
206 BuildRequires:  util-linux
207 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
208 BuildRequires:  which
209 BuildRequires:  xorg-lib-libXScrnSaver-devel
210 BuildRequires:  xorg-lib-libXtst-devel
211 BuildRequires:  xz
212 %{?with_system_yasm:BuildRequires:      yasm}
213 %{?with_system_zlib:BuildRequires:      zlib-devel}
214 Requires:       browser-plugins >= 2.0
215 Requires:       desktop-file-utils
216 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
217 # crashes if no fontconfig font present
218 Requires:       fonts-Type1-urw
219 Requires:       hicolor-icon-theme
220 Requires:       libevent >= 2.0.21
221 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
222 %{?with_system_libvpx:Requires: libvpx >= 1.4.0}
223 Requires:       lsb-release
224 %{?with_system_re2:Requires:    re2 >= 20130115-2}
225 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
226 Requires:       shared-mime-info
227 %{?with_system_sqlite:Requires: sqlite3(icu)}
228 Requires:       uname(release) >= 3.17
229 Requires:       xdg-utils >= 1.0.2-4
230 Requires:       xorg-lib-libX11 >= 1.4.99.1
231 Provides:       wwwbrowser
232 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
233 Obsoletes:      chromium-browser-inspector < 15.0.863.0
234 ExclusiveArch:  %{ix86} %{x8664} arm
235 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
236
237 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
238 # Note: these are for PLD Linux use ONLY.
239 # For your own distribution, please get your own set of keys.
240 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
241 %define         google_default_client_id 724288223830.apps.googleusercontent.com
242 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
243
244 %define         find_lang       sh find-lang.sh %{buildroot}
245
246 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
247 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
248
249 %ifarch %{ix86}
250 %define         target_arch ia32
251 %endif
252 %ifarch %{x8664}
253 %define         target_arch x64
254 %endif
255
256 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
257 %define         builddir        out/%{buildtype}
258
259 %if %{without debuginfo}
260 %define         _enable_debug_packages  0
261 %endif
262
263 %description
264 Chromium is an open-source browser project that aims to build a safer,
265 faster, and more stable way for all Internet users to experience the
266 web.
267
268 Chromium serves as a base for Google Chrome, which is Chromium
269 rebranded (name and logo) with very few additions such as usage
270 tracking and an auto-updater system.
271
272 %package l10n
273 Summary:        chromium-browser language packages
274 Group:          I18n
275 Requires:       %{name} = %{version}-%{release}
276 %if "%{_rpmversion}" >= "5"
277 BuildArch:      noarch
278 %endif
279
280 %description l10n
281 Chromium is an open-source browser project that aims to build a safer,
282 faster, and more stable way for all Internet users to experience the
283 web.
284
285 This package contains language packages for 50 languages:
286
287 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
288 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
289 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
290 zh-TW
291
292 %prep
293 %setup -qc
294 %if "%{?patchver}" != ""
295 cd chromium*-%{branch}.%{basever}
296 %patch0 -p1
297 cd ..
298 %endif
299 mv chromium*-%{branch}.%{basever}/* .
300
301 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
302 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
303 . ./chrome/VERSION
304 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
305 test "$chrome" = %{version}
306
307 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
308 test "$gyp_rev" = %{gyp_rev} || :
309
310 # add chromium and pld to useragent
311 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
312 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
313         -e 's/@BUILD_DIST_NAME@/PLD/g' \
314         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
315         < %{PATCH8} | %{__patch} -p1
316
317 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
318 ln -s %{SOURCE7} .
319
320 #%patch2 -p1 CHECK
321 %patch7 -p1
322 %patch15 -p2
323 %{!?with_libjpegturbo:%patch11 -p0}
324 %patch16 -p1
325 %patch28 -p1
326 %patch25 -p1
327 %{?with_nacl:%patch18 -p1}
328 %patch24 -p1
329 %patch26 -p2
330 %patch31 -p0
331 %patch32 -p1
332 %patch35 -p1
333 %patch36 -p1
334 %patch37 -p1
335 #%patch38 -p1 CHECK
336 %patch39 -p1
337 %patch40 -p1
338 %patch41 -p1
339 %patch42 -p1
340
341 # https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
342 touch chrome/test/data/webui/i18n_process_css_test.html
343
344 %{?with_dev:exit 0}
345
346 sh -x clean-source.sh \
347         %{!?with_nacl:nacl=0} \
348         %{!?with_system_libvpx:libvpx=0} \
349         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
350         %{!?with_system_mesa:mesa=0} \
351         %{!?with_system_protobuf:protobuf=0} \
352         %{!?with_system_re2:re2=0} \
353         %{!?with_system_snappy:snappy=0} \
354         %{!?with_system_sqlite:sqlite=0} \
355         %{!?with_system_v8:v8=0} \
356         %{!?with_system_libwebp:libwebp=0} \
357         %{!?with_system_zlib:zlib=0} \
358         %{!?with_system_ffmpeg:ffmpeg=0} \
359         %{nil}
360
361 %build
362 %if %{with nacl}
363 rm -rf native_client/toolchain/linux_x86_newlib
364 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
365 # Make symlinks for NaCL
366 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
367
368 cd native_client/toolchain/linux_x86_newlib
369 ln -s x86_64-nacl/bin bin
370 cd x86_64-nacl/bin
371 __cc='%{__cc}'
372 if [ "${__cc#ccache}" != "$__cc" ]; then
373         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
374         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
375         %{__sed} -i -e '1i#!/bin/sh' gcc g++
376         chmod +x gcc g++
377 else
378         ln -s %{_bindir}/x86_64-nacl-gcc gcc
379         ln -s %{_bindir}/x86_64-nacl-g++ g++
380 fi
381 ln -s gcc x86_64-nacl-gcc
382 ln -s g++ x86_64-nacl-g++
383 ln -s %{_bindir}/x86_64-nacl-ar .
384 ln -s %{_bindir}/x86_64-nacl-ar ar
385 ln -s %{_bindir}/x86_64-nacl-as as
386 ln -s %{_bindir}/x86_64-nacl-ranlib .
387 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
388 ln -s %{_bindir}/x86_64-nacl-strip .
389 ln -s %{_bindir}/x86_64-nacl-strip strip
390 ln -s %{_bindir}/x86_64-nacl-objcopy .
391 ln -s %{_prefix}/x86_64-nacl/lib ../lib
392 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
393 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
394 cd ../../../../..
395 fi
396 %endif
397
398 %if %{without system_ffmpeg}
399 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
400         # Re-configure bundled ffmpeg
401         cd third_party/ffmpeg
402         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
403                 --branding Chromium
404         chromium/scripts/copy_config.sh
405         chromium/scripts/generate_gyp.py
406         cd -
407 fi
408 %endif
409
410 third_party/libaddressinput/chromium/tools/update-strings.py
411
412 flags="
413         -Dtarget_arch=%{target_arch} \
414         -Dpython_arch=%{target_arch} \
415         -Dproprietary_codecs=1 \
416         -Dffmpeg_branding=Chromium \
417         -Dsystem_libdir=%{_lib} \
418         -Dpython_ver=%{py_ver} \
419 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
420         -Dno_strict_aliasing=1 -Dgcc_version=44 \
421 %endif
422         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
423         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
424         %{?with_shared_libs:-Dlibrary=shared_library} \
425         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
426         -Dinclude_tests__=0 \
427 %if %{with nacl}
428         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
429         -Ddisable_glibc_untar=1 \
430         -Ddisable_newlib_untar=1 \
431         -Ddisable_glibc=1 \
432         -Ddisable_pnacl=1 \
433         -Dbuild_pnacl_newlib=0 \
434 %else
435         -Ddisable_pnacl_untar=1 \
436         -Ddisable_nacl=1 \
437 %endif
438         %{!?with_sse2:-Ddisable_sse2=1} \
439         %{?with_selinux:-Dselinux=1} \
440         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
441         -Dlinux_link_libpci=1 \
442         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
443         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
444         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
445         -Dclang=0 \
446         -Dhost_clang=0 \
447         -Dlinux_use_bundled_binutils=0 \
448         -Dlinux_use_bundled_gold=0 \
449         -Dlinux_use_gold_flags=0 \
450         -Dlogging_like_official_build=1 \
451         -Dgoogle_api_key=%{google_api_key} \
452         -Dgoogle_default_client_id=%{google_default_client_id} \
453         -Dgoogle_default_client_secret=%{google_default_client_secret} \
454         %{gyp_with cups} \
455         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
456         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
457         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
458         %{gyp_with pulseaudio} \
459         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
460         %{gyp_with system_flac} \
461         %{gyp_with system_harfbuzz} \
462         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
463         %{gyp_with system_jsoncpp} \
464         %{gyp_with system_libexif} \
465         %{gyp_with system_libmtp} \
466         %{gyp_with system_libsrtp} \
467         %{gyp_with system_libusb} \
468         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
469         %{gyp_with system_libwebp} \
470         %{gyp_with system_libxnvctrl} \
471         %{gyp_with system_mesa} \
472         %{gyp_with system_minizip} \
473         %{gyp_with system_opus} \
474         %{gyp_with system_protobuf} \
475         %{gyp_with system_re2} \
476         %{gyp_with system_snappy} \
477         %{gyp_with system_speex} \
478         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
479         %{gyp_with system_v8} \
480         %{gyp_with system_yasm} \
481         %{gyp_with system_zlib} \
482         -Duse_system_bzip2=1 \
483         -Duse_system_expat=1 \
484         -Duse_system_libevent=1 \
485         -Duse_system_libjpeg=1 \
486         -Duse_system_libpng=1 \
487         -Duse_system_libxml=1 \
488         -Duse_system_libxslt=1 \
489         -Duse_system_nspr=1 \
490         -Duse_system_xdg_utils=1 \
491 "
492
493 build/linux/unbundle/replace_gyp_files.py $flags
494
495 %if %{with ninja}
496 chkfile=%{builddir}/build.ninja
497 %else
498 chkfile=Makefile
499 %endif
500 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
501 test -e $chkfile || \
502         CC="%{__cc}" \
503         CXX="%{__cxx}" \
504         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
505         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
506         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
507         CC_host="%{__cc}" \
508         CXX_host="%{__cxx}" \
509         LD_host="%{__cxx}" \
510 %{__python} build/gyp_chromium \
511         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
512         --depth=. \
513         build/all.gyp \
514         $flags
515
516 %if %{with ninja}
517 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
518 %else
519 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
520 %{__make} -r \
521         BUILDTYPE=%{buildtype} \
522         %{?with_verbose:V=1} \
523         CC.host="%{__cc}" \
524         CXX.host="%{__cxx}" \
525         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
526 %endif
527         chrome %{?with_sandboxing:chrome_sandbox} \
528         %{nil}
529
530 cd %{builddir}
531 MANWIDTH=80 man ./chrome.1 > man.out
532 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
537         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
538         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
539         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
540
541 %if %{without system_icu}
542 cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
543 %endif
544
545 cd %{builddir}
546 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
547 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
548 %{__sed} -i -e '
549         s,@libdir@,%{_libdir}/%{name},
550
551         /@OPTIONS@/ {
552                 r options.txt
553                 d
554         }
555 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
556 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
557 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
558 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
559 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
560 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
561 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
562 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
563 %if %{without system_ffmpeg} && 0
564 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
565 %endif
566 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
567 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
568
569 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
570
571 %if %{with nacl}
572 # Install Native Client files on platforms that support it.
573 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
574 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
575 %ifarch %{x8664}
576 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
577 %endif
578 %ifarch %{ix86}
579 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
580 %endif
581 %endif
582
583 cd -
584
585 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
586         size=${icon##*/product_logo_}
587         size=${size%.png}
588
589         # this will skip non-numeric (22_mono_invert, 22_mono)
590         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
591         test -d "$dir" || continue
592
593         install -d $RPM_BUILD_ROOT$dir
594         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
595 done
596
597 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
598 # http://code.google.com/p/chromium/issues/detail?id=24507
599 gecko-mediaplayer*.so
600 EOF
601
602 # find locales
603 %find_lang %{name}.lang
604 # always package en-US
605 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %pretrans
611 for d in locales resources; do
612         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
613                 install -d %{_datadir}/%{name}
614                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
615         fi
616 done
617 exit 0
618
619 %post
620 %update_icon_cache hicolor
621 %update_desktop_database
622 %update_browser_plugins
623
624 %postun
625 if [ "$1" = 0 ]; then
626         %update_icon_cache hicolor
627         %update_browser_plugins
628 fi
629
630 %files
631 %defattr(644,root,root,755)
632 %doc AUTHORS LICENSE
633 %{_browserpluginsconfdir}/browsers.d/%{name}.*
634 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
635 %dir %{_sysconfdir}/%{name}
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
637 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
638 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
639 %dir %{_sysconfdir}/%{name}/policies
640 %dir %{_sysconfdir}/%{name}/policies/managed
641 %attr(755,root,root) %{_bindir}/%{name}
642 %{_mandir}/man1/%{name}.1*
643 %{_desktopdir}/*.desktop
644 %{_iconsdir}/hicolor/*/apps/%{name}.png
645 %dir %{_libdir}/%{name}
646 %{_libdir}/%{name}/chrome*.pak
647 %{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
648 %{_libdir}/%{name}/content_resources.pak
649 %{_libdir}/%{name}/keyboard_resources.pak
650 %{_libdir}/%{name}/resources.pak
651 %{_libdir}/%{name}/natives_blob.bin
652 %{_libdir}/%{name}/snapshot_blob.bin
653 %{_libdir}/%{name}/locales
654 %{_libdir}/%{name}/resources
655
656 %dir %{_datadir}/%{name}
657 %dir %{_datadir}/%{name}/locales
658 %{_datadir}/%{name}/locales/en-US.pak
659 %dir %{_datadir}/%{name}/resources
660 %{_datadir}/%{name}/resources/inspector
661
662 %dir %{_libdir}/%{name}/plugins
663 %attr(755,root,root) %{_libdir}/%{name}/%{name}
664 # These unique permissions are intentional and necessary for the sandboxing
665 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
666
667 # ffmpeg libs
668 %if %{without system_ffmpeg} && 0
669 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
670 %endif
671
672 %if %{with nacl}
673 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
674 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
675 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
676 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
677 %endif
678
679 %files l10n -f %{name}.lang
680 %defattr(644,root,root,755)
This page took 0.104871 seconds and 3 git commands to generate.