]> git.pld-linux.org Git - packages/chromaprint.git/blob - chromaprint.spec
- updated to 1.5.0
[packages/chromaprint.git] / chromaprint.spec
1 #
2 # Conditional build:
3 %bcond_without  ffmpeg  # fpcalc build + libchromaprint using avfft
4 %bcond_with     fftw3   # libchromaprint using fftw3 instead of avfft
5 #
6 %if %{without ffmpeg}
7 %define with_fftw3      1
8 %endif
9 Summary:        Library implementing the AcoustID fingerprinting
10 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
11 Name:           chromaprint
12 Version:        1.5.0
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          Libraries
16 #Source0Download: https://github.com/acoustid/chromaprint/releases
17 Source0:        https://github.com/acoustid/chromaprint/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  e078aa024cf78788d55434a487b5978f
19 URL:            https://acoustid.org/chromaprint
20 BuildRequires:  cmake >= 3.3
21 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
22 %{?with_fftw3:BuildRequires:    fftw3-devel >= 3}
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  taglib-devel
25 Requires:       libchromaprint = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Chromaprint library is the core component of the AcoustID project.
30 It's a client-side library that implements a custom algorithm for
31 extracting fingerprints from raw audio sources.
32
33 The library exposes a simple C API and the Python language binding is
34 also available. The documentation for the C API can be found in the
35 main header file.
36
37 %description -l pl.UTF-8
38 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
39 biblioteka kliencka implementująca własny algorytm wydobywania
40 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
41
42 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
43 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
44 nagłówkowym.
45
46 %package -n libchromaprint
47 Summary:        Library implementing the AcoustID fingerprinting
48 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
49 Group:          Libraries
50
51 %description -n libchromaprint
52 Chromaprint library is the core component of the AcoustID project.
53 It's a client-side library that implements a custom algorithm for
54 extracting fingerprints from raw audio sources.
55
56 The library exposes a simple C API and the Python language binding
57 is also available. The documentation for the C API can be found in the
58 main header file.
59
60 %description -n libchromaprint -l pl.UTF-8
61 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
62 biblioteka kliencka implementująca własny algorytm wydobywania
63 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
64
65 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
66 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
67 nagłówkowym.
68
69 %package -n libchromaprint-devel
70 Summary:        Headers for developing programs that will use libchromaprint
71 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
72 Group:          Development/Libraries
73 Requires:       libchromaprint = %{version}-%{release}
74
75 %description -n libchromaprint-devel
76 This package contains the headers that programmers will need to
77 develop applications which will use libchromaprint.
78
79 %description -n libchromaprint-devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
81 tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
82
83 %prep
84 %setup -q -n %{name}-v%{version}
85
86 %build
87 install -d build
88 cd build
89 %cmake .. \
90         %{?with_ffmpeg:-DBUILD_TOOLS=ON} \
91         %{!?with_fftw3:-DWITH_AVFFT=ON} \
92         %{?with_fftw3:-DWITH_FFTW3=ON}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm  -rf $RPM_BUILD_ROOT
104
105 %post   -n libchromaprint -p /sbin/ldconfig
106 %postun -n libchromaprint -p /sbin/ldconfig
107
108 %if %{with ffmpeg}
109 %files
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_bindir}/fpcalc
112 %endif
113
114 %files -n libchromaprint
115 %defattr(644,root,root,755)
116 %doc NEWS.txt README.md
117 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
119
120 %files -n libchromaprint-devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libchromaprint.so
123 %{_includedir}/chromaprint.h
124 %{_pkgconfigdir}/libchromaprint.pc
This page took 0.042324 seconds and 4 git commands to generate.