]> git.pld-linux.org Git - packages/chromaprint.git/blob - chromaprint.spec
- updated to 1.3.1 (note: new soname)
[packages/chromaprint.git] / chromaprint.spec
1 #
2 # Conditional build:
3 %bcond_without  ffmpeg  # fpcalc build + libchromaprint using avfft
4 %bcond_with     fftw3   # libchromaprint using fftw3 instead of avfft
5 #
6 %if %{without ffmpeg}
7 %define with_fftw3      1
8 %endif
9 Summary:        Library implementing the AcoustID fingerprinting
10 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
11 Name:           chromaprint
12 Version:        1.3.1
13 Release:        1
14 License:        LGPL v2.1+
15 Group:          Libraries
16 Source0:        https://bitbucket.org/acoustid/chromaprint/downloads/%{name}-%{version}.tar.gz
17 # Source0-md5:  f3745ac10b4d4d992cabe743c4a3ed0f
18 URL:            https://acoustid.org/chromaprint
19 BuildRequires:  boost-devel
20 BuildRequires:  cmake >= 2.6
21 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
22 %{?with_fftw3:BuildRequires:    fftw3-devel >= 3}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  taglib-devel
25 Requires:       libchromaprint = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Chromaprint library is the core component of the AcoustID project.
30 It's a client-side library that implements a custom algorithm for
31 extracting fingerprints from raw audio sources.
32
33 The library exposes a simple C API and the Python language binding is
34 also available. The documentation for the C API can be found in the
35 main header file.
36
37 %description -l pl.UTF-8
38 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
39 biblioteka kliencka implementująca własny algorytm wydobywania
40 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
41
42 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
43 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
44 nagłówkowym.
45
46 %package -n libchromaprint
47 Summary:        Library implementing the AcoustID fingerprinting
48 Summary(pl.UTF-8):      Biblioteka implementująca odciski AcoustID
49 Group:          Libraries
50
51 %description -n libchromaprint
52 Chromaprint library is the core component of the AcoustID project.
53 It's a client-side library that implements a custom algorithm for
54 extracting fingerprints from raw audio sources.
55
56 The library exposes a simple C API and the Python language binding
57 is also available. The documentation for the C API can be found in the
58 main header file.
59
60 %description -n libchromaprint -l pl.UTF-8
61 Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
62 biblioteka kliencka implementująca własny algorytm wydobywania
63 odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
64
65 Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
66 Pythona. Dokumentację dla API C można znaleźć w głównym pliku
67 nagłówkowym.
68
69 %package -n libchromaprint-devel
70 Summary:        Headers for developing programs that will use libchromaprint
71 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
72 Group:          Development/Libraries
73 Requires:       libchromaprint = %{version}-%{release}
74
75 %description -n libchromaprint-devel
76 This package contains the headers that programmers will need to
77 develop applications which will use libchromaprint.
78
79 %description -n libchromaprint-devel -l pl.UTF-8
80 Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
81 tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
82
83 %prep
84 %setup -q
85
86 %build
87 %cmake . \
88         %{?with_ffmpeg:-DBUILD_EXAMPLES=ON} \
89         %{!?with_fftw3:-DWITH_AVFFT=ON} \
90         %{?with_fftw3:-DWITH_FFTW3=ON}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm  -rf $RPM_BUILD_ROOT
101
102 %post   -n libchromaprint -p /sbin/ldconfig
103 %postun -n libchromaprint -p /sbin/ldconfig
104
105 %if %{with ffmpeg}
106 %files
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/fpcalc
109 %endif
110
111 %files -n libchromaprint
112 %defattr(644,root,root,755)
113 %doc NEWS.txt README.md
114 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
116
117 %files -n libchromaprint-devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libchromaprint.so
120 %{_includedir}/chromaprint.h
121 %{_pkgconfigdir}/libchromaprint.pc
This page took 0.063295 seconds and 4 git commands to generate.