]> git.pld-linux.org Git - packages/chromaprint.git/blob - chromaprint.spec
- new, based on fedora spec
[packages/chromaprint.git] / chromaprint.spec
1 Summary:        Library implementing the AcoustID fingerprinting
2 Name:           chromaprint
3 Version:        0.5
4 Release:        1
5 License:        LGPL v2+
6 Group:          Libraries
7 URL:            http://www.acoustid.org/chromaprint/
8 Source0:        https://github.com/downloads/lalinsky/chromaprint/%{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  fftw3-devel >= 3
11 BuildRequires:  python
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Chromaprint library is the core component of the AcoustID project.
16 It's a client-side library that implements a custom algorithm for
17 extracting fingerprints from raw audio sources.
18
19 The library exposes a simple C API and the package also includes
20 bindings for the Python language. The documentation for the C API can
21 be found in the main header file.
22
23 %package -n libchromaprint
24 Summary:        Library implementing the AcoustID fingerprinting
25 Group:          Development/Libraries
26
27 %description -n libchromaprint
28 Chromaprint library is the core component of the AcoustID project.
29 It's a client-side library that implements a custom algorithm for
30 extracting fingerprints from raw audio sources.
31
32 The library exposes a simple C API and the package also includes
33 bindings for the Python language. The documentation for the C API can
34 be found in the main header file.
35
36 %package -n libchromaprint-devel
37 Summary:        Headers for developing programs that will use %{name}
38 Group:          Development/Libraries
39 Requires:       libchromaprint = %{version}-%{release}
40 Requires:       pkgconfig
41
42 %description -n libchromaprint-devel
43 This package contains the headers that programmers will need to
44 develop applications which will use %{name}.
45
46 %package -n python-chromaprint
47 Summary:        Python module for %{name}
48 License:        MIT
49 Group:          Development/Libraries
50 Requires:       libchromaprint = %{version}-%{release}
51
52 %description -n python-chromaprint
53 This package contains the python module to use %{name}.
54
55 %prep
56 %setup -q
57
58 %build
59 # examples require ffmpeg, so turn off examples
60 %cmake \
61         -DBUILD_EXAMPLES=off \
62         -DBUILD_TESTS=off
63
64 %{__make}
65
66 cd python
67 CFLAGS="%{rpmcflags}" \
68 %{__python} setup.py build
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 cd python
76 %{__python} setup.py install \
77         --skip-build \
78         --optimize=2 \
79         --root=$RPM_BUILD_ROOT
80
81 %clean
82 rm  -rf $RPM_BUILD_ROOT
83
84 %post   -n libchromaprint -p /sbin/ldconfig
85 %postun -n libchromaprint -p /sbin/ldconfig
86
87 %files -n libchromaprint
88 %defattr(644,root,root,755)
89 %doc CHANGES.txt COPYING.txt NEWS.txt README.txt
90 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
91 %ghost %{_libdir}/libchromaprint.so.0
92
93 %files -n libchromaprint-devel
94 %defattr(644,root,root,755)
95 %{_includedir}/chromaprint.h
96 %{_libdir}/libchromaprint.so
97 %{_pkgconfigdir}/libchromaprint.pc
98
99 # MIT licensed
100 %files -n python-chromaprint
101 %defattr(644,root,root,755)
102 %doc python/examples python/LICENSE
103 %{py_sitescriptdir}/chromaprint
104 %{py_sitescriptdir}/*.egg-info
This page took 0.076045 seconds and 4 git commands to generate.