]> git.pld-linux.org Git - packages/chef.git/commitdiff
use poldek as package manager :)
authorElan Ruusamäe <glen@delfi.ee>
Sat, 25 May 2013 16:22:02 +0000 (19:22 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 25 May 2013 16:22:24 +0000 (19:22 +0300)
chef.spec
platform-pld.patch

index 3b5ab8f3c07823ef2d5d43876b45df849f0fe591..d6a1ae5551003eb727ecb90c488eafc4d461d7e2 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -5,7 +5,7 @@
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       11.4.4
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       11.4.4
-Release:       1
+Release:       2
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
@@ -13,6 +13,8 @@ Source0:      http://rubygems.org/downloads/%{name}-%{version}.gem
 Source1:       %{name}.rb
 Patch0:                platform-pld.patch
 Patch1:                FHS.patch
 Source1:       %{name}.rb
 Patch0:                platform-pld.patch
 Patch1:                FHS.patch
+Patch2:                https://github.com/glensc/chef/compare/poldek.patch
+# Patch2-md5:  df7d8380da401ba9c37faeeb9250ae36
 URL:           http://wiki.opscode.com/display/chef
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
 URL:           http://wiki.opscode.com/display/chef
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
@@ -32,6 +34,7 @@ BuildRequires:        ruby-rspec-mocks >= 2.12.0
 #BuildRequires:        ruby-sdoc
 %endif
 Requires:      lsb-release
 #BuildRequires:        ruby-sdoc
 %endif
 Requires:      lsb-release
+Requires:      poldek >= 0.30
 Requires:      ruby-erubis
 Requires:      ruby-highline >= 1.6.9
 Requires:      ruby-json >= 1.4.4
 Requires:      ruby-erubis
 Requires:      ruby-highline >= 1.6.9
 Requires:      ruby-json >= 1.4.4
@@ -46,7 +49,6 @@ Requires:     ruby-ohai >= 0.6.0
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
-Requires:      yum >= 3.4.3-7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -58,6 +60,7 @@ configuration management to your entire infrastructure.
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 
 
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 
index c60bf64f84c7bbe84cb2e146cc9085d42ff8e81c..ccf734834d33932eaa44b671f7048993840193ae 100644 (file)
@@ -8,7 +8,7 @@
 +            :default => {
 +              :service => Chef::Provider::Service::Redhat,
 +              :cron => Chef::Provider::Cron,
 +            :default => {
 +              :service => Chef::Provider::Service::Redhat,
 +              :cron => Chef::Provider::Cron,
-+              :package => Chef::Provider::Package::Yum,
++              :package => Chef::Provider::Package::Poldek,
 +              :mdadm => Chef::Provider::Mdadm
 +            }
 +          },
 +              :mdadm => Chef::Provider::Mdadm
 +            }
 +          },
This page took 0.042369 seconds and 4 git commands to generate.