]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
3b5ab8f3c07823ef2d5d43876b45df849f0fe591
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.4.4
8 Release:        1
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  dc50aa6a4a7d4785a4c82fcaab3f9436
13 Source1:        %{name}.rb
14 Patch0:         platform-pld.patch
15 Patch1:         FHS.patch
16 URL:            http://wiki.opscode.com/display/chef
17 BuildRequires:  rpm-rubyprov
18 BuildRequires:  rpmbuild(macros) >= 1.656
19 BuildRequires:  sed >= 4.0
20 %if %{with tests}
21 BuildRequires:  ruby-abstract
22 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
23 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
24 BuildRequires:  ruby-rack
25 BuildRequires:  ruby-rake
26 #BuildRequires: ruby-rdoc
27 BuildRequires:  ruby-rest-client >= 1.0.4
28 BuildRequires:  ruby-rspec-core >= 2.12.0
29 BuildRequires:  ruby-rspec-expectations >= 2.12.0
30 BuildRequires:  ruby-rspec-mocks >= 2.12.0
31 #BuildRequires: ruby-rspec_junit_formatter
32 #BuildRequires: ruby-sdoc
33 %endif
34 Requires:       lsb-release
35 Requires:       ruby-erubis
36 Requires:       ruby-highline >= 1.6.9
37 Requires:       ruby-json >= 1.4.4
38 Requires:       ruby-mixlib-authentication >= 1.3.0
39 Requires:       ruby-mixlib-cli >= 1.3.0
40 Requires:       ruby-mixlib-config >= 1.1.2
41 Requires:       ruby-mixlib-log >= 1.3.0
42 Requires:       ruby-mixlib-shellout
43 Requires:       ruby-net-ssh >= 2.6
44 Requires:       ruby-net-ssh-multi >= 1.1.0
45 Requires:       ruby-ohai >= 0.6.0
46 Requires:       ruby-rest-client >= 1.0.4
47 Requires:       ruby-rubygems
48 Requires:       ruby-yajl >= 1.1
49 Requires:       yum >= 3.4.3-7
50 BuildArch:      noarch
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A systems integration framework, built to bring the benefits of
55 configuration management to your entire infrastructure.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61
62 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
63
64 %build
65 %if %{with tests}
66 rspec spec
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}} \
72         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
73 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
74 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
75
76 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md CONTRIBUTING.md
84 %dir %{_sysconfdir}/%{name}
85 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
86 %attr(755,root,root) %{_bindir}/chef-apply
87 %attr(755,root,root) %{_bindir}/chef-client
88 %attr(755,root,root) %{_bindir}/chef-shell
89 %attr(755,root,root) %{_bindir}/chef-solo
90 %attr(755,root,root) %{_bindir}/knife
91 %attr(755,root,root) %{_bindir}/shef
92 %{ruby_vendorlibdir}/chef.rb
93 %{ruby_vendorlibdir}/chef
94
95 %dir /var/lib/%{name}
96 %dir /var/cache/%{name}
This page took 0.664484 seconds and 2 git commands to generate.