]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
add /var/run/chef dir
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.6.0
8 Release:        6
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  3e8f67a5d11144573cf2c8d520ca39a6
13 Source1:        %{name}.rb
14 Source2:        %{name}.tmpfiles
15 Patch0:         platform-pld.patch
16 Patch1:         FHS.patch
17 Patch2:         https://github.com/glensc/chef/compare/poldek.patch
18 # Patch2-md5:   5a0fc35de33910b41cba4e87dcb4bf9a
19 Patch3:         https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
20 # Patch3-md5:   bfc884469fad7b5aa46341402be5fccd
21 URL:            http://wiki.opscode.com/display/chef
22 BuildRequires:  rpm-rubyprov
23 BuildRequires:  rpmbuild(macros) >= 1.656
24 BuildRequires:  sed >= 4.0
25 %if %{with tests}
26 BuildRequires:  ruby-abstract
27 BuildRequires:  ruby-chef-zero < 2
28 BuildRequires:  ruby-chef-zero >= 1.4
29 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
30 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
31 BuildRequires:  ruby-puma < 2
32 BuildRequires:  ruby-puma >= 1.6
33 BuildRequires:  ruby-rack
34 BuildRequires:  ruby-rake
35 #BuildRequires: ruby-rdoc
36 BuildRequires:  ruby-rest-client >= 1.0.4
37 BuildRequires:  ruby-rspec-core >= 2.12.0
38 BuildRequires:  ruby-rspec-expectations >= 2.12.0
39 BuildRequires:  ruby-rspec-mocks >= 2.12.0
40 #BuildRequires: ruby-rspec_junit_formatter
41 #BuildRequires: ruby-sdoc
42 %endif
43 Requires:       lsb-release
44 Requires:       poldek >= 0.30
45 Requires:       ruby >= 1:1.9.3.429-4
46 Requires:       ruby-erubis
47 Requires:       ruby-highline >= 1.6.9
48 Requires:       ruby-json >= 1.4.4
49 Requires:       ruby-mixlib-authentication >= 1.3.0
50 Requires:       ruby-mixlib-cli >= 1.3.0
51 Requires:       ruby-mixlib-config >= 1.1.2
52 Requires:       ruby-mixlib-log >= 1.3.0
53 Requires:       ruby-mixlib-shellout
54 Requires:       ruby-net-ssh >= 2.6
55 Requires:       ruby-net-ssh-multi >= 1.1.0
56 Requires:       ruby-ohai >= 0.6.0
57 Requires:       ruby-rest-client >= 1.0.4
58 Requires:       ruby-rubygems
59 Requires:       ruby-yajl >= 1.1
60 BuildArch:      noarch
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # do not generate python dependency, yum support is optional
64 %define         _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
65
66 %description
67 A systems integration framework, built to bring the benefits of
68 configuration management to your entire infrastructure.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76
77 grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
78
79 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
80
81 %build
82 %if %{with tests}
83 rspec spec
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
89         $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments}}}
90
91 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
92 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
93 cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
94
95 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
96 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README.md CONTRIBUTING.md
104 %dir %{_sysconfdir}/%{name}
105 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
106 %attr(755,root,root) %{_bindir}/chef-apply
107 %attr(755,root,root) %{_bindir}/chef-client
108 %attr(755,root,root) %{_bindir}/chef-service-manager
109 %attr(755,root,root) %{_bindir}/chef-shell
110 %attr(755,root,root) %{_bindir}/chef-solo
111 %attr(755,root,root) %{_bindir}/knife
112 %attr(755,root,root) %{_bindir}/shef
113 %{_mandir}/man1/chef-shell.1*
114 %{_mandir}/man1/knife-bootstrap.1*
115 %{_mandir}/man1/knife-client.1*
116 %{_mandir}/man1/knife-configure.1*
117 %{_mandir}/man1/knife-cookbook-site.1*
118 %{_mandir}/man1/knife-cookbook.1*
119 %{_mandir}/man1/knife-data-bag.1*
120 %{_mandir}/man1/knife-environment.1*
121 %{_mandir}/man1/knife-exec.1*
122 %{_mandir}/man1/knife-index.1*
123 %{_mandir}/man1/knife-node.1*
124 %{_mandir}/man1/knife-role.1*
125 %{_mandir}/man1/knife-search.1*
126 %{_mandir}/man1/knife-ssh.1*
127 %{_mandir}/man1/knife-status.1*
128 %{_mandir}/man1/knife-tag.1*
129 %{_mandir}/man1/knife.1*
130 %{_mandir}/man8/chef-client.8*
131 %{_mandir}/man8/chef-expander.8*
132 %{_mandir}/man8/chef-expanderctl.8*
133 %{_mandir}/man8/chef-server-webui.8*
134 %{_mandir}/man8/chef-server.8*
135 %{_mandir}/man8/chef-solo.8*
136 %{_mandir}/man8/chef-solr.8*
137 %{ruby_vendorlibdir}/chef.rb
138 %{ruby_vendorlibdir}/chef
139 %{systemdtmpfilesdir}/chef.conf
140
141 %dir /var/lib/%{name}
142 %dir /var/lib/%{name}/roles
143 %dir /var/lib/%{name}/data_bags
144 %dir /var/lib/%{name}/environments
145
146 %dir /var/cache/%{name}
147 %dir /var/run/%{name}
This page took 0.149374 seconds and 3 git commands to generate.