]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
update poldek patch: keep update indexes hash per options
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.6.0
8 Release:        3
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  3e8f67a5d11144573cf2c8d520ca39a6
13 Source1:        %{name}.rb
14 Patch0:         platform-pld.patch
15 Patch1:         FHS.patch
16 Patch2:         https://github.com/glensc/chef/compare/poldek.patch
17 # Patch2-md5:   5a0fc35de33910b41cba4e87dcb4bf9a
18 Patch3:         https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
19 # Patch3-md5:   bfc884469fad7b5aa46341402be5fccd
20 URL:            http://wiki.opscode.com/display/chef
21 BuildRequires:  rpm-rubyprov
22 BuildRequires:  rpmbuild(macros) >= 1.656
23 BuildRequires:  sed >= 4.0
24 %if %{with tests}
25 BuildRequires:  ruby-abstract
26 BuildRequires:  ruby-chef-zero < 2
27 BuildRequires:  ruby-chef-zero >= 1.4
28 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
29 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
30 BuildRequires:  ruby-puma < 2
31 BuildRequires:  ruby-puma >= 1.6
32 BuildRequires:  ruby-rack
33 BuildRequires:  ruby-rake
34 #BuildRequires: ruby-rdoc
35 BuildRequires:  ruby-rest-client >= 1.0.4
36 BuildRequires:  ruby-rspec-core >= 2.12.0
37 BuildRequires:  ruby-rspec-expectations >= 2.12.0
38 BuildRequires:  ruby-rspec-mocks >= 2.12.0
39 #BuildRequires: ruby-rspec_junit_formatter
40 #BuildRequires: ruby-sdoc
41 %endif
42 Requires:       lsb-release
43 Requires:       poldek >= 0.30
44 Requires:       ruby >= 1:1.9.3.429-4
45 Requires:       ruby-erubis
46 Requires:       ruby-highline >= 1.6.9
47 Requires:       ruby-json >= 1.4.4
48 Requires:       ruby-mixlib-authentication >= 1.3.0
49 Requires:       ruby-mixlib-cli >= 1.3.0
50 Requires:       ruby-mixlib-config >= 1.1.2
51 Requires:       ruby-mixlib-log >= 1.3.0
52 Requires:       ruby-mixlib-shellout
53 Requires:       ruby-net-ssh >= 2.6
54 Requires:       ruby-net-ssh-multi >= 1.1.0
55 Requires:       ruby-ohai >= 0.6.0
56 Requires:       ruby-rest-client >= 1.0.4
57 Requires:       ruby-rubygems
58 Requires:       ruby-yajl >= 1.1
59 BuildArch:      noarch
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 A systems integration framework, built to bring the benefits of
64 configuration management to your entire infrastructure.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %patch3 -p1
72
73 grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
74
75 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
76
77 %build
78 %if %{with tests}
79 rspec spec
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1} \
85         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
86 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
87 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
88 cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
89
90 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README.md CONTRIBUTING.md
98 %dir %{_sysconfdir}/%{name}
99 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
100 %attr(755,root,root) %{_bindir}/chef-apply
101 %attr(755,root,root) %{_bindir}/chef-client
102 %attr(755,root,root) %{_bindir}/chef-service-manager
103 %attr(755,root,root) %{_bindir}/chef-shell
104 %attr(755,root,root) %{_bindir}/chef-solo
105 %attr(755,root,root) %{_bindir}/knife
106 %attr(755,root,root) %{_bindir}/shef
107 %{_mandir}/man1/chef-shell.1*
108 %{_mandir}/man1/knife-bootstrap.1*
109 %{_mandir}/man1/knife-client.1*
110 %{_mandir}/man1/knife-configure.1*
111 %{_mandir}/man1/knife-cookbook-site.1*
112 %{_mandir}/man1/knife-cookbook.1*
113 %{_mandir}/man1/knife-data-bag.1*
114 %{_mandir}/man1/knife-environment.1*
115 %{_mandir}/man1/knife-exec.1*
116 %{_mandir}/man1/knife-index.1*
117 %{_mandir}/man1/knife-node.1*
118 %{_mandir}/man1/knife-role.1*
119 %{_mandir}/man1/knife-search.1*
120 %{_mandir}/man1/knife-ssh.1*
121 %{_mandir}/man1/knife-status.1*
122 %{_mandir}/man1/knife-tag.1*
123 %{_mandir}/man1/knife.1*
124 %{_mandir}/man8/chef-client.8*
125 %{_mandir}/man8/chef-expander.8*
126 %{_mandir}/man8/chef-expanderctl.8*
127 %{_mandir}/man8/chef-server-webui.8*
128 %{_mandir}/man8/chef-server.8*
129 %{_mandir}/man8/chef-solo.8*
130 %{_mandir}/man8/chef-solr.8*
131 %{ruby_vendorlibdir}/chef.rb
132 %{ruby_vendorlibdir}/chef
133
134 %dir /var/lib/%{name}
135 %dir /var/cache/%{name}
This page took 0.084429 seconds and 3 git commands to generate.