]> git.pld-linux.org Git - packages/chef.git/blame_incremental - chef.spec
Fix --no-ri patch
[packages/chef.git] / chef.spec
... / ...
CommitLineData
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
4# Conditional build:
5%bcond_with tests # build without tests
6
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
9Version: 11.16.4
10Release: 3
11License: Apache v2.0
12Group: Networking/Admin
13Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
14# Source0-md5: 084038481d60dc6311284e3a4ab22a2d
15Source2: %{name}.tmpfiles
16Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
17# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
18Patch0: platform-pld.patch
19Patch1: FHS.patch
20Patch2: poldek.patch
21Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
22# Patch3-md5: 8ff0fdfde6dc90018698775bf8f13062
23Patch4: optional-plist.patch
24URL: https://wiki.opscode.com/display/chef/
25BuildRequires: rpm-rubyprov
26BuildRequires: rpmbuild(macros) >= 1.673
27BuildRequires: sed >= 4.0
28%if %{with tests}
29BuildRequires: ruby-rack
30BuildRequires: ruby-rake
31BuildRequires: ruby-rspec-core < 2.15
32BuildRequires: ruby-rspec-core >= 2.14.0
33BuildRequires: ruby-rspec-expectations < 2.15
34BuildRequires: ruby-rspec-expectations >= 2.14.0
35BuildRequires: ruby-rspec-mocks < 2.15
36BuildRequires: ruby-rspec-mocks >= 2.14.0
37BuildRequires: ruby-rspec_junit_formatter
38%endif
39Requires: lsb-release
40Requires: poldek >= 0.30
41Requires: ruby >= 1:1.9.3.429-4
42Requires: ruby-diff-lcs < 2
43Requires: ruby-diff-lcs >= 1.2.4
44Requires: ruby-erubis < 3
45Requires: ruby-erubis >= 2.7.0-3
46Requires: ruby-ffi-yajl < 2
47Requires: ruby-ffi-yajl >= 1.0
48Requires: ruby-highline < 2
49Requires: ruby-highline >= 1.6.9
50Requires: ruby-json <= 1.8.3.1
51Requires: ruby-json >= 1.4.4
52Requires: ruby-mime-types < 2
53Requires: ruby-mime-types >= 1.16
54Requires: ruby-mixlib-authentication < 2
55Requires: ruby-mixlib-authentication >= 1.3.0-2
56Requires: ruby-mixlib-cli < 2
57Requires: ruby-mixlib-cli >= 1.4
58Requires: ruby-mixlib-config < 3
59Requires: ruby-mixlib-config >= 2.0
60Requires: ruby-mixlib-log < 2
61Requires: ruby-mixlib-log >= 1.6.0-2
62Requires: ruby-mixlib-shellout >= 1.4
63Requires: ruby-net-ssh < 3
64Requires: ruby-net-ssh >= 2.6
65Requires: ruby-net-ssh-multi < 2
66Requires: ruby-net-ssh-multi >= 1.1
67Requires: ruby-ohai < 8
68Requires: ruby-ohai >= 6.0
69Requires: ruby-rest-client >= 1.0.4
70Requires: ruby-rubygems
71Requires: ruby-yajl < 2
72Requires: ruby-yajl >= 1.1
73Suggests: chef-zero >= 2.1.4
74Suggests: ruby-plist >= 3.1.0
75BuildArch: noarch
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78# do not generate python dependency, yum support is optional
79%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
80
81%description
82A systems integration framework, built to bring the benefits of
83configuration management to your entire infrastructure.
84
85%package -n bash-completion-knife
86Summary: bash-completion for knife
87Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
88Group: Applications/Shells
89Requires: %{name} >= 0.10
90Requires: bash-completion >= 2.0
91
92%description -n bash-completion-knife
93This package provides bash-completion for knife.
94
95%description -n bash-completion-knife -l pl.UTF-8
96Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
97
98%package -n knife
99Summary: knife - Chef Server API client utility
100Group: Networking/Admin
101Requires: %{name} = %{version}-%{release}
102
103%description -n knife
104Knife is a command-line utility used to manage data on a Chef server
105through the HTTP(S) API. Knife is organized into groups of subcommands
106centered around the various object types in Chef. Each category of
107subcommand is documented in its own manual page.
108
109%prep
110%setup -q
111gzip -d metadata
112%patch0 -p1
113%patch1 -p1
114%patch2 -p1
115%patch3 -p1
116%patch4 -p1
117
118%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
119
120# cleanup backups after patching
121find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
122
123grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
124
125%build
126%if %{with tests}
127rspec spec
128%endif
129
130%install
131rm -rf $RPM_BUILD_ROOT
132install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
133 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
134 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
135
136cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
137cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
138cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
139%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
140
141cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
142
143install -d $RPM_BUILD_ROOT%{bash_compdir}
144cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%files
150%defattr(644,root,root,755)
151%doc README.md CONTRIBUTING.md
152%dir %{_sysconfdir}/%{name}
153%attr(755,root,root) %{_bindir}/chef-apply
154%attr(755,root,root) %{_bindir}/chef-client
155%attr(755,root,root) %{_bindir}/chef-service-manager
156%attr(755,root,root) %{_bindir}/chef-shell
157%attr(755,root,root) %{_bindir}/chef-solo
158%attr(755,root,root) %{_bindir}/shef
159%{_mandir}/man1/chef-shell.1*
160%{_mandir}/man8/chef-client.8*
161%{_mandir}/man8/chef-solo.8*
162%{ruby_vendorlibdir}/chef.rb
163%{ruby_vendorlibdir}/chef
164%exclude %{ruby_vendorlibdir}/chef/knife
165%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
166%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
167%exclude %{ruby_vendorlibdir}/chef/knife.rb
168%{systemdtmpfilesdir}/chef.conf
169
170%dir /var/lib/%{name}
171%dir /var/lib/%{name}/roles
172%dir /var/lib/%{name}/data_bags
173%dir /var/lib/%{name}/environments
174%dir %attr(750,root,root) /var/lib/%{name}/backup
175
176%dir /var/cache/%{name}
177%dir /var/run/%{name}
178
179%files -n knife
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_bindir}/knife
182%{ruby_vendorlibdir}/chef/knife.rb
183%{ruby_vendorlibdir}/chef/knife
184%{ruby_vendorlibdir}/chef/application/knife.rb
185%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
186%{_mandir}/man1/knife-bootstrap.1*
187%{_mandir}/man1/knife-client.1*
188%{_mandir}/man1/knife-configure.1*
189%{_mandir}/man1/knife-cookbook-site.1*
190%{_mandir}/man1/knife-cookbook.1*
191%{_mandir}/man1/knife-data-bag.1*
192%{_mandir}/man1/knife-delete.1*
193%{_mandir}/man1/knife-deps.1*
194%{_mandir}/man1/knife-diff.1*
195%{_mandir}/man1/knife-download.1*
196%{_mandir}/man1/knife-edit.1*
197%{_mandir}/man1/knife-environment.1*
198%{_mandir}/man1/knife-exec.1*
199%{_mandir}/man1/knife-index-rebuild.1*
200%{_mandir}/man1/knife-list.1*
201%{_mandir}/man1/knife-node.1*
202%{_mandir}/man1/knife-raw.1*
203%{_mandir}/man1/knife-recipe-list.1*
204%{_mandir}/man1/knife-role.1*
205%{_mandir}/man1/knife-search.1*
206%{_mandir}/man1/knife-serve.1*
207%{_mandir}/man1/knife-show.1*
208%{_mandir}/man1/knife-ssh.1*
209%{_mandir}/man1/knife-ssl-check.1*
210%{_mandir}/man1/knife-ssl-fetch.1*
211%{_mandir}/man1/knife-status.1*
212%{_mandir}/man1/knife-tag.1*
213%{_mandir}/man1/knife-upload.1*
214%{_mandir}/man1/knife-user.1*
215%{_mandir}/man1/knife-xargs.1*
216%{_mandir}/man1/knife.1*
217
218%files -n bash-completion-knife
219%defattr(644,root,root,755)
220%{bash_compdir}/knife
This page took 0.148961 seconds and 4 git commands to generate.