]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- added info patch
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl.UTF-8):      Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  30143c7974b547a12a7da47809a90951
10 Patch0:         %{name}-info.patch
11 URL:            http://check.sourceforge.net/
12 BuildRequires:  libtool
13 BuildRequires:  texinfo >= 4.2
14 Requires(post,postun):  /sbin/ldconfig
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Check is a unit test framework for C. It features a simple interface
19 for defining unit tests, putting little in the way of the developer.
20 Tests are run in a separate address space, so Check can catch both
21 assertion failures and code errors that cause segmentation faults or
22 other signals. The output from unit tests can be used within source
23 code editors and IDEs.
24
25 %description -l pl.UTF-8
26 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
27 definiowania testów jednostkowych, nie przeszkadzający zbytnio
28 programiście. Testy są uruchamiane w wydzielonej przestrzeni
29 adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
30 zapewnień (assert), jak i błędy w kodzie powodujące naruszenie
31 ochrony pamięci lub inne sygnały. Wyjście z testów jednostkowych może
32 być używane z poziomu edytorów kodu źródłowego i IDE.
33
34 %package static
35 Summary:        Static check library
36 Summary(pl.UTF-8):      Biblioteka statyczna check
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description static
41 Static check library.
42
43 %description static -l pl.UTF-8
44 Biblioteka statyczna check.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 CFLAGS="%{rpmcflags} -fPIC"
52 %configure
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         exampledir=%{_examplesdir}/%{name}-%{version} \
60         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
61         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
65 rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 /sbin/ldconfig
72 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
73
74 %postun
75 /sbin/ldconfig
76 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
81 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
82 %attr(755,root,root) %{_libdir}/libcheck.so
83 %{_includedir}/check.h
84 %{_aclocaldir}/check.m4
85 %{_pkgconfigdir}/check.pc
86 %{_infodir}/check.info*
87 %{_examplesdir}/%{name}-%{version}
88
89 %files static
90 %defattr(644,root,root,755)
91 %{_libdir}/libcheck.a
This page took 0.086294 seconds and 4 git commands to generate.