]> git.pld-linux.org Git - packages/check.git/blame - check.spec
- added info patch
[packages/check.git] / check.spec
CommitLineData
0044121d 1Summary: Check - unit testing framework for C
39525af9 2Summary(pl.UTF-8): Check - szkielet testów jednostkowych dla C
0044121d 3Name: check
a3ffaac2 4Version: 0.9.5
f3f03e56 5Release: 1
0044121d
JB
6License: LGPL v2.1+
7Group: Development/Libraries
8Source0: http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
a3ffaac2 9# Source0-md5: 30143c7974b547a12a7da47809a90951
5a1f9cd0 10Patch0: %{name}-info.patch
0044121d 11URL: http://check.sourceforge.net/
f3f03e56
SS
12BuildRequires: libtool
13BuildRequires: texinfo >= 4.2
78e36e09 14Requires(post,postun): /sbin/ldconfig
0044121d
JB
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Check is a unit test framework for C. It features a simple interface
19for defining unit tests, putting little in the way of the developer.
20Tests are run in a separate address space, so Check can catch both
21assertion failures and code errors that cause segmentation faults or
22other signals. The output from unit tests can be used within source
23code editors and IDEs.
24
ff212a42
JR
25%description -l pl.UTF-8
26Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
27definiowania testów jednostkowych, nie przeszkadzający zbytnio
28programiście. Testy są uruchamiane w wydzielonej przestrzeni
29adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
30zapewnień (assert), jak i błędy w kodzie powodujące naruszenie
31ochrony pamięci lub inne sygnały. Wyjście z testów jednostkowych może
32być używane z poziomu edytorów kodu źródłowego i IDE.
0044121d 33
1b5e9f8c
JB
34%package static
35Summary: Static check library
36Summary(pl.UTF-8): Biblioteka statyczna check
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description static
41Static check library.
42
43%description static -l pl.UTF-8
44Biblioteka statyczna check.
45
0044121d
JB
46%prep
47%setup -q
5a1f9cd0 48%patch0 -p1
0044121d
JB
49
50%build
5a1f9cd0
JB
51CFLAGS="%{rpmcflags} -fPIC"
52%configure
53%{__make}
0044121d
JB
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} install \
1bc5c11c
SS
59 exampledir=%{_examplesdir}/%{name}-%{version} \
60 examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
61 exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
0044121d
JB
62 DESTDIR=$RPM_BUILD_ROOT
63
78e36e09 64rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
f3f03e56
SS
65rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
66
0044121d
JB
67%clean
68rm -rf $RPM_BUILD_ROOT
69
f3f03e56 70%post
78e36e09 71/sbin/ldconfig
f3f03e56
SS
72[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
73
74%postun
78e36e09 75/sbin/ldconfig
f3f03e56
SS
76[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
77
0044121d
JB
78%files
79%defattr(644,root,root,755)
2a5d9e97 80%doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
78e36e09
JB
81%attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
82%attr(755,root,root) %{_libdir}/libcheck.so
78e36e09
JB
83%{_includedir}/check.h
84%{_aclocaldir}/check.m4
f3f03e56 85%{_pkgconfigdir}/check.pc
f3f03e56 86%{_infodir}/check.info*
78e36e09 87%{_examplesdir}/%{name}-%{version}
1b5e9f8c
JB
88
89%files static
90%defattr(644,root,root,755)
91%{_libdir}/libcheck.a
This page took 0.084563 seconds and 4 git commands to generate.