]> git.pld-linux.org Git - packages/check.git/blame - check.spec
- tabs in preamble
[packages/check.git] / check.spec
CommitLineData
0044121d 1Summary: Check - unit testing framework for C
39525af9 2Summary(pl.UTF-8): Check - szkielet testów jednostkowych dla C
0044121d 3Name: check
a3ffaac2 4Version: 0.9.5
f3f03e56 5Release: 1
0044121d
JB
6License: LGPL v2.1+
7Group: Development/Libraries
8Source0: http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
a3ffaac2 9# Source0-md5: 30143c7974b547a12a7da47809a90951
0044121d 10URL: http://check.sourceforge.net/
f3f03e56
SS
11BuildRequires: libtool
12BuildRequires: texinfo >= 4.2
78e36e09 13Requires(post,postun): /sbin/ldconfig
0044121d
JB
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Check is a unit test framework for C. It features a simple interface
18for defining unit tests, putting little in the way of the developer.
19Tests are run in a separate address space, so Check can catch both
20assertion failures and code errors that cause segmentation faults or
21other signals. The output from unit tests can be used within source
22code editors and IDEs.
23
ff212a42
JR
24%description -l pl.UTF-8
25Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
26definiowania testów jednostkowych, nie przeszkadzający zbytnio
27programiście. Testy są uruchamiane w wydzielonej przestrzeni
28adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
29zapewnień (assert), jak i błędy w kodzie powodujące naruszenie
30ochrony pamięci lub inne sygnały. Wyjście z testów jednostkowych może
31być używane z poziomu edytorów kodu źródłowego i IDE.
0044121d
JB
32
33%prep
34%setup -q
35
36%build
37%configure2_13
996df3b4 38%{__make} \
78e36e09 39 CFLAGS="%{rpmcflags} -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
0044121d
JB
40
41%install
42rm -rf $RPM_BUILD_ROOT
43
44%{__make} install \
1bc5c11c
SS
45 exampledir=%{_examplesdir}/%{name}-%{version} \
46 examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
47 exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
0044121d
JB
48 DESTDIR=$RPM_BUILD_ROOT
49
78e36e09 50rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
f3f03e56
SS
51rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
52
0044121d
JB
53%clean
54rm -rf $RPM_BUILD_ROOT
55
f3f03e56 56%post
78e36e09 57/sbin/ldconfig
f3f03e56
SS
58[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
59
60%postun
78e36e09 61/sbin/ldconfig
f3f03e56
SS
62[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
63
0044121d
JB
64%files
65%defattr(644,root,root,755)
2a5d9e97 66%doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
78e36e09
JB
67%attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
68%attr(755,root,root) %{_libdir}/libcheck.so
69# -static ?
f3f03e56 70%{_libdir}/libcheck.a
78e36e09
JB
71%{_includedir}/check.h
72%{_aclocaldir}/check.m4
f3f03e56 73%{_pkgconfigdir}/check.pc
f3f03e56 74%{_infodir}/check.info*
78e36e09 75%{_examplesdir}/%{name}-%{version}
This page took 0.073426 seconds and 4 git commands to generate.