]> git.pld-linux.org Git - packages/check.git/blame - check.spec
- release 2
[packages/check.git] / check.spec
CommitLineData
0044121d 1Summary: Check - unit testing framework for C
39525af9 2Summary(pl.UTF-8): Check - szkielet testów jednostkowych dla C
0044121d 3Name: check
a661bf6c 4Version: 0.9.8
ad7c7a3c 5Release: 2
0044121d 6License: LGPL v2.1+
28297c4f
ER
7Group: Libraries
8Source0: http://downloads.sourceforge.net/check/%{name}-%{version}.tar.gz
a661bf6c 9# Source0-md5: 5d75e9a6027cde79d2c339ef261e7470
5a1f9cd0 10Patch0: %{name}-info.patch
0044121d 11URL: http://check.sourceforge.net/
8c92c757 12# aclocal required for %{_aclocaldir}
13BuildRequires: automake
f3f03e56
SS
14BuildRequires: libtool
15BuildRequires: texinfo >= 4.2
0044121d
JB
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
4713b48d 18%undefine __cxx
19
0044121d
JB
20%description
21Check is a unit test framework for C. It features a simple interface
22for defining unit tests, putting little in the way of the developer.
23Tests are run in a separate address space, so Check can catch both
24assertion failures and code errors that cause segmentation faults or
25other signals. The output from unit tests can be used within source
26code editors and IDEs.
27
ff212a42
JR
28%description -l pl.UTF-8
29Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
30definiowania testów jednostkowych, nie przeszkadzający zbytnio
31programiście. Testy są uruchamiane w wydzielonej przestrzeni
32adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
28297c4f
ER
33zapewnień (assert), jak i błędy w kodzie powodujące naruszenie ochrony
34pamięci lub inne sygnały. Wyjście z testów jednostkowych może być
35używane z poziomu edytorów kodu źródłowego i IDE.
36
37%package devel
38Summary: Libraries and headers for developing programs with check
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Libraries and headers for developing programs with check
0044121d 44
1b5e9f8c
JB
45%package static
46Summary: Static check library
47Summary(pl.UTF-8): Biblioteka statyczna check
48Group: Development/Libraries
28297c4f 49Requires: %{name}-devel = %{version}-%{release}
1b5e9f8c
JB
50
51%description static
52Static check library.
53
54%description static -l pl.UTF-8
55Biblioteka statyczna check.
56
0044121d
JB
57%prep
58%setup -q
5a1f9cd0 59%patch0 -p1
0044121d
JB
60
61%build
5a1f9cd0
JB
62CFLAGS="%{rpmcflags} -fPIC"
63%configure
64%{__make}
0044121d
JB
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%{__make} install \
1bc5c11c
SS
70 exampledir=%{_examplesdir}/%{name}-%{version} \
71 examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
72 exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
0044121d
JB
73 DESTDIR=$RPM_BUILD_ROOT
74
78e36e09 75rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
f3f03e56 76rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
a661bf6c 77rm -f $RPM_BUILD_ROOT%{_infodir}/dir
f3f03e56 78
0044121d
JB
79%clean
80rm -rf $RPM_BUILD_ROOT
81
a661bf6c
ER
82%post -p /sbin/ldconfig
83%postun -p /sbin/ldconfig
f3f03e56 84
a661bf6c
ER
85%post devel -p /sbin/postshell
86-/usr/sbin/fix-info-dir -c %{_infodir}
87
88%postun devel -p /sbin/postshell
89-/usr/sbin/fix-info-dir -c %{_infodir}
f3f03e56 90
0044121d
JB
91%files
92%defattr(644,root,root,755)
2a5d9e97 93%doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
78e36e09 94%attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
a661bf6c 95%attr(755,root,root) %ghost %{_libdir}/libcheck.so.0
28297c4f
ER
96
97%files devel
98%defattr(644,root,root,755)
78e36e09 99%attr(755,root,root) %{_libdir}/libcheck.so
78e36e09
JB
100%{_includedir}/check.h
101%{_aclocaldir}/check.m4
f3f03e56 102%{_pkgconfigdir}/check.pc
f3f03e56 103%{_infodir}/check.info*
78e36e09 104%{_examplesdir}/%{name}-%{version}
1b5e9f8c
JB
105
106%files static
107%defattr(644,root,root,755)
108%{_libdir}/libcheck.a
This page took 0.044209 seconds and 4 git commands to generate.