]> git.pld-linux.org Git - packages/charles.git/blob - charles.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/charles.git] / charles.spec
1 # I have no access to full version, so I'm packaging trial version only.
2 # If you have full tarball, add with(out?)_trial bcond
3
4 # Conditional build:
5 %bcond_without  trial           # build from full tarball
6
7 %define         rel     0.4
8 %include        /usr/lib/rpm/macros.java
9 Summary:        Web debugging proxy application
10 Name:           charles
11 Version:        3.5.2
12 Release:        %{rel}
13 License:        Proprietary, not distributable
14 Group:          Networking/Daemons
15 Source0:        http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
16 # NoSource0-md5:        49498a331ae53fc1bb02c21d8bcd3be9
17 NoSource:       0
18 Source1:        %{name}.sh
19 URL:            http://www.charlesproxy.com/
20 BuildRequires:  rpm-javaprov
21 BuildRequires:  rpmbuild(macros) >= 1.300
22 Requires:       java(jaf)
23 Requires:       java-oro >= 1.4
24 Requires:       jpackage-utils
25 Requires:       jre-X11 >= 1.4
26 ExclusiveArch:  i586 i686 pentium3 pentium4 athlon %{x8664}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # already stripped
30 %define         _enable_debug_packages  0
31
32 %description
33 Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
34 developer to view all of the HTTP and SSL / HTTPS traffic between
35 their machine and the Internet. This includes requests, responses and
36 the HTTP headers (which contain the cookies and caching information).
37
38 %prep
39 %setup -q -n %{name}
40
41 install -p %{SOURCE1} .
42 %if "%{_lib}" != "lib"
43 %{__sed} -i -e 's,/usr/lib,%{_libdir},' %{name}.sh
44 %endif
45
46 rm lib/jakarta-oro-2.0.8.jar
47 rm lib/activation.jar
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
52
53 cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
54 %ifarch %{ix86}
55 install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
56 %endif
57 install -p %{name}.sh $RPM_BUILD_ROOT%{_bindir}/%{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/%{name}
65 %{_javadir}/%{name}
66 %ifarch %{ix86}
67 %dir %{_libdir}/%{name}
68 %attr(755,root,root) %{_libdir}/%{name}/libjdic.so
69 %endif
This page took 0.071711 seconds and 3 git commands to generate.