]> git.pld-linux.org Git - packages/charles.git/blame - charles.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/charles.git] / charles.spec
CommitLineData
5f2b8dd5
ER
1# I have no access to full version, so I'm packaging trial version only.
2# If you have full tarball, add with(out?)_trial bcond
3
4# Conditional build:
5%bcond_without trial # build from full tarball
6
756aee12 7%define rel 0.4
d211014a 8Summary: Web debugging proxy application
9Name: charles
e83da80c 10Version: 3.5.2
0617de2c 11Release: %{rel}
d211014a 12License: Proprietary, not distributable
fd314aaf 13Group: Networking/Daemons
3973bcf4 14Source0: http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
e83da80c 15# NoSource0-md5: 49498a331ae53fc1bb02c21d8bcd3be9
d211014a 16NoSource: 0
17Source1: %{name}.sh
18URL: http://www.charlesproxy.com/
d211014a 19BuildRequires: rpm-javaprov
20BuildRequires: rpmbuild(macros) >= 1.300
3973bcf4
ER
21Requires: java(jaf)
22Requires: java-oro >= 1.4
d211014a 23Requires: jpackage-utils
3973bcf4 24Requires: jre-X11 >= 1.4
5f50a8f4 25ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
d211014a 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
fd314aaf
ER
28# already stripped
29%define _enable_debug_packages 0
30
d211014a 31%description
32Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
33developer to view all of the HTTP and SSL / HTTPS traffic between
34their machine and the Internet. This includes requests, responses and
35the HTTP headers (which contain the cookies and caching information).
36
37%prep
38%setup -q -n %{name}
39
756aee12
ER
40install -p %{SOURCE1} .
41%if "%{_lib}" != "lib"
42%{__sed} -i -e 's,/usr/lib,%{_libdir},' %{name}.sh
43%endif
44
3973bcf4
ER
45rm lib/jakarta-oro-2.0.8.jar
46rm lib/activation.jar
47
d211014a 48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
5f50a8f4 51
fd314aaf 52cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
5f50a8f4 53%ifarch %{ix86}
fd314aaf 54install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
5f50a8f4 55%endif
756aee12 56install -p %{name}.sh $RPM_BUILD_ROOT%{_bindir}/%{name}
d211014a 57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
d211014a 63%attr(755,root,root) %{_bindir}/%{name}
fd314aaf 64%{_javadir}/%{name}
5f50a8f4 65%ifarch %{ix86}
fd314aaf
ER
66%dir %{_libdir}/%{name}
67%attr(755,root,root) %{_libdir}/%{name}/libjdic.so
5f50a8f4 68%endif
This page took 0.071222 seconds and 4 git commands to generate.