]> git.pld-linux.org Git - packages/cgit.git/blob - cgit.spec
- updated to 0.9.1
[packages/cgit.git] / cgit.spec
1 #
2 # Conditional build
3 %bcond_with     verbose         # verbose build (V=1)
4 #
5 Summary:        cgit - a fast webinterface to git
6 Summary(pl.UTF-8):      cgit - szybki interfejs WWW do gita
7 Name:           cgit
8 Version:        0.9.1
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://hjemli.net/git/cgit/snapshot/%{name}-%{version}.tar.bz2
13 # Source0-md5:  78403e6a15a61bb06cb2b8447079139a
14 Source1:        %{name}.conf
15 Source2:        %{name}-repo.conf
16 Source3:        %{name}-apache.conf
17 Source4:        %{name}-httpd.conf
18 Patch0:         %{name}-system-git.patch
19 Patch1:         %{name}-override-cflags.patch
20 Patch2:         notes.patch
21 Patch100:       git.patch
22 URL:            http://hjemli.net/git/cgit
23 BuildRequires:  git-core-devel >= 1.8.0
24 BuildRequires:  openssl-devel
25 BuildConflicts: zlib-devel = 1.2.5-1
26 Requires:       webapps
27 Conflicts:      apache-base < 2.4.0-1
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         webapp          cgit
31 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
32 %define         appdir          %{_datadir}/%{webapp}
33 %define         cgibindir       %{_prefix}/lib/cgi-bin
34
35 %description
36 Cgit is a CGI application implemented in C: it's basically (yet)
37 another git command, used to generate HTML. Cgit is not forking: all
38 git operations are performed by linking with libgit.a. It uses a
39 built-in cache: the generated HTML is stored on disk for the benefit
40 of later requests.
41
42 %description -l pl.UTF-8
43 Cgit to napisana w C aplikacja CGI - zasadniczo jest to (kolejny)
44 interfejs do gita, generujący kod HTML. Cgit jest aplikacją
45 nieforkującą - wszystkie operacje na repozytoriach wykonywane są z
46 użyciem biblioteki. Aplikacja ta korzysta z cache - wygenerowany kod
47 HTML zapisany jest na dysku dla kolejnych żądań.
48
49 %prep
50 %setup -q
51 %patch100 -p1
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55
56 %build
57 %{__make} \
58         CC="%{__cc}" \
59         CFLAGS="%{rpmcflags} -I/usr/include/git-core" \
60         LDFLAGS="%{rpmldflags}" \
61         LIBDIR=%{_libdir} \
62         CGIT_CONFIG="%{webappdir}/%{webapp}.conf" \
63         CGIT_SCRIPT_PATH="%{cgibindir}" \
64         %{?with_verbose:V=1}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         LIBDIR=%{_libdir} \
72         CGIT_CONFIG="%{webappdir}/%{webapp.conf}" \
73         CGIT_DATA_PATH="%{appdir}" \
74         CGIT_SCRIPT_PATH="%{cgibindir}" \
75         %{?with_verbose:V=1}
76
77 # cache
78 install -d $RPM_BUILD_ROOT/var/cache/cgit
79
80 # webapp stuff
81 install -d $RPM_BUILD_ROOT%{webappdir}
82 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}
83 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}
84 install %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/apache.conf
85 install %{SOURCE4} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %triggerin -- apache1 < 1.3.37-3, apache1-base
91 %webapp_register apache %{webapp}
92
93 %triggerun -- apache1 < 1.3.37-3, apache1-base
94 %webapp_unregister apache %{webapp}
95
96 %triggerin -- apache-base
97 %webapp_register httpd %{webapp}
98
99 %triggerun -- apache-base
100 %webapp_unregister httpd %{webapp}
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README cgitrc.5.txt
105 %dir %{webappdir}
106 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit.conf
107 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/cgit-repo.conf
108 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
109 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
110 %attr(755,root,root) %{cgibindir}/cgit.cgi
111 %attr(770,root,http) /var/cache/cgit
112 %{appdir}
113 %dir %{_prefix}/lib/cgit
114 %dir %{_prefix}/lib/cgit/filters
115 %attr(755,root,root) %{_prefix}/lib/cgit/filters/commit-links.sh
116 %attr(755,root,root) %{_prefix}/lib/cgit/filters/syntax-highlighting.sh
This page took 0.052725 seconds and 3 git commands to generate.