]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
- use lua51 not lua50
[packages/celestia.git] / celestia.spec
1
2 %bcond_without  kde             # KDE UI as the default one
3 %bcond_with     gtk             # use gtk2 UI instead
4 %bcond_with     gnome           # use libgnome2 UI instead
5 %bcond_with     glut            # use glut UI instead
6
7 %bcond_without  theora          # without theora support
8
9 %if %{with gtk} || %{with gnome} || %{with glut}
10 %undefine       with_kde
11 %endif
12
13 Summary:        A real-time visual space simulation
14 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
15 Name:           celestia
16 Version:        1.5.1
17 Release:        1
18 License:        GPL
19 Group:          X11/Applications/Science
20 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
21 # Source0-md5:  df6854a2cf62d2e96612398c13b68fd2
22 Patch0:         %{name}-as-needed.patch
23 Patch1:         %{name}-gcc43.patch
24 Patch2:         %{name}-extras.patch
25 Patch3:         %{name}-desktop.patch
26 Patch4:         %{name}-lua51.patch
27 URL:            http://www.shatters.net/celestia/
28 BuildRequires:  OpenGL-GLU-devel
29 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %if %{with gtk} || %{with gnome}
33 BuildRequires:  cairo-devel
34 BuildRequires:  gtk+2-devel >= 2.6
35 BuildRequires:  gtkglext-devel
36 %endif
37 BuildRequires:  gettext-devel
38 %{?with_kde:BuildRequires:      kdelibs-devel}
39 %{?with_gnome:BuildRequires:    libgnomeui-devel}
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libpng-devel
42 BuildRequires:  libstdc++-devel
43 %{?with_theora:BuildRequires:   libtheora-devel}
44 BuildRequires:  libtool
45 BuildRequires:  lua51-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  sed >= 4.0
48 Requires:       OpenGL
49 # celestia < 1.4 original packages
50 Obsoletes:      celestia-extrasolar
51 Obsoletes:      celestia-generator
52 Obsoletes:      celestia-stars
53 Obsoletes:      celestia-task-default
54 # texture replacement addons, virtual provides
55 Obsoletes:      celestia-textures-earth
56 Obsoletes:      celestia-textures-earth-clouds
57 Obsoletes:      celestia-textures-earth-night
58 Obsoletes:      celestia-textures-galileanmoons
59 Obsoletes:      celestia-textures-mars
60 Obsoletes:      celestia-textures-mars-bumpmap
61 Obsoletes:      celestia-textures-mercury
62 Obsoletes:      celestia-textures-mercury-bumpmap
63 Obsoletes:      celestia-textures-moon
64 Obsoletes:      celestia-textures-moon-bumpmap
65 # celestia addons
66 Obsoletes:      celestia-blackhole
67 Obsoletes:      celestia-galaxies_extended
68 Obsoletes:      celestia-galaxy_clusters
69 Obsoletes:      celestia-globular_clusters
70 Obsoletes:      celestia-im-starwars
71 Obsoletes:      celestia-pathfinder
72 Obsoletes:      celestia-voyager
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
76
77 %description
78 Celestia is a free real-time space simulation that lets you experience
79 our universe in three dimensions. Unlike most planetarium software,
80 Celestia doesn't confine you to the surface of the Earth. You can
81 travel throughout the solar system, to any of over 100,000 stars, or
82 even beyond the galaxy. All travel in Celestia is seamless; the
83 exponential zoom feature lets you explore space across a huge range of
84 scales, from galaxy clusters down to spacecraft only a few meters
85 across. A 'point-and-goto' interface makes it simple to navigate
86 through the universe to the object you want to visit.
87
88 %description -l pl.UTF-8
89 Celestia to wolny symulator przestrzeni komicznej w czasie
90 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
91 trzech wymiarach. W odróżnieniu od innych programów planetarnych
92 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
93 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
94 nawet poza galaktykę. Wszystkie podróże w Celestii są
95 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
96 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
97 widoku kilkumetrowych statków kosmicznych. Interfejs typu
98 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
99
100 %prep
101 %setup -q
102 %patch0
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4
107
108 # ugly hack not to require GConf2-devel if we're not building gnome version
109 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
110
111 %build
112 cp -f /usr/share/automake/config.sub admin
113 %{__make} -f admin/Makefile.common
114
115 %configure \
116         %{?with_kde:--with-kde} \
117         %{?with_gtk:--with-gtk} \
118         %{?with_gnome:--with-gnome} \
119         %{?with_glut:--with-glut} \
120         --disable-rpath \
121         %{!?with_theora:--disable-theora} \
122         --with-lua \
123         --with-qt-dir=%{_libdir}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         kde_htmldir=%{_kdedocdir} \
133         kde_libs_htmldir=%{_kdedocdir} \
134         appsdir=%{_desktopdir}/kde
135
136 # desktop/icon
137 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
138 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
139 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
140
141 %find_lang %{name} --all-name --with-kde
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %if %{with gnome}
147 %post
148 %gconf_schema_install celestia.schemas
149
150 %preun
151 %gconf_schema_uninstall celestia.schemas
152 %endif
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc README AUTHORS TODO controls.txt ChangeLog
157 %attr(755,root,root) %{_bindir}/*
158 %{_datadir}/celestia
159 %{_pixmapsdir}/*
160 %if %{with kde}
161 %{_datadir}/apps/celestia
162 %{_datadir}/config/*
163 %{_datadir}/mimelnk/application/*
164 %{_datadir}/services/*
165 %{_iconsdir}/*/*/apps/%{name}.png
166 %{_desktopdir}/kde/*.desktop
167 %else
168 %{_desktopdir}/*.desktop
169 %endif
170 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.041779 seconds and 3 git commands to generate.