]> git.pld-linux.org Git - packages/celestia.git/blame - celestia.spec
- use lua51 not lua50
[packages/celestia.git] / celestia.spec
CommitLineData
efaf8d4e 1
2%bcond_without kde # KDE UI as the default one
3%bcond_with gtk # use gtk2 UI instead
4%bcond_with gnome # use libgnome2 UI instead
5%bcond_with glut # use glut UI instead
6
275eebf7
KK
7%bcond_without theora # without theora support
8
efaf8d4e 9%if %{with gtk} || %{with gnome} || %{with glut}
10%undefine with_kde
11%endif
12
ff9c6890 13Summary: A real-time visual space simulation
57396fd6 14Summary(pl.UTF-8): Symulacja przestrzeni kosmicznej w czasie rzeczywistym
ff9c6890 15Name: celestia
84e273a4 16Version: 1.5.1
7277547a 17Release: 1
ff9c6890 18License: GPL
0e5662ec 19Group: X11/Applications/Science
f0c406a2 20Source0: http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
84e273a4
KK
21# Source0-md5: df6854a2cf62d2e96612398c13b68fd2
22Patch0: %{name}-as-needed.patch
23Patch1: %{name}-gcc43.patch
24Patch2: %{name}-extras.patch
25Patch3: %{name}-desktop.patch
009c7ae9 26Patch4: %{name}-lua51.patch
ff9c6890 27URL: http://www.shatters.net/celestia/
72a82a1c 28BuildRequires: OpenGL-GLU-devel
7277547a 29%{?with_glut:BuildRequires: OpenGL-glut-devel >= 4.0}
1a2dda0a
JB
30BuildRequires: autoconf
31BuildRequires: automake
efaf8d4e 32%if %{with gtk} || %{with gnome}
33BuildRequires: cairo-devel
34BuildRequires: gtk+2-devel >= 2.6
35BuildRequires: gtkglext-devel
36%endif
115a8331 37BuildRequires: gettext-devel
efaf8d4e 38%{?with_kde:BuildRequires: kdelibs-devel}
39%{?with_gnome:BuildRequires: libgnomeui-devel}
a684a621 40BuildRequires: libjpeg-devel
41BuildRequires: libpng-devel
42BuildRequires: libstdc++-devel
275eebf7 43%{?with_theora:BuildRequires: libtheora-devel}
0490466f 44BuildRequires: libtool
009c7ae9 45BuildRequires: lua51-devel
4322beb0 46BuildRequires: pkgconfig
efaf8d4e 47BuildRequires: sed >= 4.0
45cdd808 48Requires: OpenGL
efaf8d4e 49# celestia < 1.4 original packages
50Obsoletes: celestia-extrasolar
51Obsoletes: celestia-generator
52Obsoletes: celestia-stars
53Obsoletes: celestia-task-default
54# texture replacement addons, virtual provides
55Obsoletes: celestia-textures-earth
56Obsoletes: celestia-textures-earth-clouds
57Obsoletes: celestia-textures-earth-night
58Obsoletes: celestia-textures-galileanmoons
59Obsoletes: celestia-textures-mars
60Obsoletes: celestia-textures-mars-bumpmap
61Obsoletes: celestia-textures-mercury
62Obsoletes: celestia-textures-mercury-bumpmap
63Obsoletes: celestia-textures-moon
64Obsoletes: celestia-textures-moon-bumpmap
65# celestia addons
66Obsoletes: celestia-blackhole
67Obsoletes: celestia-galaxies_extended
68Obsoletes: celestia-galaxy_clusters
69Obsoletes: celestia-globular_clusters
70Obsoletes: celestia-im-starwars
71Obsoletes: celestia-pathfinder
72Obsoletes: celestia-voyager
ff9c6890 73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
a684a621 75%define _noautoreqdep libGL.so.1 libGLU.so.1 libGLcore.so.1
1a2dda0a 76
ff9c6890 77%description
78Celestia is a free real-time space simulation that lets you experience
79our universe in three dimensions. Unlike most planetarium software,
80Celestia doesn't confine you to the surface of the Earth. You can
81travel throughout the solar system, to any of over 100,000 stars, or
82even beyond the galaxy. All travel in Celestia is seamless; the
83exponential zoom feature lets you explore space across a huge range of
84scales, from galaxy clusters down to spacecraft only a few meters
85across. A 'point-and-goto' interface makes it simple to navigate
86through the universe to the object you want to visit.
87
4107a3bb 88%description -l pl.UTF-8
ff9c6890 89Celestia to wolny symulator przestrzeni komicznej w czasie
7277547a
KK
90rzeczywistym, który pozwala doświadczać naszego Wszechświata w
91trzech wymiarach. W odróżnieniu od innych programów planetarnych
92Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
93podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
94nawet poza galaktykę. Wszystkie podróże w Celestii są
95niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
96odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
97widoku kilkumetrowych statków kosmicznych. Interfejs typu
98'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
ff9c6890 99
100%prep
f0c406a2 101%setup -q
84e273a4 102%patch0
d267ffc3 103%patch1 -p1
f0c406a2 104%patch2 -p1
105%patch3 -p1
009c7ae9 106%patch4
724d8895 107
efaf8d4e 108# ugly hack not to require GConf2-devel if we're not building gnome version
109%{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
36f18dc6 110
efaf8d4e 111%build
112cp -f /usr/share/automake/config.sub admin
113%{__make} -f admin/Makefile.common
36f18dc6 114
0490466f 115%configure \
efaf8d4e 116 %{?with_kde:--with-kde} \
117 %{?with_gtk:--with-gtk} \
118 %{?with_gnome:--with-gnome} \
119 %{?with_glut:--with-glut} \
0490466f 120 --disable-rpath \
275eebf7 121 %{!?with_theora:--disable-theora} \
d267ffc3 122 --with-lua \
8cb97c25 123 --with-qt-dir=%{_libdir}
36f18dc6 124
efaf8d4e 125%{__make}
ff9c6890 126
127%install
128rm -rf $RPM_BUILD_ROOT
2560aac7 129
130%{__make} install \
36f18dc6 131 DESTDIR=$RPM_BUILD_ROOT \
efaf8d4e 132 kde_htmldir=%{_kdedocdir} \
52c7f06c 133 kde_libs_htmldir=%{_kdedocdir} \
efaf8d4e 134 appsdir=%{_desktopdir}/kde
2560aac7 135
136# desktop/icon
f0c406a2 137install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
efaf8d4e 138%{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
139install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
36f18dc6 140
52c7f06c 141%find_lang %{name} --all-name --with-kde
89ee6494 142
ff9c6890 143%clean
144rm -rf $RPM_BUILD_ROOT
145
efaf8d4e 146%if %{with gnome}
147%post
148%gconf_schema_install celestia.schemas
149
150%preun
151%gconf_schema_uninstall celestia.schemas
152%endif
153
f0c406a2 154%files -f %{name}.lang
ff9c6890 155%defattr(644,root,root,755)
efaf8d4e 156%doc README AUTHORS TODO controls.txt ChangeLog
ff9c6890 157%attr(755,root,root) %{_bindir}/*
f0c406a2 158%{_datadir}/celestia
2560aac7 159%{_pixmapsdir}/*
efaf8d4e 160%if %{with kde}
f0c406a2 161%{_datadir}/apps/celestia
89ee6494 162%{_datadir}/config/*
2560aac7 163%{_datadir}/mimelnk/application/*
164%{_datadir}/services/*
efaf8d4e 165%{_iconsdir}/*/*/apps/%{name}.png
e812d11b 166%{_desktopdir}/kde/*.desktop
efaf8d4e 167%else
e812d11b 168%{_desktopdir}/*.desktop
efaf8d4e 169%endif
170%{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.115207 seconds and 4 git commands to generate.