]> git.pld-linux.org Git - packages/ccrtp.git/blob - ccrtp.spec
- up to 1.7.0
[packages/ccrtp.git] / ccrtp.spec
1 Summary:        Common C++ class framework for RTP/RTCP
2 Summary(pl.UTF-8):      Szkielet klas C++ dla RTP/RTCP
3 Name:           ccrtp
4 Version:        1.7.0
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
9 # Source0-md5:  eb86cd2ac06af27ea60b1a349122605c
10 Patch0:         %{name}-gcc4.patch
11 Patch1:         %{name}-lt.patch
12 URL:            http://www.gnu.org/software/ccrtp/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  commoncpp2-devel >= 1.7.0
16 BuildRequires:  doxygen
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 ccRTP is a generic, extensible and efficient C++ framework for
22 developing applications based on the Real-Time Transport Protocol
23 (RTP) from the IETF. It is based on Common C++ and provides a full
24 RTP/RTCP stack for sending and receiving of realtime data by the use
25 of send and receive packet queues. ccRTP supports unicast,
26 multi-unicast and multicast, manages multiple sources, handles RTCP
27 automatically, supports different threading models and is generic as
28 for underlying network and transport protocols.
29
30 %description -l pl.UTF-8
31 ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
32 rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
33 (RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
34 wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
35 wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
36 multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
37 automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
38 podstawowych sieci i protokołów transportowych.
39
40 %package devel
41 Summary:        Header files for ccrtp library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ccrtp
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       commoncpp2-devel
46
47 %description devel
48 Header files for ccrtp library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki ccrtp.
52
53 %package static
54 Summary:        Static ccrtp library
55 Summary(pl.UTF-8):      Statyczna biblioteka ccrtp
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static ccrtp library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka ccrtp.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS COPYING COPYING.addendum README
94 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %doc doc/html/*.html doc/html/*.*g*
99 %attr(755,root,root) %{_libdir}/lib*.so
100 %{_libdir}/lib*.la
101 %{_includedir}/ccrtp
102 %{_pkgconfigdir}/*.pc
103 %{_infodir}/*.info*
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/lib*.a
This page took 0.066937 seconds and 3 git commands to generate.