]> git.pld-linux.org Git - packages/ccrtp.git/blob - ccrtp.spec
- updated to 2.0.3
[packages/ccrtp.git] / ccrtp.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
4 #
5 Summary:        Common C++ class framework for RTP packets
6 Summary(pl.UTF-8):      Szkielet klas C++ dla pakietów RTP
7 Name:           ccrtp
8 Version:        2.0.3
9 Release:        1
10 License:        GPL v2+ with runtime exception
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
13 # Source0-md5:  0d57da1b8e212fb634b8951067fbc1e0
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-openssl.patch
16 URL:            http://www.gnu.org/software/ccrtp/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.2.3}
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 %{!?with_gcrypt:BuildRequires:  openssl-devel}
24 BuildRequires:  pkgconfig
25 BuildRequires:  ucommon-devel >= 5.0.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 ccRTP is a generic, extensible and efficient C++ framework for
30 developing applications based on the Real-Time Transport Protocol
31 (RTP) from the IETF. It is based on Common C++ and provides a full
32 RTP/RTCP stack for sending and receiving of realtime data by the use
33 of send and receive packet queues. ccRTP supports unicast,
34 multi-unicast and multicast, manages multiple sources, handles RTCP
35 automatically, supports different threading models and is generic as
36 for underlying network and transport protocols.
37
38 %description -l pl.UTF-8
39 ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
40 rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
41 (RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
42 wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
43 wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
44 multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
45 automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
46 podstawowych sieci i protokołów transportowych.
47
48 %package devel
49 Summary:        Header files for ccrtp library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ccrtp
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.2.3}
54 Requires:       libstdc++-devel
55 %{!?with_gcrypt:Requires:       openssl-devel}
56 Requires:       ucommon-devel >= 5.0.0
57
58 %description devel
59 Header files for ccrtp library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki ccrtp.
63
64 %package static
65 Summary:        Static ccrtp library
66 Summary(pl.UTF-8):      Statyczna biblioteka ccrtp
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static ccrtp library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka ccrtp.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 # LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
88 %configure \
89         %{!?with_gcrypt:LIBGCRYPT_CONFIG=/nonexisting}
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
107 %attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libccrtp.so.0
109
110 %files devel
111 %defattr(644,root,root,755)
112 %doc doc/html/*.{css,html,js,png}
113 %attr(755,root,root) %{_libdir}/libccrtp.so
114 %{_libdir}/libccrtp.la
115 %{_includedir}/ccrtp
116 %{_pkgconfigdir}/libccrtp.pc
117 %{_infodir}/ccrtp.info*
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libccrtp.a
This page took 0.107683 seconds and 3 git commands to generate.