]> git.pld-linux.org Git - packages/ccache.git/blob - ccache.spec
updated %doc files
[packages/ccache.git] / ccache.spec
1 Summary:        Compiler cache
2 Summary(pl.UTF-8):      Pamięć podręczna dla kompilatora
3 Summary(pt_BR.UTF-8):   Cache para compiladores C/C++
4 Name:           ccache
5 Version:        3.3.3
6 Release:        1
7 License:        GPL v3
8 Group:          Development/Tools
9 Source0:        https://www.samba.org/ftp/ccache/%{name}-%{version}.tar.xz
10 # Source0-md5:  6918b36301a0b8ffdc96549f609a4ebc
11 URL:            http://ccache.samba.org/
12 BuildRequires:  automake
13 BuildRequires:  tar >= 1:1.22
14 BuildRequires:  xz
15 BuildRequires:  zlib-devel >= 1.2.3
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _libdir         %{_prefix}/%{_lib}/%{name}
19
20 %description
21 ccache is a compiler cache. It acts as a caching pre-processor to
22 C/C++ compilers, using the -E compiler switch and a hash to detect
23 when a compilation can be satisfied from cache. This often results in
24 a 5 to 10 times speedup in common compilations.
25
26 %description -l pl.UTF-8
27 ccache to pamięć podręczna dla kompilatora - działa jako cachujący
28 preprocesor dla kompilatorów C/C++, wykorzystujący opcję kompilatora
29 -E oraz tablicę haszującą do wykrywania, czy do kompilacji wystarczy
30 zawartość pamięci podręcznej. Daje to zazwyczaj przyspieszenie
31 kompilacji 5 do 10 razy.
32
33 %description -l pt_BR.UTF-8
34 ccache é um cache para compiladores. Ele funciona mantendo um cache de
35 pré-processamento para compiladores C/C++ utilizando-se do parâmetro
36 - -E e de um hash para detectar quando uma compilação pode ser
37   reaproveitada de um cache armazenado em disco. O ganho de tempo em
38   compilações comuns pode chegar a uma escala de até 10 vezes em relação
39   ao tempo normal.
40
41 %package wrapper
42 Summary:        Symlinks for c++/cc/g++/gcc
43 Summary(pl.UTF-8):      Dowiązania symboliczne do c++/cc/g++/gcc
44 Group:          Development/Tools
45 Requires:       %{name} = %{version}-%{release}
46
47 %description wrapper
48 This package contains the softlinks to ccache for each compiler.
49
50 %description wrapper -l pl.UTF-8
51 Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
52 kompilatora.
53
54 %prep
55 %setup -q
56
57 # Make sure system zlib is used
58 %{__rm} -r zlib
59
60 %build
61 cp -f /usr/share/automake/config.* .
62 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
63 %configure
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT/etc/env.d
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
75 for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
76         ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
77 done
78 echo 'export PATH=%{_libdir}:$PATH' > \
79         $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS.* LICENSE.* MANUAL.* NEWS.* README.md
87 %attr(755,root,root) %{_bindir}/ccache
88 %{_mandir}/man1/ccache.1.*
89
90 %files wrapper
91 %defattr(644,root,root,755)
92 %attr(755,root,root) /etc/profile.d/%{name}.sh
93 %dir %{_libdir}
94 %attr(755,root,root) %{_libdir}/c++
95 %attr(755,root,root) %{_libdir}/cc
96 %attr(755,root,root) %{_libdir}/g++
97 %attr(755,root,root) %{_libdir}/gcc
98 %attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-g++
99 %attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-gcc
This page took 0.065243 seconds and 3 git commands to generate.