]> git.pld-linux.org Git - packages/ccache.git/blob - ccache.spec
enable large file access for ccache
[packages/ccache.git] / ccache.spec
1 Summary:        Compiler cache
2 Summary(pl.UTF-8):      Przyspieszacz kompilowania
3 Summary(pt_BR.UTF-8):   Cache para compiladores C/C++
4 Name:           ccache
5 Version:        3.1.8
6 Release:        2
7 License:        GPL v3
8 Group:          Development/Tools
9 Source0:        http://samba.org/ftp/ccache/%{name}-%{version}.tar.bz2
10 # Source0-md5:  0e0f25fb342dcb1196d9c2986a7323cf
11 Patch0:         %{name}-nohash_size_mtime.patch
12 URL:            http://ccache.samba.org/
13 BuildRequires:  automake
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _libdir         %{_prefix}/%{_lib}/%{name}
17 %define         specflags       -D_FILE_OFFSET_BITS=64
18
19 %description
20 ccache is a compiler cache. It acts as a caching pre-processor to
21 C/C++ compilers, using the -E compiler switch and a hash to detect
22 when a compilation can be satisfied from cache. This often results in
23 a 5 to 10 times speedup in common compilations.
24
25 %description -l pl.UTF-8
26 ccache działa jako cachujący preprocesor dla kompilatorów C/C++. Przy
27 użyciu opcji kompilatora -E oraz tablicy haszującej do wykrywania, czy
28 do kompilacji wystarczy zawartość cache. Daje to zazwyczaj
29 przyspieszenie kompilacji 5 do 10 razy.
30
31 %description -l pt_BR.UTF-8
32 ccache é um cache para compiladores. Ele funciona mantendo um cache de
33 pré-processamento para compiladores C/C++ utilizando-se do parâmetro
34 - -E e de um hash para detectar quando uma compilação pode ser
35   reaproveitada de um cache armazenado em disco. O ganho de tempo em
36   compilações comuns pode chegar a uma escala de até 10 vezes em relação
37   ao tempo normal.
38
39 %package wrapper
40 Summary:        Symlinks for c++/cc/g++/gcc
41 Summary(pl.UTF-8):      Dowiązania symboliczne do c++/cc/g++/gcc
42 Group:          Development/Tools
43 Requires:       %{name} = %{version}-%{release}
44
45 %description wrapper
46 This package contains the softlinks to ccache for each compiler.
47
48 %description wrapper -l pl.UTF-8
49 Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
50 kompilatora.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 cp -f /usr/share/automake/config.* .
58 %configure
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT/etc/env.d
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
71         CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
72         CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
73         CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
74 do
75         echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
76 done
77
78 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
79 for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
80         ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
81 done
82 echo 'export PATH=%{_libdir}:$PATH' > \
83         $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
91 %attr(755,root,root) %{_bindir}/ccache
92 %{_mandir}/man1/ccache.1.*
93 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CCACHE_*
94
95 %files wrapper
96 %defattr(644,root,root,755)
97 %attr(755,root,root) /etc/profile.d/%{name}.sh
98 %dir %{_libdir}
99 %attr(755,root,root) %{_libdir}/*
This page took 0.033126 seconds and 3 git commands to generate.