]> git.pld-linux.org Git - packages/captive-drivers.git/blob - captive-drivers.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/captive-drivers.git] / captive-drivers.spec
1 # the drivers that were supposed to work, didn't.
2 # so these drivers didn't work for me.
3 #
4 # Conditional build:
5 %bcond_with     license_agreement       # generates package
6 %define         source_url      http://download.microsoft.com/download/9/7/6/9763833d-bd58-41e2-9911-50f64c7252a3/
7 #
8 Summary:        NTFS Drivers
9 Summary(pl.UTF-8):      Sterowniki NTFS
10 %define         base_name       captive-drivers
11 %if %{with license_agreement}
12 Name:           %{base_name}
13 %else
14 Name:           %{base_name}-installer
15 %endif
16 Version:        0.2
17 %define         _rel    2
18 Release:        %{_rel}%{?with_license_agreement:wla}
19 Group:          Libraries
20 License:        restricted, non-distributable
21 %if %{with license_agreement}
22 # NB! This is 145M download.
23 Source0:        %{source_url}xpsp1a_en_x86_CHK.exe
24 # Source0-md5:  329c25f457fea66ec502b7ef70cb9ede
25 BuildRequires:  cabextract
26 Requires:       captive
27 %else
28 Source0:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
29 # Source0-md5:  329c25f457fea66ec502b7ef70cb9ede
30 Requires:       rpm-build-tools >= 4.4.37
31 Requires:       rpmbuild(macros) >= 1.544
32 Provides:       %{base_name}
33 %endif
34 ExclusiveArch:  %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Contains ntfs.sys and ntoskrnl.exe from Windows XP SP1.
39 %if !%{with license_agreement}
40 License issues made us not to include inherent files into this package
41 by default. If you want to create full working package please build it
42 with the following command:
43
44 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
45 %endif
46
47 %description -l pl.UTF-8
48 Pakiet zawierający ntfs.sys i ntoskrnl.exe z Windows XP SP1.
49 %if !%{with license_agreement}
50 Kwestie licencji zmusiły nas do niedołączania do tego pakietu istotnych
51 plików. Jeśli chcesz stworzyć w pełni funkcjonalny pakiet, zbuduj go za
52 pomocą polecenia:
53
54 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
55 %endif
56
57 %prep
58 %setup -q -c -T
59 %if %{with license_agreement}
60 cabextract %{SOURCE0} -F ntfs.sys
61 cabextract %{SOURCE0} -F ntoskrnl.ex_
62 cabextract ntoskrnl.ex_
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %if !%{with license_agreement}
69 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
70
71 sed -e '
72         s/@BASE_NAME@/%{base_name}/g
73         s/@TARGET_CPU@/%{_target_cpu}/g
74         s-@VERSION@-%{version}-g
75         s-@RELEASE@-%{release}-g
76         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
77         s,@DATADIR@,%{_datadir}/%{base_name},g
78 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
79
80 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
81 %else
82 install -d $RPM_BUILD_ROOT/var/lib/captive
83 install ntfs.sys ntoskrnl.exe $RPM_BUILD_ROOT/var/lib/captive
84 %endif
85
86 %if !%{with license_agreement}
87 %post
88 %{_bindir}/%{base_name}.install
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %if %{with license_agreement}
97 /var/lib/captive/*
98 %else
99 %attr(755,root,root) %{_bindir}/%{base_name}.install
100 %{_datadir}/%{base_name}
101 %endif
This page took 0.071352 seconds and 3 git commands to generate.