]> git.pld-linux.org Git - packages/captive-drivers.git/blame - captive-drivers.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/captive-drivers.git] / captive-drivers.spec
CommitLineData
4f6ec1fb 1# the drivers that were supposed to work, didn't.
5fd23de0 2# so these drivers didn't work for me.
1dff71eb 3#
4# Conditional build:
5%bcond_with license_agreement # generates package
6%define source_url http://download.microsoft.com/download/9/7/6/9763833d-bd58-41e2-9911-50f64c7252a3/
7#
5fd23de0 8Summary: NTFS Drivers
7902ebbe 9Summary(pl.UTF-8): Sterowniki NTFS
1dff71eb 10%define base_name captive-drivers
11%if %{with license_agreement}
12Name: %{base_name}
13%else
14Name: %{base_name}-installer
15%endif
16Version: 0.2
75347c9f 17%define _rel 2
1dff71eb 18Release: %{_rel}%{?with_license_agreement:wla}
19Group: Libraries
5fd23de0 20License: restricted, non-distributable
1dff71eb 21%if %{with license_agreement}
3a3676b5 22# NB! This is 145M download.
1dff71eb 23Source0: %{source_url}xpsp1a_en_x86_CHK.exe
75347c9f 24# Source0-md5: 329c25f457fea66ec502b7ef70cb9ede
8f82caf4 25BuildRequires: cabextract
4f6ec1fb 26Requires: captive
1dff71eb 27%else
de9e11e7 28Source0: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
75347c9f 29# Source0-md5: 329c25f457fea66ec502b7ef70cb9ede
28572366 30Requires: rpm-build-tools >= 4.4.37
6c44d04a 31Requires: rpmbuild(macros) >= 1.544
1dff71eb 32Provides: %{base_name}
33%endif
5fd23de0
ER
34ExclusiveArch: %{ix86}
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
6cb78aad 38Contains ntfs.sys and ntoskrnl.exe from Windows XP SP1.
1a50eb6c 39%if !%{with license_agreement}
1dff71eb 40License issues made us not to include inherent files into this package
41by default. If you want to create full working package please build it
42with the following command:
43
44%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
45%endif
6cb78aad 46
9106bbb1
JR
47%description -l pl.UTF-8
48Pakiet zawierający ntfs.sys i ntoskrnl.exe z Windows XP SP1.
1a50eb6c 49%if !%{with license_agreement}
9106bbb1
JR
50Kwestie licencji zmusiły nas do niedołączania do tego pakietu istotnych
51plików. Jeśli chcesz stworzyć w pełni funkcjonalny pakiet, zbuduj go za
52pomocą polecenia:
1dff71eb 53
54%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
55%endif
5fd23de0
ER
56
57%prep
58%setup -q -c -T
1dff71eb 59%if %{with license_agreement}
8f82caf4
ER
60cabextract %{SOURCE0} -F ntfs.sys
61cabextract %{SOURCE0} -F ntoskrnl.ex_
62cabextract ntoskrnl.ex_
1dff71eb 63%endif
5fd23de0 64
5fd23de0
ER
65%install
66rm -rf $RPM_BUILD_ROOT
1dff71eb 67
1a50eb6c 68%if !%{with license_agreement}
1dff71eb 69install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
70
71sed -e '
72 s/@BASE_NAME@/%{base_name}/g
73 s/@TARGET_CPU@/%{_target_cpu}/g
74 s-@VERSION@-%{version}-g
75 s-@RELEASE@-%{release}-g
76 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
de9e11e7 77 s,@DATADIR@,%{_datadir}/%{base_name},g
1dff71eb 78' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
79
80install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
81%else
5fd23de0 82install -d $RPM_BUILD_ROOT/var/lib/captive
8f82caf4 83install ntfs.sys ntoskrnl.exe $RPM_BUILD_ROOT/var/lib/captive
1dff71eb 84%endif
85
1a50eb6c 86%if !%{with license_agreement}
1dff71eb 87%post
88%{_bindir}/%{base_name}.install
89%endif
5fd23de0
ER
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
1dff71eb 96%if %{with license_agreement}
5fd23de0 97/var/lib/captive/*
1dff71eb 98%else
99%attr(755,root,root) %{_bindir}/%{base_name}.install
100%{_datadir}/%{base_name}
101%endif
This page took 0.0686 seconds and 4 git commands to generate.