- fixed scripts (was stoppng service on upgrade), STBR AC-STABLE auto/ac/capi4k-utils-2005_07_18-1
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 24 Feb 2006 15:01:04 +0000 (15:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    capi4k-utils.spec -> 1.16

capi4k-utils.spec

index e8a2064..651c107 100644 (file)
@@ -20,7 +20,8 @@ Patch1:               %{name}-amd64.patch
 URL:           ftp://ftp.in-berlin.de/pub/capi4linux/
 BuildRequires: libtool
 BuildRequires: ppp-plugin-devel
-Requires(post,postun): /sbin/ldconfig
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(post):        /sbin/ldconfig
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -50,8 +51,8 @@ j
 
 %package devel
 Summary:       Header files for capi development
-Summary(pl):   Pliki nag³ówkowe capi
 Summary(de):   Kopfdateien zur Entwicklung von CAPI Programmen
+Summary(pl):   Pliki nag³ówkowe capi
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
@@ -193,21 +194,15 @@ rm -rf $RPM_BUILD_ROOT
 %post
 /sbin/ldconfig
 /sbin/chkconfig --add capi
-exit 0
+%service capi restart
 
 %preun
 if [ "$1" = "0" ]; then
-       /etc/rc.d/init.d/capi stop >&2
+       %service capi stop
        /sbin/chkconfig --del capi
 fi
-exit 0
 
-%postun
-/sbin/ldconfig
-if [ "$1" -ge "1" ]; then
-       /etc/rc.d/init.d/capi stop >&2
-fi
-exit 0
+%postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
This page took 0.152592 seconds and 4 git commands to generate.