]> git.pld-linux.org Git - packages/calibre.git/blob - calibre.spec
- Rs: python-dateutil, python-PIL
[packages/calibre.git] / calibre.spec
1 #
2 # NOTE:
3 # Upstream packages some unfree fonts which we cannot redistribute,
4 # so when upgrading calibre we should download upstream tarball by hand from
5 # http://downloads.sourceforge.net/calibre and run below script in order
6 # to remove them:
7 #
8 # #!/bin/sh
9 #
10 # VERSION=$1
11 #
12 # rm -rf calibre
13 # tar -xvzf calibre-$VERSION.tar.gz
14 # rm -f calibre/resources/fonts/liberation/*
15 # rm -f calibre/resources/fonts/prs500/*
16 #
17 # tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18 #
19 Summary:        E-book converter and library management
20 Name:           calibre
21 Version:        0.6.53
22 Release:        0.1
23 License:        GPL v3+
24 Group:          Applications/Multimedia
25 Source0:        %{name}-%{version}-nofonts.tar.bz2
26 # Source0-md5:  74f8a83e86820b248eb094bde4f1ab69
27 Patch0:         %{name}-prefix.patch
28 URL:            http://www.calibre-ebook.com/
29 BuildRequires:  ImageMagick-devel
30 BuildRequires:  chmlib-devel
31 BuildRequires:  podofo-devel
32 BuildRequires:  poppler-Qt-devel
33 BuildRequires:  python-BeautifulSoup
34 BuildRequires:  python-PIL
35 BuildRequires:  python-PyQt4-devel
36 BuildRequires:  python-cssutils
37 BuildRequires:  python-dateutil
38 BuildRequires:  python-lxml
39 BuildRequires:  python-mechanize
40 BuildRequires:  python-modules-sqlite
41 BuildRequires:  python-sip-devel
42 BuildRequires:  rpm-pythonprov
43 Requires:       python-PIL
44 Requires:       python-cssutils
45 Requires:       python-dateutil
46 Requires:       python-lxml
47 Requires:       python-mechanize
48 Requires:       python-modules-sqlite
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Calibre is meant to be a complete e-library solution. It includes
53 library management, format conversion, news feeds to ebook conversion
54 as well as e-book reader sync features.
55
56 Calibre is primarily a ebook cataloging program. It manages your ebook
57 collection for you. It is designed around the concept of the logical
58 book, i.e. a single entry in the database that may correspond to
59 ebooks in several formats. It also supports conversion to and from a
60 dozen different ebook formats.
61
62 Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
63 CBR, CBZ, RTF, TXT, PDF and LRS.
64
65 %prep
66 %setup -q -n %{name}
67 %patch0 -p1
68
69 %build
70 %{__python} setup.py build
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__python} setup.py install \
76         --root=$RPM_BUILD_ROOT \
77         --libdir=%{_libdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc COPYRIGHT README
85 %attr(755,root,root) %{_bindir}/*
86 %{_datadir}/%{name}
87 %{_libdir}/%{name}
This page took 0.057212 seconds and 4 git commands to generate.