]> git.pld-linux.org Git - packages/caja-python.git/blob - caja-python.spec
Release 3 (by relup.sh)
[packages/caja-python.git] / caja-python.spec
1 # NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2 # but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3 Summary:        Python bindings for libcaja-extension library
4 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libcaja-extension
5 Name:           caja-python
6 Version:        1.26.0
7 Release:        3
8 License:        GPL v2+
9 Group:          Libraries/Python
10 Source0:        https://pub.mate-desktop.org/releases/1.26/python-caja-%{version}.tar.xz
11 # Source0-md5:  08991236a39d9ad8e4c59e564786b9bd
12 URL:            https://wiki.mate-desktop.org/mate-desktop/components/python-caja/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1:1.10
15 BuildRequires:  caja-devel >= 1.17.1
16 BuildRequires:  gettext-tools >= 0.19.8
17 BuildRequires:  gtk-doc >= 1.9
18 BuildRequires:  libtool >= 1:1.4.3
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRequires:  python3-devel >= 1:3.6
22 BuildRequires:  python3-pygobject3-devel >= 3.0.0
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       caja >= 1.17.1
29 Requires:       python3-libs >= 1:3.6
30 Obsoletes:      mate-file-manager-python < 1.8.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Python bindings for libcaja-extension library, allowing to write Caja
35 extensions in Python.
36
37 %description -l pl.UTF-8
38 Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
39 tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
40
41 %package devel
42 Summary:        Development files for Python Caja extensions
43 Summary(pl.UTF-8):      Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
44 Group:          Development/Libraries
45 # doesn't require base; the only file is pkg-config specific, so let's require it
46 Requires:       pkgconfig
47 Obsoletes:      mate-file-manager-python-devel < 1.8.0
48
49 %description devel
50 Development files for Caja extensions written in Python.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
54 Pythonie.
55
56 %package apidocs
57 Summary:        Python Caja API documentation
58 Summary(pl.UTF-8):      Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
59 Group:          Documentation
60 Obsoletes:      mate-file-manager-python-apidocs < 1.8.0
61 BuildArch:      noarch
62
63 %description apidocs
64 Python Caja API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
68
69 %package examples
70 Summary:        Example Python extensions for Caja file manager
71 Summary(pl.UTF-8):      Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
72 Group:          Documentation
73 Obsoletes:      mate-file-manager-python-examples < 1.8.0
74
75 %description examples
76 Example Python extensions for Caja file manager.
77
78 %description examples -l pl.UTF-8
79 Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
80
81 %prep
82 %setup -q -n python-caja-%{version}
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --enable-gtk-doc \
92         --disable-silent-rules \
93         --with-html-dir=%{_gtkdocdir}
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         HTMLdir=%{_gtkdocdir}/caja-python
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
105
106 # not installed because of incomplete docs/Makefile
107 cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
108
109 # examples
110 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
111 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113
114 # directory for python plugins for caja - see src/caja-python.c or caja-python.pc
115 install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
116
117 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{es_ES,frp,ie,jv,ku_IQ,pms}
118
119 %find_lang python-caja
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f python-caja.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README
127 %attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
128 %{_datadir}/caja/extensions/libcaja-python.caja-extension
129 %dir %{_datadir}/caja-python
130 %dir %{_datadir}/caja-python/extensions
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_pkgconfigdir}/caja-python.pc
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_gtkdocdir}/caja-python
139
140 %files examples
141 %defattr(644,root,root,755)
142 %{_examplesdir}/%{name}-%{version}
This page took 0.126037 seconds and 3 git commands to generate.