]> git.pld-linux.org Git - packages/caja-python.git/blob - caja-python.spec
- up to 1.8.1
[packages/caja-python.git] / caja-python.spec
1 # NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2 # but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3 Summary:        Python bindings for libcaja-extension library
4 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libcaja-extension
5 Name:           caja-python
6 Version:        1.8.1
7 Release:        1
8 License:        GPL v2+
9 Group:          Libraries/Python
10 Source0:        http://pub.mate-desktop.org/releases/1.8/python-caja-%{version}.tar.xz
11 # Source0-md5:  9419ca3e13de36efe1c3fd60696d22cf
12 URL:            http://mate-desktop.org/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1:1.10
15 BuildRequires:  caja-devel >= 1.6.0
16 BuildRequires:  gtk-doc >= 1.9
17 BuildRequires:  libtool >= 1:1.4.3
18 BuildRequires:  libxslt-progs
19 BuildRequires:  pkgconfig
20 BuildRequires:  python-devel >= 2.7
21 # pygobject3 is preferred over pygobject 2 with no configure switch
22 BuildRequires:  python-pygobject3-devel >= 3.0.0
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       caja >= 1.6.0
28 Requires:       python-libs
29 Obsoletes:      mate-file-manager-python
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Python bindings for libcaja-extension library, allowing to write Caja
34 extensions in Python.
35
36 %description -l pl.UTF-8
37 Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
38 tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
39
40 %package devel
41 Summary:        Development files for Python Caja extensions
42 Summary(pl.UTF-8):      Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
43 Group:          Development/Libraries
44 # doesn't require base; the only file is pkg-config specific, so let's require it
45 Requires:       pkgconfig
46 Obsoletes:      mate-file-manager-python-devel
47
48 %description devel
49 Development files for Caja extensions written in Python.
50
51 %description devel -l pl.UTF-8
52 Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
53 Pythonie.
54
55 %package apidocs
56 Summary:        Python Caja API documentation
57 Summary(pl.UTF-8):      Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
58 Group:          Documentation
59 Obsoletes:      mate-file-manager-python-apidocs
60
61 %description apidocs
62 Python Caja API documentation.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
66
67 %package examples
68 Summary:        Example Python extensions for Caja file manager
69 Summary(pl.UTF-8):      Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
70 Group:          Documentation
71 Obsoletes:      mate-file-manager-python-examples
72
73 %description examples
74 Example Python extensions for Caja file manager.
75
76 %description examples -l pl.UTF-8
77 Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
78
79 %prep
80 %setup -q -n python-caja-%{version}
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --enable-gtk-doc \
90         --with-html-dir=%{_gtkdocdir}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT \
99         HTMLdir=%{_gtkdocdir}/caja-python
100
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
102
103 # not installed because of incomplete docs/Makefile
104 cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
105
106 # examples
107 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
110
111 # directory for python plugins for caja - see src/caja-python.c or caja-python.pc
112 install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README
120 %attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
121 %dir %{_datadir}/caja-python
122 %dir %{_datadir}/caja-python/extensions
123
124 %files devel
125 %defattr(644,root,root,755)
126 %{_pkgconfigdir}/caja-python.pc
127
128 %files apidocs
129 %defattr(644,root,root,755)
130 %{_gtkdocdir}/caja-python
131
132 %files examples
133 %defattr(644,root,root,755)
134 %{_examplesdir}/%{name}-%{version}
This page took 0.07806 seconds and 3 git commands to generate.