]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- updated to 1.8.10
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %if "%{pld_release}" == "ac"
6 %bcond_with     xcb             # XCB backend
7 %else
8 %bcond_without  xcb             # XCB backend
9 %endif
10 %bcond_with     tests           # perform tests (can fail due to out of memory)
11 #
12 Summary:        Cairo - multi-platform 2D graphics library
13 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
14 Name:           cairo
15 Version:        1.8.10
16 Release:        1
17 License:        LGPL v2.1 or MPL v1.1
18 Group:          Libraries
19 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  b60a82f405f9400bbfdcf850b1728d25
21 Patch0:         %{name}-link.patch
22 URL:            http://cairographics.org/
23 BuildRequires:  autoconf >= 2.58
24 BuildRequires:  automake >= 1:1.8
25 BuildRequires:  fontconfig-devel
26 BuildRequires:  freetype-devel >= 1:2.3.0
27 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
29 BuildRequires:  libpng-devel >= 2:1.4.0
30 BuildRequires:  libtool
31 BuildRequires:  pixman-devel >= 0.12.0
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm >= 4.4.9-56
34 %if %{with xcb}
35 BuildRequires:  libxcb-devel >= 0.9.92
36 BuildRequires:  xcb-util-devel >= 0.2
37 %endif
38 %if "%{pld_release}" == "ac"
39 BuildRequires:  xrender-devel >= 0.6
40 %else
41 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
42 %endif
43 BuildRequires:  zlib-devel
44 Requires:       freetype >= 1:2.3.0
45 %{?with_glitz:Requires: glitz >= 0.5.1}
46 Requires:       pixman >= 0.12.0
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Cairo provides anti-aliased vector-based rendering for X. Paths
51 consist of line segments and cubic splines and can be rendered at any
52 width with various join and cap styles. All colors may be specified
53 with optional translucence (opacity/alpha) and combined using the
54 extended Porter/Duff compositing algebra as found in the X Render
55 Extension.
56
57 Cairo exports a stateful rendering API similar in spirit to the path
58 construction, text, and painting operators of PostScript, (with the
59 significant addition of translucence in the imaging model). When
60 complete, the API is intended to support the complete imaging model of
61 PDF 1.4.
62
63 %description -l pl.UTF-8
64 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
65 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
66 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
67 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
68 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
69 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
70 można znaleźć w rozszerzeniu X Render.
71
72 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
73 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
74 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
75 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
76
77 %package devel
78 Summary:        Development files for Cairo library
79 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       fontconfig-devel
83 Requires:       freetype-devel >= 1:2.3.0
84 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
85 Requires:       libpng-devel >= 2:1.4.0
86 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
87 Requires:       pixman-devel >= 0.12.0
88 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
89 %if "%{pld_release}" == "ac"
90 Requires:       xrender-devel >= 0.6
91 %else
92 Requires:       xorg-lib-libXrender-devel >= 0.6
93 %endif
94
95 %description devel
96 Development files for Cairo library.
97
98 %description devel -l pl.UTF-8
99 Pliki programistyczne biblioteki Cairo.
100
101 %package static
102 Summary:        Static Cairo library
103 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106
107 %description static
108 Static Cairo library.
109
110 %description static -l pl.UTF-8
111 Statyczna biblioteka Cairo.
112
113 %package apidocs
114 Summary:        Cairo API documentation
115 Summary(pl.UTF-8):      Dokumentacja API Cairo
116 Group:          Documentation
117 Requires:       gtk-doc-common
118
119 %description apidocs
120 Cairo API documentation.
121
122 %description apidocs -l pl.UTF-8
123 Dokumentacja API Cairo.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128
129 %build
130 %{?with_apidocs:%{__gtkdocize}}
131 %{__libtoolize}
132 %{__aclocal} -I build
133 %{__autoheader}
134 %{__autoconf}
135 %{__automake}
136 %configure \
137         --enable-freetype \
138         %{?with_glitz:--enable-glitz} \
139         %{?with_apidocs:--enable-gtk-doc} \
140         --enable-pdf=yes \
141         --enable-png \
142         --enable-ps \
143         %{?with_xcb:--enable-xcb} \
144         --with-html-dir=%{_gtkdocdir}
145 %{__make}
146 %{?with_tests:%{__make} check}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 # COPYING contains only notes, not LGPL/MPL texts
165 %doc AUTHORS COPYING ChangeLog NEWS README
166 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libcairo.so
172 %{_libdir}/libcairo.la
173 %{_includedir}/cairo
174 %{_pkgconfigdir}/cairo.pc
175 %{_pkgconfigdir}/cairo-ft.pc
176 %{_pkgconfigdir}/cairo-pdf.pc
177 %{_pkgconfigdir}/cairo-png.pc
178 %{_pkgconfigdir}/cairo-ps.pc
179 %{_pkgconfigdir}/cairo-svg.pc
180 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
181 %{_pkgconfigdir}/cairo-xlib.pc
182 %{_pkgconfigdir}/cairo-xlib-xrender.pc
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libcairo.a
187
188 %if %{with apidocs}
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/cairo
192 %endif
This page took 0.035972 seconds and 3 git commands to generate.