]> git.pld-linux.org Git - packages/cacti-plugin-npc.git/blob - cacti-plugin-npc.spec
- BR glib2-devel
[packages/cacti-plugin-npc.git] / cacti-plugin-npc.spec
1 # TODO
2 # - Edit the MySQL options on line 143 of /cacti/plugins/npc/neb/inserter.c
3 %define         plugin  npc
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Plugin for Cacti - NPC
6 Summary(pl.UTF-8):      Wtyczka do Cacti - NPC
7 Name:           cacti-plugin-npc
8 Version:        0.1.1a
9 Release:        0.2
10 License:        GPL v2
11 Group:          Applications/WWW
12 Source0:        http://forums.cacti.net/files/%{plugin}-%{version}.tar.gz
13 # Source0-md5:  325f2e49070420346b55b7b4e2994d34
14 Patch0:         %{name}-path_headers.patch
15 # inserter.c patch for nagios 3.0b6 from http://forums.cacti.net/about10327-0-asc-150.html
16 #Patch1: http://forums.cacti.net/files/neb_159.patch
17 # from http://forums.cacti.net/about10327-0-asc-135.html
18 Patch1:         %{name}-extinfo.patch
19 URL:            http://forums.cacti.net/about10327.html
20 BuildRequires:  glib2-devel
21 BuildRequires:  mysql-devel >= 4.1.0
22 BuildRequires:  nagios-devel >= 2.1
23 BuildRequires:  rpm-perlprov
24 Requires:       cacti >= 0.8.6h
25 Requires:       nagios >= 2.1
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         cactidir                /usr/share/cacti
29 %define         plugindir               %{cactidir}/plugins/%{plugin}
30 %define         moduledir               %{_libdir}/nagios/modules
31
32 %description
33 Plugin for Cacti - A UI replacement for Nagios integrated into Cacti.
34
35 %description -l pl.UTF-8
36 Wtyczka do Cacti - zamiennik interfejsu użytkownika dla Nagiosa
37 zintegrowany z Cacti.
38
39 %prep
40 %setup -q -n %{plugin}
41 %patch0 -p1
42 %patch1 -p1
43
44 %build
45 cd neb
46 %{__cc} %{rpmcflags} -Wall -o inserter.o inserter.c -shared -I../include $(pkg-config glib-2.0 --cflags) $(mysql_config --cflags --libs) -fPIC
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{plugindir},%{moduledir}}
51 install neb/inserter.o $RPM_BUILD_ROOT%{moduledir}
52 cp -a . $RPM_BUILD_ROOT%{plugindir}
53 rm -rf $RPM_BUILD_ROOT%{plugindir}/neb
54
55 # Edit nagios.cfg and set:
56 #
57 #        retain_state_information=0
58 #        event_broker_options=-1
59 #        broker_module=%{moduledir}/inserter.o
60
61 # Setting retain_state_information=0 causes all hosts and services to
62 # go to a pending state until rechecked by Nagios. Without this setting
63 # the inserter module will never update any data in NPC. Its a minor
64 # inconvenience that I will try to fix in the inserter module.
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc TODO README
72 %{plugindir}
73 %attr(755,root,root) %{moduledir}/inserter.o
This page took 0.038643 seconds and 4 git commands to generate.