]> git.pld-linux.org Git - packages/cacti-plugin-boost.git/blob - cacti-plugin-boost.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cacti-plugin-boost.git] / cacti-plugin-boost.spec
1 # TODO
2 # - sync pl
3 # - init.d processes
4 %define         plugin boost
5 %define         php_min_version 5.2.0
6 %include        /usr/lib/rpm/macros.php
7 Summary:        Large Site Performance Booster for Cacti
8 Summary(pl.UTF-8):      Wtyczka do Cacti - Boost
9 Name:           cacti-plugin-%{plugin}
10 Version:        5.1
11 Release:        7
12 License:        GPL v2
13 Group:          Applications/WWW
14 Source0:        http://docs.cacti.net/_media/plugin:boost-v%{version}-1.tgz
15 # Source0-md5:  31bda9b46d933e61bdcd77243928c89c
16 Patch0:         paths.patch
17 Patch1:         chmod.patch
18 URL:            http://docs.cacti.net/plugin:boost
19 BuildRequires:  rpmbuild(macros) >= 1.553
20 Requires:       cacti >= 0.8.7g-6
21 Requires:       cacti(pia) >= 2.8
22 Requires:       php(core) >= %{php_min_version}
23 Requires:       php(pcre)
24 Requires:       php(session)
25 Requires:       php(date)
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         cactidir                /usr/share/cacti
30 %define         plugindir               %{cactidir}/plugins/%{plugin}
31 %define         cachedir                /var/cache/cacti/%{plugin}
32
33 %description
34 Cacti plugin that boosts Cacti performance especially for large sites.
35
36 This plugin boost's Cacti performance especially for Large Sites. It
37 does this by introducing three new features to Cacti.
38
39 First, it caches recently viewed images to a public Cache folder for
40 all users to share.
41
42 Second, it introduces an "on demand" RRD update feaure to Cacti. This
43 feature will only update the RRD files when there is demand on the
44 system to view a graph. The RRD's will be updated just before the
45 Graph is rendered by the web server. Then, on a predetermined
46 schedule, it conducts a batch update's of all remaining RRD's.
47
48 Lastly, it introduces an RRD update service to Cacti. This service
49 allows you to add multiple Cacti servers to your web farm allowing all
50 the servers to participate in the "on demand" RRD update and viewing
51 process.
52
53 %description -l pl.UTF-8
54 Wtyczka Cacti zwiększająca jego wydajność, szczególnie w przypadku
55 dużych serwisów.
56
57 %prep
58 %setup -qc
59 %undos -f php
60 cd %{plugin}
61 %patch0 -p1
62 %patch1 -p1
63 cd -
64
65 mv %{plugin}/{README,LICENSE,cacti_rrdsvc} .
66
67 # cleanup backups after patching
68 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{plugindir},%{cachedir}}
73 cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README
81 %{plugindir}
82 %attr(770,root,http) %dir %{cachedir}
This page took 0.054592 seconds and 3 git commands to generate.