]> git.pld-linux.org Git - packages/bzrtp.git/blob - bzrtp.spec
- updated to 4.4.0 (GPL v3+ now)
[packages/bzrtp.git] / bzrtp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Open source implementation of ZRTP keys exchange protocol
6 Summary(pl.UTF-8):      Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
7 Name:           bzrtp
8 Version:        4.4.0
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 #Source0Download: https://gitlab.linphone.org/BC/public/bzrtp/tags
13 Source0:        https://gitlab.linphone.org/BC/public/bzrtp/-/archive/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  981738ec9161c2a4c5220605ed4cbb71
15 URL:            http://www.linphone.org/
16 BuildRequires:  CUnit
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  bctoolbox-devel >= 4.4.0
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpmbuild(macros) >= 1.748
24 BuildRequires:  sqlite3-devel >= 3.6.0
25 Requires:       bctoolbox >= 4.4.0
26 Requires:       sqlite3 >= 3.6.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 bzrtp is an opensource implementation of ZRTP keys exchange protocol. 
31 The library written in C 89 is fully portable and can be executed on
32 many platforms including both ARM processor and x86. 
33
34 %description -l pl.UTF-8
35 bzrtp to mająca otwarte źródła implementacja protokołu wymiany kluczy
36 ZRTP. Napisana w C 89 biblioteka jest w pełni przenośna i może być
37 wykonywana na wielu platformach, w tym ARM oraz x86.
38
39 %package devel
40 Summary:        Header file for bzrtp library
41 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bzrtp
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header file for bzrtp library.
47
48 %description devel -l pl.UTF-8
49 Plik nagłówkowy biblioteki bzrtp.
50
51 %package static
52 Summary:        Static bzrtp library
53 Summary(pl.UTF-8):      Statyczna biblioteka bzrtp
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static bzrtp library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka bzrtp.
62
63 %prep
64 %setup -q
65
66 %build
67 # rebuild ac/am/lt for as-needed to work
68 %{__libtoolize}
69 %{__aclocal} -I m4
70 %{__autoconf}
71 %{__automake}
72 %if %{_ver_ge "%{cc_version}" "8.0"}
73 CPPFLAGS="%{rpmcppflags} -Wno-error=cast-function-type"
74 %endif
75 %configure \
76         --disable-silent-rules \
77         %{?with_static_libs:--enable-static}
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # obsoleted by pkg-config
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbzrtp.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc CHANGELOG.md README.md
99 %attr(755,root,root) %{_libdir}/libbzrtp.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libbzrtp.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libbzrtp.so
105 %{_includedir}/bzrtp
106 %{_pkgconfigdir}/libbzrtp.pc
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libbzrtp.a
112 %endif
This page took 0.060589 seconds and 3 git commands to generate.