]> git.pld-linux.org Git - packages/byobu.git/blob - byobu.spec
add TerminalEmulator to desktop Categories
[packages/byobu.git] / byobu.spec
1 Summary:        A set of useful profiles and a profile-switcher for GNU screen
2 Summary(hu.UTF-8):      Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
3 Summary(pl.UTF-8):      Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
4 Name:           byobu
5 Version:        5.111
6 Release:        1
7 License:        GPL v3
8 Group:          Applications/System
9 Source0:        https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
10 # Source0-md5:  286151043876bf9f7e884f95f706aa73
11 Patch0:         desktop.patch
12 URL:            https://launchpad.net/byobu
13 BuildRequires:  gettext-tools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.596
16 Requires:       desktop-file-utils
17 Requires:       python >= 1:2.5
18 Requires:       python-snack
19 Suggests:       screen
20 Suggests:       tmux >= 1.5
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautocompressdoc '*.txt'
25
26 %define         _libexecdir     %{_prefix}/lib
27
28 %description
29 Byobu is an elegant enhancement of the otherwise functional, plain,
30 practical GNU Screen. Byobu includes an enhanced profile and
31 configuration utilities for the GNU screen window manager, such as
32 toggle-able system status notifications.
33
34 %description -l hu.UTF-8
35 Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
36 praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
37 és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
38 ki/bekapcsolható rendszer státusz jelentéseket.
39
40 %description -l pl.UTF-8
41 Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
42 praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
43 narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
44 - takie jak przełączane powiadomienia o stanie systemu.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %{__sed} -i -e '
51         s#/share/doc/byobu#/share/doc/%{name}-%{version}#
52 ' usr/share/byobu/keybindings/*
53
54 # cleanup backups after patching
55 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
56
57 %build
58 %configure
59 %{__make}
60
61 for po in po/*.po; do
62         lang=${po#po/}
63         lang=${lang%.po}
64         mkdir -p locale/${lang}/LC_MESSAGES/
65         msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
66 done
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} install \
71         INSTALL="install -p" \
72         CP="cp -p" \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 # some debian hackery, just use the "current" one for pld
76 install -d $RPM_BUILD_ROOT%{_desktopdir}
77 mv $RPM_BUILD_ROOT{%{_datadir}/%{name}/desktop,%{_desktopdir}}/%{name}.desktop
78
79 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
80
81 install -d $RPM_BUILD_ROOT%{_localedir}
82 cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
83
84 %find_lang %{name}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %update_desktop_database
91
92 %postun
93 %update_desktop_database
94
95 %files -f %{name}.lang
96 %defattr(644,root,root,755)
97 %doc README
98 %doc usr/share/doc/byobu/*.txt
99 %dir %{_sysconfdir}/%{name}
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
101 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
102 %attr(755,root,root) %{_bindir}/byobu
103 %attr(755,root,root) %{_bindir}/byobu-config
104 %attr(755,root,root) %{_bindir}/byobu-ctrl-a
105 %attr(755,root,root) %{_bindir}/byobu-disable
106 %attr(755,root,root) %{_bindir}/byobu-disable-prompt
107 %attr(755,root,root) %{_bindir}/byobu-enable
108 %attr(755,root,root) %{_bindir}/byobu-enable-prompt
109 %attr(755,root,root) %{_bindir}/byobu-export
110 %attr(755,root,root) %{_bindir}/byobu-janitor
111 %attr(755,root,root) %{_bindir}/byobu-keybindings
112 %attr(755,root,root) %{_bindir}/byobu-launch
113 %attr(755,root,root) %{_bindir}/byobu-launcher
114 %attr(755,root,root) %{_bindir}/byobu-launcher-install
115 %attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
116 %attr(755,root,root) %{_bindir}/byobu-layout
117 %attr(755,root,root) %{_bindir}/byobu-prompt
118 %attr(755,root,root) %{_bindir}/byobu-quiet
119 %attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
120 %attr(755,root,root) %{_bindir}/byobu-screen
121 %attr(755,root,root) %{_bindir}/byobu-select-backend
122 %attr(755,root,root) %{_bindir}/byobu-select-profile
123 %attr(755,root,root) %{_bindir}/byobu-select-session
124 %attr(755,root,root) %{_bindir}/byobu-shell
125 %attr(755,root,root) %{_bindir}/byobu-silent
126 %attr(755,root,root) %{_bindir}/byobu-status
127 %attr(755,root,root) %{_bindir}/byobu-status-detail
128 %attr(755,root,root) %{_bindir}/byobu-tmux
129 %attr(755,root,root) %{_bindir}/byobu-ugraph
130 %attr(755,root,root) %{_bindir}/byobu-ulevel
131 %attr(755,root,root) %{_bindir}/col1
132 %attr(755,root,root) %{_bindir}/ctail
133 %attr(755,root,root) %{_bindir}/manifest
134 %attr(755,root,root) %{_bindir}/purge-old-kernels
135 %attr(755,root,root) %{_bindir}/vigpg
136 %attr(755,root,root) %{_bindir}/wifi-status
137 %{_mandir}/man1/*.1*
138 /etc/profile.d/Z97-byobu.sh
139 %{_datadir}/dbus-1/services/us.kirkland.terminals.byobu.service
140 %{_desktopdir}/%{name}.desktop
141 # preserve +x bits where needed
142 %defattr(-,root,root,-)
143 %{_libexecdir}/%{name}
144 %{_datadir}/%{name}
This page took 0.056194 seconds and 3 git commands to generate.