]> git.pld-linux.org Git - packages/byobu.git/blob - byobu.spec
requires snack python module (from newt)
[packages/byobu.git] / byobu.spec
1 Summary:        A set of useful profiles and a profile-switcher for GNU screen
2 Summary(hu.UTF-8):      Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
3 Summary(pl.UTF-8):      Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
4 Name:           byobu
5 Version:        5.97
6 Release:        0.3
7 License:        GPL v3
8 Group:          Applications/System
9 Source0:        https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
10 # Source0-md5:  06fc9398700de1ecba576e0819fe5626
11 URL:            https://launchpad.net/byobu
12 BuildRequires:  gettext-tools
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.596
15 Requires:       desktop-file-utils
16 Requires:       python >= 1:2.5
17 Requires:       python-snack
18 Suggests:       screen
19 Suggests:       tmux
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _libexecdir     %{_prefix}/lib
24
25 %description
26 Byobu is an elegant enhancement of the otherwise functional, plain,
27 practical GNU Screen. Byobu includes an enhanced profile and
28 configuration utilities for the GNU screen window manager, such as
29 toggle-able system status notifications.
30
31 %description -l hu.UTF-8
32 Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
33 praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
34 és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
35 ki/bekapcsolható rendszer státusz jelentéseket.
36
37 %description -l pl.UTF-8
38 Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
39 praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
40 narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
41 - takie jak przełączane powiadomienia o stanie systemu.
42
43 %prep
44 %setup -q
45
46 %build
47 %configure
48 %{__make}
49
50 for po in po/*.po; do
51         lang=${po#po/}
52         lang=${lang%.po}
53         mkdir -p locale/${lang}/LC_MESSAGES/
54         msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
55 done
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         INSTALL="install -p" \
61         CP="cp -p" \
62         docdir=%{_docdir}/%{name} \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
66
67 install -d $RPM_BUILD_ROOT%{_localedir}
68 cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
69
70 %find_lang %{name}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %update_desktop_database
77
78 %postun
79 %update_desktop_database
80
81 %files -f %{name}.lang
82 %defattr(644,root,root,755)
83 %doc README
84 %doc usr/share/doc/byobu/*.txt
85 %dir %{_sysconfdir}/%{name}
86 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
87 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
88 %attr(755,root,root) %{_bindir}/byobu
89 %attr(755,root,root) %{_bindir}/byobu-config
90 %attr(755,root,root) %{_bindir}/byobu-ctrl-a
91 %attr(755,root,root) %{_bindir}/byobu-disable
92 %attr(755,root,root) %{_bindir}/byobu-disable-prompt
93 %attr(755,root,root) %{_bindir}/byobu-enable
94 %attr(755,root,root) %{_bindir}/byobu-enable-prompt
95 %attr(755,root,root) %{_bindir}/byobu-export
96 %attr(755,root,root) %{_bindir}/byobu-janitor
97 %attr(755,root,root) %{_bindir}/byobu-keybindings
98 %attr(755,root,root) %{_bindir}/byobu-launch
99 %attr(755,root,root) %{_bindir}/byobu-launcher
100 %attr(755,root,root) %{_bindir}/byobu-launcher-install
101 %attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
102 %attr(755,root,root) %{_bindir}/byobu-layout
103 %attr(755,root,root) %{_bindir}/byobu-prompt
104 %attr(755,root,root) %{_bindir}/byobu-quiet
105 %attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
106 %attr(755,root,root) %{_bindir}/byobu-screen
107 %attr(755,root,root) %{_bindir}/byobu-select-backend
108 %attr(755,root,root) %{_bindir}/byobu-select-profile
109 %attr(755,root,root) %{_bindir}/byobu-select-session
110 %attr(755,root,root) %{_bindir}/byobu-shell
111 %attr(755,root,root) %{_bindir}/byobu-silent
112 %attr(755,root,root) %{_bindir}/byobu-status
113 %attr(755,root,root) %{_bindir}/byobu-status-detail
114 %attr(755,root,root) %{_bindir}/byobu-tmux
115 %attr(755,root,root) %{_bindir}/byobu-ugraph
116 %attr(755,root,root) %{_bindir}/byobu-ulevel
117 %attr(755,root,root) %{_bindir}/col1
118 %attr(755,root,root) %{_bindir}/ctail
119 %attr(755,root,root) %{_bindir}/vigpg
120 %attr(755,root,root) %{_bindir}/wifi-status
121 %{_mandir}/man1/*.1*
122 %{_desktopdir}/%{name}.desktop
123 # preserve +x bits where needed
124 %defattr(-,root,root,-)
125 %{_libexecdir}/%{name}
126 %{_datadir}/%{name}
This page took 0.053144 seconds and 3 git commands to generate.