]> git.pld-linux.org Git - packages/byobu.git/blame - byobu.spec
add TerminalEmulator to desktop Categories
[packages/byobu.git] / byobu.spec
CommitLineData
2b3e186c
ZU
1Summary: A set of useful profiles and a profile-switcher for GNU screen
2Summary(hu.UTF-8): Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
2e06fbbb 3Summary(pl.UTF-8): Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
2b3e186c 4Name: byobu
c6331c1b 5Version: 5.111
691ed72a 6Release: 1
f896fdc8 7License: GPL v3
2b3e186c 8Group: Applications/System
f896fdc8 9Source0: https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
c6331c1b 10# Source0-md5: 286151043876bf9f7e884f95f706aa73
62082d7d 11Patch0: desktop.patch
f896fdc8 12URL: https://launchpad.net/byobu
d420996e 13BuildRequires: gettext-tools
d3ce91ff 14BuildRequires: rpm-pythonprov
f896fdc8
ER
15BuildRequires: rpmbuild(macros) >= 1.596
16Requires: desktop-file-utils
2e06fbbb 17Requires: python >= 1:2.5
dcd70459 18Requires: python-snack
58a24a03 19Suggests: screen
f1b85bf3 20Suggests: tmux >= 1.5
2b3e186c
ZU
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
a90e290a
ER
24%define _noautocompressdoc '*.txt'
25
f896fdc8
ER
26%define _libexecdir %{_prefix}/lib
27
2b3e186c
ZU
28%description
29Byobu is an elegant enhancement of the otherwise functional, plain,
30practical GNU Screen. Byobu includes an enhanced profile and
31configuration utilities for the GNU screen window manager, such as
32toggle-able system status notifications.
33
34%description -l hu.UTF-8
35Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
36praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
37és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
38ki/bekapcsolható rendszer státusz jelentéseket.
39
2e06fbbb
JB
40%description -l pl.UTF-8
41Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
42praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
43narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
44- takie jak przełączane powiadomienia o stanie systemu.
45
2b3e186c 46%prep
f896fdc8 47%setup -q
62082d7d 48%patch0 -p1
2b3e186c 49
a90e290a
ER
50%{__sed} -i -e '
51 s#/share/doc/byobu#/share/doc/%{name}-%{version}#
52' usr/share/byobu/keybindings/*
53
54# cleanup backups after patching
55find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
56
2b3e186c 57%build
f896fdc8
ER
58%configure
59%{__make}
60
61for po in po/*.po; do
62 lang=${po#po/}
63 lang=${lang%.po}
64 mkdir -p locale/${lang}/LC_MESSAGES/
65 msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
66done
2b3e186c
ZU
67
68%install
69rm -rf $RPM_BUILD_ROOT
f896fdc8
ER
70%{__make} install \
71 INSTALL="install -p" \
72 CP="cp -p" \
f896fdc8
ER
73 DESTDIR=$RPM_BUILD_ROOT
74
bf09bee7
ER
75# some debian hackery, just use the "current" one for pld
76install -d $RPM_BUILD_ROOT%{_desktopdir}
77mv $RPM_BUILD_ROOT{%{_datadir}/%{name}/desktop,%{_desktopdir}}/%{name}.desktop
bf09bee7 78
f896fdc8 79%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
2b3e186c 80
f896fdc8
ER
81install -d $RPM_BUILD_ROOT%{_localedir}
82cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
2b3e186c
ZU
83
84%find_lang %{name}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
f896fdc8
ER
89%post
90%update_desktop_database
91
92%postun
93%update_desktop_database
94
2b3e186c
ZU
95%files -f %{name}.lang
96%defattr(644,root,root,755)
f896fdc8
ER
97%doc README
98%doc usr/share/doc/byobu/*.txt
99%dir %{_sysconfdir}/%{name}
100%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
101%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
2b3e186c
ZU
102%attr(755,root,root) %{_bindir}/byobu
103%attr(755,root,root) %{_bindir}/byobu-config
f896fdc8
ER
104%attr(755,root,root) %{_bindir}/byobu-ctrl-a
105%attr(755,root,root) %{_bindir}/byobu-disable
106%attr(755,root,root) %{_bindir}/byobu-disable-prompt
107%attr(755,root,root) %{_bindir}/byobu-enable
108%attr(755,root,root) %{_bindir}/byobu-enable-prompt
2b3e186c 109%attr(755,root,root) %{_bindir}/byobu-export
f896fdc8
ER
110%attr(755,root,root) %{_bindir}/byobu-janitor
111%attr(755,root,root) %{_bindir}/byobu-keybindings
112%attr(755,root,root) %{_bindir}/byobu-launch
113%attr(755,root,root) %{_bindir}/byobu-launcher
114%attr(755,root,root) %{_bindir}/byobu-launcher-install
115%attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
116%attr(755,root,root) %{_bindir}/byobu-layout
117%attr(755,root,root) %{_bindir}/byobu-prompt
118%attr(755,root,root) %{_bindir}/byobu-quiet
119%attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
120%attr(755,root,root) %{_bindir}/byobu-screen
121%attr(755,root,root) %{_bindir}/byobu-select-backend
122%attr(755,root,root) %{_bindir}/byobu-select-profile
123%attr(755,root,root) %{_bindir}/byobu-select-session
124%attr(755,root,root) %{_bindir}/byobu-shell
125%attr(755,root,root) %{_bindir}/byobu-silent
2b3e186c
ZU
126%attr(755,root,root) %{_bindir}/byobu-status
127%attr(755,root,root) %{_bindir}/byobu-status-detail
f896fdc8
ER
128%attr(755,root,root) %{_bindir}/byobu-tmux
129%attr(755,root,root) %{_bindir}/byobu-ugraph
130%attr(755,root,root) %{_bindir}/byobu-ulevel
131%attr(755,root,root) %{_bindir}/col1
132%attr(755,root,root) %{_bindir}/ctail
bf09bee7
ER
133%attr(755,root,root) %{_bindir}/manifest
134%attr(755,root,root) %{_bindir}/purge-old-kernels
f896fdc8
ER
135%attr(755,root,root) %{_bindir}/vigpg
136%attr(755,root,root) %{_bindir}/wifi-status
137%{_mandir}/man1/*.1*
bf09bee7
ER
138/etc/profile.d/Z97-byobu.sh
139%{_datadir}/dbus-1/services/us.kirkland.terminals.byobu.service
50e506b4
ER
140%{_desktopdir}/%{name}.desktop
141# preserve +x bits where needed
142%defattr(-,root,root,-)
f896fdc8
ER
143%{_libexecdir}/%{name}
144%{_datadir}/%{name}
This page took 0.088379 seconds and 4 git commands to generate.