]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 2; verbose build by default; upstream nc fix; enable loadfont features in initrd
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define with_glibc 1
34 %endif
35 Summary:        Set of common Unix utilities for embeded systems
36 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 # stable line only
40 Version:        1.22.1
41 Release:        2
42 License:        GPL v2
43 Group:          Applications
44 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
45 # Source0-md5:  337d1a15ab1cb1d4ed423168b1eb7d7e
46 Source1:        %{name}.config
47 Source2:        %{name}-initrd.config
48 %{?with_altconfig:Source3:      %{cfgfile}}
49 Patch100:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
50 # Patch100-md5: 538d8cddbdfc449239b25a40bc8d1575
51 Patch101:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
52 # Patch101-md5: bc381f9ceb3824141c968f5bc4353943
53 Patch102:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
54 # Patch102-md5: 24686ec2750a8703feb57fc9c6aaed1d
55 Patch103:       http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
56 # Patch103-md5: 69eecaae5f812d08655dfdf34b60503f
57 Patch1:         %{name}-logconsole.patch
58 Patch2:         %{name}-printf-gettext.patch
59 Patch3:         %{name}-loadfont.patch
60 Patch4:         %{name}-kernel_headers.patch
61 Patch5:         %{name}-insmod-morearchs.patch
62 Patch6:         %{name}-dhcp.patch
63 Patch7:         %{name}-fix_64_archs.patch
64 Patch9:         %{name}-ash-export-PATH.patch
65 URL:            http://www.busybox.net/
66 BuildRequires:  gcc >= 3.2
67 BuildRequires:  perl-tools-pod
68 BuildRequires:  rpmbuild(macros) >= 1.652
69 %if %{with initrd} || %{with static}
70         %if %{with dietlibc}
71 BuildRequires:  dietlibc-static
72         %else
73                 %if %{with glibc}
74 BuildRequires:  glibc-static
75                 %else
76 %if "%{_target_base_arch}" != "%{_host_base_arch}"
77 BuildRequires:  cross%{_target_base_arch}-uClibc-static
78 %else
79         %ifarch ppc %{x8664}
80 BuildRequires:  uClibc-static >= 3:0.9.30.1
81         %else
82 BuildRequires:  uClibc-static >= 3:0.9.30.1
83         %endif
84 %endif
85                 %endif
86         %endif
87 %endif
88 %{?with_sh_prov:Provides:       /bin/sh}
89 %{?with_fileutl_prov:Provides:  fileutils}
90 %{?with_grep_prov:Provides:     grep}
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _bindir         /bin
94
95 %if "%{_target_base_arch}" != "%{_host_base_arch}"
96         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
97 %else
98         %define CrossOpts %{nil}
99 %endif
100
101 %define         filterout_ld    -Wl,-z,(combreloc|relro)
102
103 %description
104 BusyBox combines tiny versions of many common UNIX utilities into a
105 single small executable. It provides minimalist replacements for most
106 of the utilities you usually find in fileutils, shellutils, findutils,
107 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
108 POSIX environment for any small or embedded system. The utilities in
109 BusyBox generally have fewer options than their full-featured GNU
110 cousins; however, the options that are included provide the expected
111 functionality and behave very much like their GNU counterparts.
112
113 BusyBox has been written with size-optimization and limited resources
114 in mind. It is also extremely modular so you can easily include or
115 exclude commands (or features) at compile time. This makes it easy to
116 customize your embedded systems. To create a working system, just add
117 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
118 ae).
119
120 %description -l pl.UTF-8
121 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
122 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
123 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
124 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
125 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
126 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
127 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
128 (np. elvis-tiny albo ae).
129
130 %description -l pt_BR.UTF-8
131 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
132 executável, fornecendo substitutos minimalistas para muitos dos
133 executáveis encontrados em pacotes como fileutils, shellutils,
134 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
135 em geral têm menos opções que os utilitários GNU, mas as opções
136 implementadas comportam-se de maneira similar aos equivalentes GNU.
137
138 %package static
139 Summary:        Static busybox
140 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
141 Group:          Applications
142
143 %description static
144 Static busybox.
145
146 %description static -l pl.UTF-8
147 Statycznie skonsolidowany busybox.
148
149 %package initrd
150 Summary:        Static busybox for initrd
151 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
152 Group:          Base
153 Conflicts:      geninitrd < 10000.20
154
155 %description initrd
156 Static busybox for initrd.
157
158 %description initrd -l pl.UTF-8
159 Statycznie skonsolidowany busybox dla initrd.
160
161 %prep
162 %setup -q
163 %patch100 -p1
164 %patch101 -p1
165 %patch102 -p1
166 %patch103 -p1
167 %patch1 -p1
168 %patch2 -p1
169 #%patch3 -p1
170 %patch4 -p1
171 %patch5 -p1
172 %patch6 -p1
173 %patch7 -p1
174 %patch9 -p1
175
176 %build
177 install -d built
178 %if %{with initrd}
179 install %{SOURCE2} .config
180 %{__make} oldconfig
181 %{__make} \
182         %{?with_verbose:V=1} \
183         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
184         LDFLAGS="%{rpmldflags} -static" \
185 %if %{with dietlibc}
186         LIBRARIES="-lrpc" \
187         CC="diet %{__cc}"
188 %else
189 %if %{with glibc}
190         %{CrossOpts} \
191         CC="%{__cc}"
192 %else
193         %if "%{_target_base_arch}" != "%{_host_base_arch}"
194         CROSS="%{_target_cpu}-uclibc-" \
195         %endif
196         CC="%{_target_cpu}-uclibc-gcc"
197 %endif
198 %endif
199
200 mv -f busybox built/busybox.initrd
201 %{__make} clean
202 %endif
203
204 %if %{with altconfig}
205 install %{SOURCE3} .config
206 %else
207 install %{SOURCE1} .config
208 %endif
209
210 %if %{with static}
211 %{__make} oldconfig
212 %{__make} \
213         %{?with_verbose:V=1} \
214         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
215         LDFLAGS="%{rpmldflags} -static" \
216 %if %{with dietlibc}
217         LIBRARIES="-lrpc" \
218         CC="diet %{__cc}"
219 %else
220 %if %{with glibc}
221         %{CrossOpts} \
222         CC="%{__cc}"
223 %else
224         %if "%{_target_base_arch}" != "%{_host_base_arch}"
225         CROSS="%{_target_cpu}-uclibc-" \
226         %endif
227         CC="%{_target_cpu}-uclibc-gcc"
228 %endif
229 %endif
230
231 mv -f busybox built/busybox.static
232 %{__make} clean
233 %endif
234
235 %if %{with dynamic}
236 %{__make} oldconfig
237 %{__make} \
238         %{?with_verbose:V=1} \
239         %{CrossOpts} \
240         CFLAGS_EXTRA="%{rpmcflags}" \
241         LDFLAGS="%{rpmldflags}" \
242         CC="%{__cc}"
243 %{__make} busybox.links docs/busybox.1
244 %endif
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248
249 %if %{with static}
250 install -d $RPM_BUILD_ROOT%{_bindir}
251 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
252 %endif
253
254 %if %{with initrd}
255 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
256 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
257 %endif
258
259 %if %{with dynamic}
260 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
261 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
262 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
263
264 # install links to busybox binary, when linkfl is defined
265 %if %{with linkfl}
266 %{__make} install \
267         PREFIX=$RPM_BUILD_ROOT
268 %else
269 install busybox $RPM_BUILD_ROOT%{_bindir}
270 %endif
271 %endif
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %if %{with dynamic}
277 %files
278 %defattr(644,root,root,755)
279 %doc AUTHORS README .config
280
281 %if %{with linkfl}
282 %attr(755,root,root) /bin/*
283 %attr(755,root,root) /sbin/*
284 %attr(755,root,root) %{_bindir}/*
285 %attr(755,root,root) %{_sbindir}/*
286 %else
287 %attr(755,root,root) %{_bindir}/busybox
288 %endif
289
290 %{_libdir}/busybox
291 %{_mandir}/man1/busybox.1*
292 %endif
293
294 %if %{with static}
295 %files static
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_bindir}/busybox.static
298 %endif
299
300 %if %{with initrd}
301 %files initrd
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/initrd/busybox
304 %endif
This page took 0.075522 seconds and 3 git commands to generate.