]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- rel 2; verbose build by default; upstream nc fix; enable loadfont features in initrd
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
494a100b 21%bcond_without verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
33%define with_glibc 1
34%endif
dce89576 35Summary: Set of common Unix utilities for embeded systems
718bff43
ER
36Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
37Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 38Name: busybox
586f52e3 39# stable line only
6477eb94 40Version: 1.22.1
494a100b 41Release: 2
bbbc183d 42License: GPL v2
d79d7625 43Group: Applications
693dc2a0 44Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
6477eb94 45# Source0-md5: 337d1a15ab1cb1d4ed423168b1eb7d7e
4f8fe04f
AM
46Source1: %{name}.config
47Source2: %{name}-initrd.config
8f98fac8 48%{?with_altconfig:Source3: %{cfgfile}}
6477eb94
AM
49Patch100: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
50# Patch100-md5: 538d8cddbdfc449239b25a40bc8d1575
51Patch101: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
52# Patch101-md5: bc381f9ceb3824141c968f5bc4353943
53Patch102: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
54# Patch102-md5: 24686ec2750a8703feb57fc9c6aaed1d
494a100b
AM
55Patch103: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
56# Patch103-md5: 69eecaae5f812d08655dfdf34b60503f
b2b9509f 57Patch1: %{name}-logconsole.patch
58Patch2: %{name}-printf-gettext.patch
59Patch3: %{name}-loadfont.patch
29a4a582
JR
60Patch4: %{name}-kernel_headers.patch
61Patch5: %{name}-insmod-morearchs.patch
62Patch6: %{name}-dhcp.patch
63Patch7: %{name}-fix_64_archs.patch
29a4a582 64Patch9: %{name}-ash-export-PATH.patch
87902b66 65URL: http://www.busybox.net/
255676bf 66BuildRequires: gcc >= 3.2
839c36a5 67BuildRequires: perl-tools-pod
d41f35db 68BuildRequires: rpmbuild(macros) >= 1.652
ef0df9c1 69%if %{with initrd} || %{with static}
6f6b5afa 70 %if %{with dietlibc}
1735ff25 71BuildRequires: dietlibc-static
6f6b5afa 72 %else
73 %if %{with glibc}
1735ff25 74BuildRequires: glibc-static
6f6b5afa 75 %else
cbbddfaa 76%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 77BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 78%else
9922ba41 79 %ifarch ppc %{x8664}
c574afd9 80BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 81 %else
c574afd9 82BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 83 %endif
9a45af3a 84%endif
6f6b5afa 85 %endif
86 %endif
1735ff25 87%endif
a54ace54 88%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
89%{?with_fileutl_prov:Provides: fileutils}
90%{?with_grep_prov:Provides: grep}
ee61dafa
MM
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
e7982b05 93%define _bindir /bin
fc11b50f 94
cbbddfaa 95%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 96 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
97%else
98 %define CrossOpts %{nil}
99%endif
100
558ca139
JR
101%define filterout_ld -Wl,-z,(combreloc|relro)
102
ee61dafa 103%description
65512310 104BusyBox combines tiny versions of many common UNIX utilities into a
105single small executable. It provides minimalist replacements for most
106of the utilities you usually find in fileutils, shellutils, findutils,
107textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
108POSIX environment for any small or embedded system. The utilities in
109BusyBox generally have fewer options than their full-featured GNU
110cousins; however, the options that are included provide the expected
111functionality and behave very much like their GNU counterparts.
112
113BusyBox has been written with size-optimization and limited resources
114in mind. It is also extremely modular so you can easily include or
115exclude commands (or features) at compile time. This makes it easy to
116customize your embedded systems. To create a working system, just add
117a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
118ae).
ee61dafa 119
c499e458
JR
120%description -l pl.UTF-8
121BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
122wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 123zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
124tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
125lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
126odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
127systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
128(np. elvis-tiny albo ae).
129
c499e458
JR
130%description -l pt_BR.UTF-8
131BusyBox combina versões reduzidas de muitos utilitários UNIX num único
132executável, fornecendo substitutos minimalistas para muitos dos
133executáveis encontrados em pacotes como fileutils, shellutils,
134findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
135em geral têm menos opções que os utilitários GNU, mas as opções
68092394 136implementadas comportam-se de maneira similar aos equivalentes GNU.
137
34ec6041
JB
138%package static
139Summary: Static busybox
718bff43 140Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 141Group: Applications
34ec6041
JB
142
143%description static
144Static busybox.
145
c499e458 146%description static -l pl.UTF-8
dfafd31f 147Statycznie skonsolidowany busybox.
34ec6041 148
52db7bd4
MM
149%package initrd
150Summary: Static busybox for initrd
718bff43 151Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 152Group: Base
1857f402 153Conflicts: geninitrd < 10000.20
52db7bd4
MM
154
155%description initrd
156Static busybox for initrd.
157
c499e458 158%description initrd -l pl.UTF-8
dfafd31f 159Statycznie skonsolidowany busybox dla initrd.
52db7bd4 160
ee61dafa 161%prep
693dc2a0 162%setup -q
6477eb94
AM
163%patch100 -p1
164%patch101 -p1
165%patch102 -p1
494a100b 166%patch103 -p1
0b555ee8
JB
167%patch1 -p1
168%patch2 -p1
a54ace54 169#%patch3 -p1
0cf45dc5 170%patch4 -p1
0b555ee8 171%patch5 -p1
5a7abf9a 172%patch6 -p1
0b555ee8 173%patch7 -p1
586f52e3 174%patch9 -p1
ea0cda84 175
ee61dafa 176%build
839c36a5 177install -d built
52db7bd4 178%if %{with initrd}
4f8fe04f
AM
179install %{SOURCE2} .config
180%{__make} oldconfig
52db7bd4 181%{__make} \
91a4c8e3 182 %{?with_verbose:V=1} \
95f61a42 183 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 184 LDFLAGS="%{rpmldflags} -static" \
27ca3ce9 185%if %{with dietlibc}
52db7bd4 186 LIBRARIES="-lrpc" \
661e2e64 187 CC="diet %{__cc}"
1735ff25
MM
188%else
189%if %{with glibc}
9922ba41 190 %{CrossOpts} \
1735ff25 191 CC="%{__cc}"
27ca3ce9 192%else
cbbddfaa 193 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 194 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 195 %endif
27ca3ce9
AM
196 CC="%{_target_cpu}-uclibc-gcc"
197%endif
1735ff25
MM
198%endif
199
839c36a5 200mv -f busybox built/busybox.initrd
52db7bd4 201%{__make} clean
52db7bd4
MM
202%endif
203
1735ff25
MM
204%if %{with altconfig}
205install %{SOURCE3} .config
13fc95fb
ER
206%else
207install %{SOURCE1} .config
1735ff25
MM
208%endif
209
4a69c6c5 210%if %{with static}
4f8fe04f 211%{__make} oldconfig
6f6b5afa 212%{__make} \
91a4c8e3 213 %{?with_verbose:V=1} \
ef0df9c1 214 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 215 LDFLAGS="%{rpmldflags} -static" \
ef0df9c1
JR
216%if %{with dietlibc}
217 LIBRARIES="-lrpc" \
661e2e64 218 CC="diet %{__cc}"
ef0df9c1
JR
219%else
220%if %{with glibc}
221 %{CrossOpts} \
52db7bd4 222 CC="%{__cc}"
ef0df9c1 223%else
cbbddfaa 224 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 225 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 226 %endif
ef0df9c1
JR
227 CC="%{_target_cpu}-uclibc-gcc"
228%endif
229%endif
230
839c36a5 231mv -f busybox built/busybox.static
2481202a 232%{__make} clean
34ec6041 233%endif
2481202a 234
63de0802 235%if %{with dynamic}
b5011fd7 236%{__make} oldconfig
b7f899e9 237%{__make} \
91a4c8e3 238 %{?with_verbose:V=1} \
9922ba41 239 %{CrossOpts} \
b7f899e9 240 CFLAGS_EXTRA="%{rpmcflags}" \
63de0802 241 LDFLAGS="%{rpmldflags}" \
f5ad7fd6 242 CC="%{__cc}"
bf1f4257 243%{__make} busybox.links docs/busybox.1
63de0802 244%endif
4e2ab1f5 245
ee61dafa
MM
246%install
247rm -rf $RPM_BUILD_ROOT
b7f899e9 248
63de0802
JB
249%if %{with static}
250install -d $RPM_BUILD_ROOT%{_bindir}
251install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
252%endif
253
a71afd72
JR
254%if %{with initrd}
255install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 256install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 257%endif
34ec6041 258
63de0802
JB
259%if %{with dynamic}
260install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 261install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 262install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 263
d635bde0 264# install links to busybox binary, when linkfl is defined
4a69c6c5 265%if %{with linkfl}
2678f462 266%{__make} install \
5a7abf9a 267 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
268%else
269install busybox $RPM_BUILD_ROOT%{_bindir}
270%endif
63de0802 271%endif
d635bde0 272
ee61dafa
MM
273%clean
274rm -rf $RPM_BUILD_ROOT
275
63de0802 276%if %{with dynamic}
ee61dafa
MM
277%files
278%defattr(644,root,root,755)
a230e0df 279%doc AUTHORS README .config
d635bde0 280
4a69c6c5 281%if %{with linkfl}
77109ddb 282%attr(755,root,root) /bin/*
d635bde0 283%attr(755,root,root) /sbin/*
284%attr(755,root,root) %{_bindir}/*
285%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
286%else
287%attr(755,root,root) %{_bindir}/busybox
d635bde0 288%endif
289
65512310 290%{_libdir}/busybox
77109ddb 291%{_mandir}/man1/busybox.1*
63de0802 292%endif
bb4ca08e 293
4a69c6c5 294%if %{with static}
34ec6041
JB
295%files static
296%defattr(644,root,root,755)
297%attr(755,root,root) %{_bindir}/busybox.static
298%endif
52db7bd4
MM
299
300%if %{with initrd}
301%files initrd
302%defattr(644,root,root,755)
1857f402 303%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 304%endif
This page took 0.118901 seconds and 4 git commands to generate.