]> git.pld-linux.org Git - packages/bullet.git/blob - bullet.spec
- use undos macro to fix patching
[packages/bullet.git] / bullet.spec
1 Summary:        Bullet - vollision detection and rigid body dynamics library
2 Summary(pl.UTF-8):      Bullet - biblioteka wykrywania kolizji oraz dynamiki ciała sztywnego
3 Name:           bullet
4 Version:        2.77
5 Release:        1
6 License:        Zlib
7 Group:          Applications
8 Source0:        http://bullet.googlecode.com/files/%{name}-%{version}.tgz
9 # Source0-md5:  2f5074a1a29b618c672f1da4748e374b
10 Patch0:         %{name}-lib_suffix.patch
11 URL:            http://www.bulletphysics.com/Bullet/wordpress/
12 BuildRequires:  OpenGL-glut-devel
13 BuildRequires:  cmake
14 BuildRequires:  rpmbuild(macros) >= 1.600
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # better fix by proper linking
18 %define         skip_post_check_so      libBulletMultiThreaded.so.*
19
20 %description
21 Bullet is a collision detection and rigid nody dynamics library.
22
23 %description -l pl.UTF-8
24 Bullet to biblioteka wykrywania kolizji oraz dynamiki ciała sztywnego
25
26 %package devel
27 Summary:        Header files for bullet library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki bullet
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Header files for bullet library.
34
35 %description devel -l pl.UTF-8
36 Pliki nagłówkowe biblioteki bullet.
37
38 %prep
39 %setup -q
40 %undos src/MiniCL/CMakeLists.txt
41 %patch0 -p1
42
43 %build
44 mkdir build
45 cd build
46 %cmake \
47         -DBUILD_DEMOS=OFF \
48         -DBUILD_EXTRAS=ON \
49         -DINCLUDE_INSTALL_DIR=%{_includedir}/%{name} \
50         ..
51
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} -C build install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHORS ChangeLog NEWS README
69 %attr(755,root,root) %{_libdir}/libBulletCollision.so.*.*
70 %attr(755,root,root) %{_libdir}/libBulletDynamics.so.*.*
71 %attr(755,root,root) %{_libdir}/libBulletMultiThreaded.so.*.*
72 %attr(755,root,root) %{_libdir}/libBulletSoftBody.so.*.*
73 %attr(755,root,root) %{_libdir}/libBulletSoftBodySolvers_CPU.so.*.*
74 %attr(755,root,root) %{_libdir}/libLinearMath.so.*.*
75 %attr(755,root,root) %{_libdir}/libMiniCL.so.*.*
76
77 %files devel
78 %defattr(644,root,root,755)
79 %doc Bullet_User_Manual.pdf
80 %attr(755,root,root) %{_libdir}/libBulletCollision.so
81 %attr(755,root,root) %{_libdir}/libBulletDynamics.so
82 %attr(755,root,root) %{_libdir}/libBulletMultiThreaded.so
83 %attr(755,root,root) %{_libdir}/libBulletSoftBody.so
84 %attr(755,root,root) %{_libdir}/libBulletSoftBodySolvers_CPU.so
85 %attr(755,root,root) %{_libdir}/libLinearMath.so
86 %attr(755,root,root) %{_libdir}/libMiniCL.so
87 %{_includedir}/%{name}
88 %{_pkgconfigdir}/%{name}.pc
This page took 0.24096 seconds and 3 git commands to generate.