]> git.pld-linux.org Git - packages/btparser.git/blob - btparser.spec
- rebuild with binutils 2.29
[packages/btparser.git] / btparser.spec
1 Summary:        Parser and analyzer for backtraces produced by GDB
2 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
3 Name:           btparser
4 Version:        0.26
5 Release:        5
6 License:        GPL v2+
7 Group:          Development/Tools
8 Source0:        https://github.com/abrt/btparser/archive/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  22cb4fe5593344f0acac8936494141f6
10 URL:            https://github.com/abrt/btparser
11 %ifarch %{x8664}
12 BuildRequires:  binutils-static
13 %endif
14 BuildRequires:  glib2-devel >= 1:2.21
15 BuildRequires:  pkgconfig
16 BuildRequires:  python-devel
17 BuildRequires:  python-distribute
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xmlto
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Btparser is a backtrace parser and analyzer, which works with
27 backtraces produced by the GNU Project Debugger. It can parse a text
28 file with a backtrace to a tree of C structures, allowing to analyze
29 the threads and frames of the backtrace and work with them.
30
31 Btparser also contains some backtrace manipulation and extraction
32 routines:
33 - it can find a frame in the crash-time backtrace where the program
34   most likely crashed (a chance is that the function described in that
35   frame is buggy)
36 - it can produce a duplication hash of the backtrace, which helps to
37   discover that two crash-time backtraces are duplicates, triggered by
38   the same flaw of the code
39 - it can "rate" the backtrace quality, which depends on the number of
40   frames with and without the function name known (missing function name
41   is caused by missing debugging symbols)
42
43 %description -l pl.UTF-8
44 Btparser to analizator śladów wywołań (backtrace'ów), działający ze
45 śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
46 przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
47 na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
48
49 Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
50 wywołań:
51 - potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
52   najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to funkcja
53   w tej ramce zawiera błąd)
54 - potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
55   zadane ślady pośmiertne są duplikatami spowodowanymi tym samym błędem
56   w kodzie
57 - potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
58   bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
59   diagnostycznych)
60
61 %package libs
62 Summary:        Btparser library
63 Summary(pl.UTF-8):      Biblioteka btparser
64 Group:          Libraries
65 Requires:       glib2 >= 1:2.21
66
67 %description libs
68 Btparser library.
69
70 %description libs -l pl.UTF-8
71 Biblioteka btparser.
72
73 %package devel
74 Summary:        Header files for %{name} library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
76 Group:          Development/Libraries
77 Requires:       %{name}-libs = %{version}-%{release}
78 Requires:       glib2-devel >= 1:2.21
79
80 %description devel
81 Header files for %{name} library.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe biblioteki %{name}.
85
86 %package -n python-btparser
87 Summary:        Python bindings for %{name}
88 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki btparser
89 Group:          Libraries/Python
90 Requires:       %{name}-libs = %{version}-%{release}
91 Requires:       python-modules
92
93 %description -n python-btparser
94 Python bindings for %{name}.
95
96 %description -n python-btparser -l pl.UTF-8
97 Wiązania Pythona do biblioteki btparser.
98
99 %prep
100 %setup -q
101
102 %build
103 %configure \
104 %ifarch %{x8664}
105         --enable-fingerprints
106 %endif
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
117
118 %py_postclean
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog NEWS README RELEASE TODO
129 %attr(755,root,root) %{_bindir}/btparser
130 %{_mandir}/man1/btparser.1*
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libbtparser.so.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libbtparser.so
140 %{_includedir}/btparser
141 %{_pkgconfigdir}/btparser.pc
142
143 %files -n python-btparser
144 %defattr(644,root,root,755)
145 %dir %{py_sitedir}/btparser
146 %{py_sitedir}/btparser/__init__.py[co]
147 %attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.07326 seconds and 3 git commands to generate.