]> git.pld-linux.org Git - packages/btparser.git/blob - btparser.spec
- rebuild with binutils 2.24.51.0.1
[packages/btparser.git] / btparser.spec
1 Summary:        Parser and analyzer for backtraces produced by GDB
2 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
3 Name:           btparser
4 Version:        0.25
5 Release:        2
6 License:        GPL v2+
7 Group:          Development/Tools
8 Source0:        https://fedorahosted.org/released/btparser/%{name}-%{version}.tar.xz
9 # Source0-md5:  7fcf3f97dd6df827151638a41855c5bb
10 URL:            http://fedorahosted.org/btparser/
11 %ifarch %{x8664}
12 BuildRequires:  binutils-static
13 %endif
14 BuildRequires:  glib2-devel >= 1:2.21
15 BuildRequires:  pkgconfig
16 BuildRequires:  python-devel
17 BuildRequires:  python-distribute
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xmlto
22 BuildRequires:  xz
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Btparser is a backtrace parser and analyzer, which works with
28 backtraces produced by the GNU Project Debugger. It can parse a text
29 file with a backtrace to a tree of C structures, allowing to analyze
30 the threads and frames of the backtrace and work with them.
31
32 Btparser also contains some backtrace manipulation and extraction
33 routines:
34 - it can find a frame in the crash-time backtrace where the program
35   most likely crashed (a chance is that the function described in that
36   frame is buggy)
37 - it can produce a duplication hash of the backtrace, which helps to
38   discover that two crash-time backtraces are duplicates, triggered by
39   the same flaw of the code
40 - it can "rate" the backtrace quality, which depends on the number of
41   frames with and without the function name known (missing function
42   name is caused by missing debugging symbols)
43
44 %description -l pl.UTF-8
45 Btparser to analizator śladów wywołań (backtrace'ów), działający ze
46 śladami tworzonymi przez debugger GDB z projektu GNU. Potrafi
47 przetworzyć plik tekstowy ze śladem na drzewo struktur C, co pozwala
48 na analizę wątków oraz ramek śladu wywołań i dalszą pracę z nimi.
49
50 Btparser zawiera także trochę procedur do obróbki i wydobywania śladów
51 wywołań:
52 - potrafi znaleźć ramkę w pośmiertnym śladzie wywołań, w której
53   najprawdopodobniej nastąpiła wywrotka programu (możliwe, że to
54   funkcja w tej ramce zawiera błąd)
55 - potrafi utworzyć skrót (hasz) śladu, pozwalający wykryć, czy dwa
56   zadane ślady pośmiertne są duplikatami spowodowanymi tym samym
57   błędem w kodzie
58 - potrafi "ocenić jakość" śladów, zależną od liczby ramek ze znaną i
59   bez znanej nazwy funkcji (brak nazwy funkcji wynika z braku symboli
60   diagnostycznych)
61
62 %package libs
63 Summary:        Btparser library
64 Summary(pl.UTF-8):      Biblioteka btparser
65 Group:          Libraries
66 Requires:       glib2 >= 1:2.21
67
68 %description libs
69 Btparser library.
70
71 %description libs -l pl.UTF-8
72 Biblioteka btparser.
73
74 %package devel
75 Summary:        Header files for %{name} library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79 Requires:       glib2-devel >= 1:2.21
80
81 %description devel
82 Header files for %{name} library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki %{name}.
86
87 %package -n python-btparser
88 Summary:        Python bindings for %{name}
89 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki btparser
90 Group:          Libraries/Python
91 Requires:       %{name}-libs = %{version}-%{release}
92 Requires:       python-modules
93
94 %description -n python-btparser
95 Python bindings for %{name}.
96
97 %description -n python-btparser -l pl.UTF-8
98 Wiązania Pythona do biblioteki btparser.
99
100 %prep
101 %setup -q
102
103 %build
104 %configure \
105 %ifarch %{x8664}
106         --enable-fingerprints
107 %endif
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
118
119 %py_postclean
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   libs -p /sbin/ldconfig
125 %postun libs -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ChangeLog NEWS README RELEASE TODO
130 %attr(755,root,root) %{_bindir}/btparser
131 %{_mandir}/man1/btparser.1*
132
133 %files libs
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libbtparser.so.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libbtparser.so
141 %{_includedir}/btparser
142 %{_pkgconfigdir}/btparser.pc
143
144 %files -n python-btparser
145 %defattr(644,root,root,755)
146 %dir %{py_sitedir}/btparser
147 %{py_sitedir}/btparser/__init__.py[co]
148 %attr(755,root,root) %{py_sitedir}/btparser/_btparser.so
This page took 0.055305 seconds and 3 git commands to generate.