]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- added at-spi2 bcond/BR
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #       - ocaml bcond is useless now:
4 #               Cannot find ocamlfind.
5 #               BrlAPI Caml bindings will be compiled but not installed.
6 #       - check java stuff
7 #       - create bcond to build with minimal deps (wo ncurses,gpm,at-spi*)
8 #
9 # warning: Installed (but unpackaged) file(s) found:
10 #    /usr/lib/ocaml/brlapi/META
11 #    /usr/lib/ocaml/brlapi/brlapi.cma
12 #    /usr/lib/ocaml/brlapi/brlapi.cmi
13 #    /usr/lib/ocaml/brlapi/brlapi.cmxa
14 #    /usr/lib/ocaml/brlapi/brlapi.mli
15 #    /usr/lib/ocaml/brlapi/libbrlapi_stubs.a
16 #    /usr/lib/ocaml/stublibs/dllbrlapi_stubs.so
17 #    /usr/lib/ocaml/stublibs/dllbrlapi_stubs.so.owner
18 #    /usr/share/man/man1/xbrlapi.1.gz
19 #
20 # Conditional build:
21 %bcond_without  apidocs         # documentation generated with doxygen
22 %bcond_with     java            # java bindings
23 %bcond_with     ocaml           # ocaml bindings (NFY)
24 %bcond_without  python          # python bindings
25 %bcond_without  tcl             # tcl bindings
26 %bcond_without  x               # build X11-based utilities
27 %bcond_without  speech_dispatcher       # build without speech-dispatcher driver
28 %bcond_without  at_spi2         # build without AtSpi2 driver
29 #
30 %include        /usr/lib/rpm/macros.java
31 Summary:        Braille display driver for Linux/Unix
32 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
33 Name:           brltty
34 Version:        4.2
35 Release:        1
36 Group:          Daemons
37 License:        GPL
38 Source0:        http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
39 # Source0-md5:  192af5e634210616928496645e392097
40 Patch0:         %{name}-stat.patch
41 URL:            http://mielke.cc/brltty/
42 BuildRequires:  at-spi-devel
43 BuildRequires:  autoconf >= 2.62
44 BuildRequires:  automake
45 BuildRequires:  bison
46 #BuildRequires: bluez-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 BuildRequires:  gpm-devel
50 %{?with_java:BuildRequires:     jdk}
51 BuildRequires:  ncurses-devel
52 %{?with_ocaml:BuildRequires:    ocaml}
53 BuildRequires:  pkgconfig
54 %{?with_python:BuildRequires:   python-Pyrex}
55 %{?with_java:BuildRequires:     rpm-javaprov}
56 %{?with_python:BuildRequires:   rpm-pythonprov}
57 %{?with_tcl:BuildRequires:      tcl-devel}
58 %{?with_x:BuildRequires:        xorg-lib-libXaw-devel}
59 %{?with_x:BuildRequires:        xorg-lib-libXtst-devel}
60 # libbrlttyblb
61 #BR: libbraile-devel (-lllibbraile <braille.h>)
62 # libbrlttysfl
63 BuildRequires:  flite-devel
64 # libbrlttysmp
65 #BR: Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)
66 # libbrlttyssd
67 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel}
68 # libbrlttyssw
69 #BR: Swift-devel (-lswift <swift.h>)
70 # libbrlttysth
71 #BR: Theta-devel (-ltheta <theta.h>)
72 # libbrlttysvv
73 #BR: ViaVoice-devel (-lviavoice <eci.h>)
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 BRLTTY is a background process (daemon) which provides access to the
78 Linux/Unix console (when in text mode) for a blind person using a
79 refreshable Braille display. It drives the Braille display, and
80 provides complete screen review functionality. Some speech capability
81 has also been incorporated.
82
83 %description -l pl.UTF-8
84 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
85 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
86 odświeżaniem (refreshable Braille display). BRLTTY steruje
87 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
88 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
89 mowy.
90
91 %package -n brlapi
92 Summary:        Application Programming Interface for BRLTTY
93 Summary(pl.UTF-8):      API do BRLTTY
94 Group:          Applications/System
95
96 %description -n brlapi
97 This package provides the run-time support for the Application
98 Programming Interface to BRLTTY.
99
100 Install this package if you have an application which directly
101 accesses a refreshable Braille display.
102
103 %description -n brlapi -l pl.UTF-8
104 Ten pakiet zawiera środowisko uruchomieniowe dla programów
105 korzystających z API BRLTTY.
106
107 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
108 wyświetlacza Braille'a z odświeżaniem.
109
110 %package -n brlapi-devel
111 Summary:        Headers and documentation for BrlAPI
112 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
113 Group:          Development/Libraries
114 Requires:       brlapi = %{version}-%{release}
115
116 %description -n brlapi-devel
117 This package provides the header files, shared object linker
118 reference, and reference documentation for BrlAPI (the Application
119 Programming Interface to BRLTTY). It enables the implementation of
120 applications which take direct advantage of a refreshable Braille
121 display in order to present information in ways which are more
122 appropriate for blind users and/or to provide user interfaces which
123 are more specifically atuned to their needs.
124
125 Install this package if you're developing or maintaining an
126 application which directly accesses a refreshable Braille display.
127
128 %description -n brlapi-devel -l pl.UTF-8
129 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
130 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
131 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
132 bardziej przystosowany dla osób niewidomych.
133
134 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
135 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
136
137 %package -n brlapi-static
138 Summary:        Static BrlAPI library
139 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
140 Group:          Development/Libraries
141 Requires:       brlapi-devel = %{version}-%{release}
142
143 %description -n brlapi-static
144 This is package with static BrlAPI library.
145
146 %description -n brlapi-static -l pl.UTF-8
147 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
148
149 %package -n brlapi-apidocs
150 Summary:        BrlAPI documentation
151 Summary(pl.UTF-8):      Documentacja BrlAPI
152 Group:          Documentation
153
154 %description -n brlapi-apidocs
155 Documentation for BrlAPI in HTML format generated from brltty
156 sources by doxygen.
157
158 %description -n brlapi-apidocs -l pl.UTF-8
159 Dokumentacja BrlAPI w formacie HTML generowane ze
160 źrodeł brltty przez doxygen.
161
162 %package -n java-brlapi
163 Summary:        BrlAPI library for Java
164 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
165 Group:          Libraries
166 Requires:       brlapi = %{version}-%{release}
167
168 %description -n java-brlapi
169 BrlAPI library for Java.
170
171 %description -n java-brlapi -l pl.UTF-8
172 Biblioteka BrlAPI dla Javy.
173
174 %package -n python-brlapi
175 Summary:        Python interface to BrlAPI
176 Summary(pl.UTF-8):      Pythonowy interfejs do BrlAPI
177 Group:          Libraries
178 Requires:       brlapi = %{version}-%{release}
179
180 %description -n python-brlapi
181 Python interface to BrlAPI.
182
183 %description -n python-brlapi -l pl.UTF-8
184 Pythonowy interfejs do BrlAPI.
185
186 %package -n brlapi-tcl
187 Summary:        BrlAPI library for Tcl
188 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
189 Group:          Libraries
190 Requires:       brlapi = %{version}-%{release}
191
192 %description -n brlapi-tcl
193 BrlAPI library for Tcl.
194
195 %description -n brlapi-tcl -l pl.UTF-8
196 Biblioteka BrlAPI dla Tcl.
197
198 %prep
199 %setup -q
200 %patch0 -p1
201
202 %build
203 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
204 %configure \
205         --with-install-root="$RPM_BUILD_ROOT" \
206         %{!?with_java:--disable-java-bindings} \
207         --enable-api
208
209 %{__make} -j1
210
211 directory="doc"
212 mkdir -p "$directory"
213 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
214 do
215         mkdir -p "$directory/${file%/*}"
216         cp -rp "$file" "$directory/$file"
217 done
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 %{__make} -j1 install
222 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
223
224 %clean
225 rm -rf $RPM_BUILD_ROOT
226
227 %pre
228 # The pre-install scriptlet.
229
230 # If a configuration file already exists then rpm installs the new one as
231 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
232 # already exists.
233
234 # There's no explicit way to tell if a configuration file has been installed
235 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
236 # erasing the .rpmnew file now so that we can see if it gets created later.
237 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
238
239 %post
240 # The post-install scriptlet.
241
242 # If BRLTTY's boot parameter has been specified then update the just installed
243 # configuration file template to reflect the options supplied thereby.
244
245 # First, we need to determine which file to update. If there's a .rpmnew file
246 # then update it since a previous configuration file must already have existed.
247 file="%{_sysconfdir}/brltty.conf"
248 new="${file}.rpmnew"
249 [ -f "${new}" ] && file="${new}"
250
251 # Update the configuration file template via the Bootdisks/bp2cf script.
252 # Include it right within this scriptlet so that it needn't be installed.
253 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
254 (
255         # First, set bp2cf's command line arguments.
256         set -- -u -f "${file}"
257
258 #!/bin/sh
259 ###############################################################################
260 # BRLTTY - A background process providing access to the Linux console (when in
261 #          text mode) for a blind person using a refreshable Braille display.
262 #
263 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
264 #
265 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
266 #
267 # This is free software, placed under the terms of the
268 # GNU General Public License, as published by the Free Software
269 # Foundation.  Please see the file COPYING for details.
270 #
271 # Web Page: http://mielke.cc/brltty/
272 #
273 # This software is maintained by Dave Mielke <dave@mielke.cc>.
274 ###############################################################################
275
276 # Convert the boot parameter to configuration file directives.
277 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
278 # If /proc is not mounted then use the brltty environment variable.
279 # Invoke with -h for usage information.
280
281 programName="${0##*/}"
282 programMessage()
283 {
284         echo 2>&1 "${programName}: ${1}"
285 }
286 syntaxError()
287 {
288         programMessage "${1}"
289         exit 2
290 }
291 internalError()
292 {
293         programMessage "${1}"
294         exit 3
295 }
296
297 configurationFile=""
298 requestedAction=create
299 deviceTranslation=none
300 requestedParameter=""
301 OPTIND=1
302 while getopts ":f:cundop:h" option
303 do
304         case "${option}" in
305             f) configurationFile="${OPTARG}";;
306             c) requestedAction=create;;
307             u) requestedAction=update;;
308             n) deviceTranslation=none;;
309             d) deviceTranslation=devfs;;
310             o) deviceTranslation=old;;
311             p) requestedParameter="${OPTARG}";;
312             h)
313                 cat <<EOF
314 Usage: ${programName} [option ...]
315 -f file  The configuration file to create/update.
316 -c       Create the configuration file (write to stdout if no -f).
317 -u       Update the configuration file (copying from stdin to stdout if no -f).
318 -n       Do not translate device paths.
319 -d       Do old-style to devfs device path translation.
320 -o       Do devfs to old-style device path translation.
321 -p [driver][,[device][,[table]]]
322          Explicitly specify the boot parameter.
323 -h       Display this usage summary.
324 EOF
325                 exit 0
326                 ;;
327             \?) syntaxError "unknown option: -${OPTARG}";;
328             :) syntaxError "missing value: -${OPTARG}";;
329             *) internalError "unimplemented option: -${option}";;
330         esac
331 done
332 shift "`expr $OPTIND - 1`"
333 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
334
335 case "${requestedAction}" in
336     create)
337         putConfigurationLine()
338         {
339                 echo "${1}" || exit 4
340         }
341         startConfigurationFile()
342         {
343                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
344                 putConfigurationLine "`makeHeaderLine Created`"
345                 putConfigurationLine "`makeParameterLine`"
346                 putConfigurationLine ""
347         }
348         putConfigurationDirective()
349         {
350                 putConfigurationLine "${1} ${2}"
351         }
352         finalizeConfigurationFile()
353         {
354                 :
355         }
356         ;;
357     update)
358         putSedCommand()
359         {
360                 sedScript="${sedScript}
361 ${1}"
362         }
363         startConfigurationFile()
364         {
365                 if [ -n "${configurationFile}" ]; then
366                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
367                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
368                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
369                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
370                         outputFile="${configurationFile}.new"
371                         exec <"${configurationFile}" >"${outputFile}"
372                 fi
373                 sedScript=""
374                 putSedCommand "1i\\
375 `makeHeaderLine Updated`\\
376 `makeParameterLine`\\
377 "
378         }
379         putConfigurationDirective()
380         {
381                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
382                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
383                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
384         }
385         finalizeConfigurationFile()
386         {
387                 sed -e "${sedScript}"
388                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
389         }
390         ;;
391     *) internalError "unimplemented action: ${requestedAction}";;
392 esac
393
394 translateDevice_none()
395 {
396         :
397 }
398 translateDevice_devfs()
399 {
400         minor="${device#ttyS}"
401         if [ "${minor}" != "${device}" ]; then
402                 device="tts/${minor}"
403                 return 0
404         fi
405         minor="${device#lp}"
406         if [ "${minor}" != "${device}" ]; then
407                 device="printers/${minor}"
408                 return 0
409         fi
410         programMessage "unsupported old-style device: ${device}"
411 }
412 translateDevice_old()
413 {
414         major="${device%%/*}"
415         if [ "${major}" != "${device}" ]; then
416                 minor="${device#*/}"
417                 case "${major}" in
418                     tts) devfs="ttyS${minor}";;
419                     printers) devfs="lp${minor}";;
420                 esac
421         fi
422         if [ -n "${devfs}" ]; then
423                 device="${devfs}"
424         else
425                 programMessage "unsupported devfs device: ${device}"
426         fi
427 }
428
429 makeHeaderLine()
430 {
431         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
432 }
433 makeParameterLine()
434 {
435         echo "# Boot Parameter:${bootParameter}"
436 }
437 putConfigurationFile()
438 {
439         startConfigurationFile
440         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
441         [ -n "${brailleDevice}" ] && {
442         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
443         if [ "${device#/}" = "${device}" ]; then
444                 translateDevice_${deviceTranslation}
445         fi
446         putConfigurationDirective "braille-device" "${device}"
447         }
448         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
449         finalizeConfigurationFile
450 }
451 parseBootParameter()
452 {
453         bootParameter="${bootParameter} ${1}"
454         number=1
455         while [ "${number}" -le 3 ]; do
456                 cut="cut -d, -f${number}"
457                 [ "${number}" -gt 1 ] && cut="${cut} -s"
458                 operand="`echo ${1} | ${cut}`"
459                 if [ -n "${operand}" ]; then
460                         case "${number}" in
461                             1) brailleDriver="${operand}";;
462                             2) brailleDevice="${operand}";;
463                             3) textTable="${operand}";;
464                         esac
465                 fi
466                 number="`expr ${number} + 1`"
467         done
468 }
469 putBootParameter()
470 {
471         parseBootParameter "${1}"
472         putConfigurationFile
473 }
474 parseBootCommand()
475 {
476         found=false
477         while [ "${#}" -gt 0 ]; do
478                 case "${1}" in
479                     "brltty="*)
480                         found=true
481                         parseBootParameter "${1#*=}"
482                         ;;
483                 esac
484                 shift
485         done
486         "${found}" && putConfigurationFile
487 }
488
489 brailleDriver=""
490 brailleDevice=""
491 textTable=""
492 bootCommandFile="/proc/cmdline"
493 if [ -n "${requestedParameter}" ]; then
494         putBootParameter "${requestedParameter}"
495 elif [ -f "${bootCommandFile}" ]; then
496         parseBootCommand `cat "${bootCommandFile}"`
497 elif [ -n "${brltty}" ]; then
498         putBootParameter "${brltty}"
499 fi
500 exit 0
501 )
502
503 %post   -n brlapi -p /sbin/ldconfig
504 %postun -n brlapi -p /sbin/ldconfig
505
506 %files
507 %defattr(644,root,root,755)
508 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
509 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
510 %attr(755,root,root) %{_bindir}/brltty
511 %attr(755,root,root) %{_bindir}/brltty-install
512 %attr(755,root,root) %{_bindir}/brltty-config
513 %attr(755,root,root) %{_bindir}/vstp
514 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
515 %dir %{_libdir}/brltty
516 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
517 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
518 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
519 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
520 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
521 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
522 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
523 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
524 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
525 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
526 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
527 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
528 %attr(755,root,root) %{_libdir}/brltty/libbrlttybil.so
529 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
530 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
531 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
532 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
533 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
534 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
535 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
536 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
537 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
538 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
539 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
540 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
541 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
542 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
543 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
544 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
545 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so
546 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
547 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
548 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so
549 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
550 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
551 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
552 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
553 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
554 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
555 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
556 %attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so
557 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
558 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
559
560 %{_sysconfdir}/brltty
561 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
562 %{_mandir}/man1/brltty.1*
563 %{_mandir}/man1/vstp.1*
564 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
565
566 %files -n brlapi
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/libbrlapi.so.0.5.5
569 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.5
570
571 %files -n brlapi-devel
572 %defattr(644,root,root,755)
573 %doc Documents/Manual-BrlAPI/English/BrlAPI*
574 %attr(755,root,root) %{_libdir}/libbrlapi.so
575 %{_includedir}/brltty
576 %{_includedir}/brlapi*.h
577 %{_mandir}/man3/*
578
579 %files -n brlapi-static
580 %defattr(644,root,root,755)
581 %{_libdir}/libbrlapi.a
582
583 %if %{with apidocs}
584 %files -n brlapi-apidocs
585 %defattr(644,root,root,755)
586 %doc Documents/BrlAPIref/html/*
587 %endif
588
589 %if %{with java}
590 %files -n java-brlapi
591 %defattr(644,root,root,755)
592 %{_libdir}/java/libbrlapi_java.so
593 %{_javadir}/brlapi.jar
594 %endif
595
596 %if %{with python}
597 %files -n python-brlapi
598 %defattr(644,root,root,755)
599 %{py_sitedir}/Brlapi-*.egg-info
600 %attr(755,root,root) %{py_sitedir}/brlapi.so
601 %endif
602
603 %if %{with tcl}
604 %files -n brlapi-tcl
605 %defattr(644,root,root,755)
606 %dir %{_libdir}/brlapi-0.5.5
607 %attr(755,root,root) %{_libdir}/brlapi-0.5.5/libbrlapi_tcl.so
608 %{_libdir}/brlapi-0.5.5/pkgIndex.tcl
609 %endif
This page took 0.071114 seconds and 3 git commands to generate.