]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
Release 4 (by relup.sh)
[packages/brltty.git] / brltty.spec
1 # TODO: user/group (see Autostart/Systemd/sysusers)
2 #
3 # Conditional build:
4 %bcond_without  apidocs                 # documentation generated with doxygen
5 %bcond_without  java                    # Java bindings
6 %bcond_without  ocaml                   # OCaml bindings
7 %bcond_without  python                  # Python bindings
8 %bcond_without  python3                 # Python 3.x bindings
9 %bcond_without  tcl                     # Tcl bindings
10 %bcond_without  x                       # X11-based utilities
11 %bcond_without  gpm                     # mouse tracking via GPM
12 %bcond_without  libbraille              # libbraille Braille driver
13 %bcond_without  liblouis                # liblouis in-line contracted Braille support
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  espeak_ng               # eSpeak-NG synthesizer driver
16 %bcond_without  flite                   # Flite synthesizer driver
17 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
18 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
19 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
20 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
21 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
22 %bcond_with     at_spi                  # AtSpi screen driver
23 %bcond_without  at_spi2                 # AtSpi2 screen driver
24
25 %define         brlapi_ver      0.8.3
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        6.4
30 Release:        4
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  6400b2b6cb8bbbb31d850a24903ddb67
35 Patch1:         %{name}-speech-dispatcher.patch
36 Patch4:         %{name}-glibc25.patch
37 URL:            http://mielke.cc/brltty/
38 BuildRequires:  alsa-lib-devel
39 %{?with_at_spi:BuildRequires:   at-spi-devel}
40 %{?with_at_spi2:BuildRequires:  at-spi2-core-devel >= 2.0}
41 BuildRequires:  autoconf >= 2.64
42 BuildRequires:  automake
43 BuildRequires:  bison
44 # just headers
45 BuildRequires:  bluez-libs-devel
46 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
47 %{?with_apidocs:BuildRequires:  doxygen}
48 %{?with_espeak:BuildRequires:   espeak-devel}
49 %{?with_espeak_ng:BuildRequires:        espeak-ng-devel}
50 BuildRequires:  expat-devel
51 %{?with_flite:BuildRequires:    flite-devel}
52 BuildRequires:  gettext-tools
53 %{?with_at_spi2:BuildRequires:  glib2-devel >= 2.0}
54 %{?with_gpm:BuildRequires:      gpm-devel}
55 %{?with_java:BuildRequires:     jdk}
56 %{?with_java:BuildRequires:     jpackage-utils}
57 %{?with_libbraille:BuildRequires:       libbraille-devel}
58 BuildRequires:  libicu-devel
59 %{?with_liblouis:BuildRequires: liblouis-devel}
60 BuildRequires:  ncurses-devel
61 %{?with_ocaml:BuildRequires:    ocaml}
62 BuildRequires:  pcre2-32-devel
63 BuildRequires:  pkgconfig
64 BuildRequires:  polkit-devel
65 %{?with_python:BuildRequires:   python-Cython}
66 %{?with_python3:BuildRequires:  python3-Cython}
67 %{?with_java:BuildRequires:     rpm-javaprov}
68 %{?with_python:BuildRequires:   rpm-pythonprov}
69 BuildRequires:  rpmbuild(macros) >= 1.714
70 BuildRequires:  sed >= 4.0
71 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
72 BuildRequires:  systemd-devel >= 1:209
73 BuildRequires:  tar >= 1:1.22
74 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
75 %if %{with x}
76 BuildRequires:  xorg-lib-libX11-devel
77 BuildRequires:  xorg-lib-libXaw-devel
78 BuildRequires:  xorg-lib-libXext-devel
79 BuildRequires:  xorg-lib-libXfixes-devel
80 BuildRequires:  xorg-lib-libXt-devel
81 BuildRequires:  xorg-lib-libXtst-devel
82 %endif
83 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
84 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
85 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
86 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
87 BuildRequires:  xz
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %description
91 BRLTTY is a background process (daemon) which provides access to the
92 Linux/Unix console (when in text mode) for a blind person using a
93 refreshable Braille display. It drives the Braille display, and
94 provides complete screen review functionality. Some speech capability
95 has also been incorporated.
96
97 %description -l pl.UTF-8
98 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
99 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
100 odświeżaniem (refreshable Braille display). BRLTTY steruje
101 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
102 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
103 mowy.
104
105 %package -n dracut-brltty
106 Summary:        Braille support for Dracut
107 Summary(pl.UTF-8):      Obsługa Braille'a dla Dracuta
108 Group:          Applications/Text
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       dracut
111
112 %description -n dracut-brltty
113 Braille support for Dracut.
114
115 %description -n dracut-brltty -l pl.UTF-8
116 Obsługa Braille'a dla Dracuta.
117
118 %package -n brlapi
119 Summary:        Application Programming Interface for BRLTTY
120 Summary(pl.UTF-8):      API do BRLTTY
121 License:        LGPL v2.1+
122 Group:          Libraries
123
124 %description -n brlapi
125 This package provides the run-time support for the Application
126 Programming Interface to BRLTTY.
127
128 Install this package if you have an application which directly
129 accesses a refreshable Braille display.
130
131 %description -n brlapi -l pl.UTF-8
132 Ten pakiet zawiera środowisko uruchomieniowe dla programów
133 korzystających z API BRLTTY.
134
135 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
136 wyświetlacza Braille'a z odświeżaniem.
137
138 %package -n brlapi-devel
139 Summary:        Headers and documentation for BrlAPI
140 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
141 License:        LGPL v2.1+
142 Group:          Development/Libraries
143 Requires:       brlapi = %{version}-%{release}
144
145 %description -n brlapi-devel
146 This package provides the header files, shared object linker
147 reference, and reference documentation for BrlAPI (the Application
148 Programming Interface to BRLTTY). It enables the implementation of
149 applications which take direct advantage of a refreshable Braille
150 display in order to present information in ways which are more
151 appropriate for blind users and/or to provide user interfaces which
152 are more specifically atuned to their needs.
153
154 Install this package if you're developing or maintaining an
155 application which directly accesses a refreshable Braille display.
156
157 %description -n brlapi-devel -l pl.UTF-8
158 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
159 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
160 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
161 bardziej przystosowany dla osób niewidomych.
162
163 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
164 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
165
166 %package -n brlapi-static
167 Summary:        Static BrlAPI library
168 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
169 License:        LGPL v2.1+
170 Group:          Development/Libraries
171 Requires:       brlapi-devel = %{version}-%{release}
172
173 %description -n brlapi-static
174 This is package with static BrlAPI library.
175
176 %description -n brlapi-static -l pl.UTF-8
177 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
178
179 %package -n brlapi-apidocs
180 Summary:        BrlAPI documentation
181 Summary(pl.UTF-8):      Documentacja BrlAPI
182 Group:          Documentation
183 BuildArch:      noarch
184
185 %description -n brlapi-apidocs
186 Documentation for BrlAPI in HTML format generated from brltty sources
187 by doxygen.
188
189 %description -n brlapi-apidocs -l pl.UTF-8
190 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
191 doxygen.
192
193 %package -n java-brlapi
194 Summary:        BrlAPI library for Java
195 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
196 License:        LGPL v2.1+
197 Group:          Libraries
198 Requires:       brlapi = %{version}-%{release}
199
200 %description -n java-brlapi
201 BrlAPI library for Java.
202
203 %description -n java-brlapi -l pl.UTF-8
204 Biblioteka BrlAPI dla Javy.
205
206 %package -n ocaml-brlapi
207 Summary:        OCaml binding for BrlAPI
208 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
209 License:        LGPL v2.1+
210 Group:          Libraries
211 Requires:       brlapi = %{version}-%{release}
212 %requires_eq    ocaml-runtime
213
214 %description -n ocaml-brlapi
215 OCaml binding for BrlAPI.
216
217 %description -n ocaml-brlapi -l pl.UTF-8
218 Wiązania OCamla do BrlAPI.
219
220 %package -n ocaml-brlapi-devel
221 Summary:        OCaml binding for BrlAPI - development files
222 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
223 License:        LGPL v2.1+
224 Group:          Libraries
225 Requires:       ocaml-brlapi = %{version}-%{release}
226 %requires_eq    ocaml
227
228 %description -n ocaml-brlapi-devel
229 OCaml binding for BrlAPI - development files.
230
231 %description -n ocaml-brlapi-devel -l pl.UTF-8
232 Wiązania OCamla do BrlAPI - pliki programistyczne.
233
234 %package -n python-brlapi
235 Summary:        Python 2.x interface to BrlAPI
236 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
237 License:        LGPL v2.1+
238 Group:          Libraries
239 Requires:       brlapi = %{version}-%{release}
240
241 %description -n python-brlapi
242 Python 2.x interface to BrlAPI.
243
244 %description -n python-brlapi -l pl.UTF-8
245 Interfejs Pythona 2.x do BrlAPI.
246
247 %package -n python3-brlapi
248 Summary:        Python 3.x interface to BrlAPI
249 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
250 License:        LGPL v2.1+
251 Group:          Libraries
252 Requires:       brlapi = %{version}-%{release}
253
254 %description -n python3-brlapi
255 Python 3.x interface to BrlAPI.
256
257 %description -n python3-brlapi -l pl.UTF-8
258 Interfejs Pythona 3.x do BrlAPI.
259
260 %package -n brlapi-tcl
261 Summary:        BrlAPI library for Tcl
262 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
263 License:        LGPL v2.1+
264 Group:          Libraries
265 Requires:       brlapi = %{version}-%{release}
266
267 %description -n brlapi-tcl
268 BrlAPI library for Tcl.
269
270 %description -n brlapi-tcl -l pl.UTF-8
271 Biblioteka BrlAPI dla Tcl.
272
273 %prep
274 %setup -q
275 %patch1 -p1
276 #patch2 -p1
277 %patch4 -p1
278
279 %{__sed} -i -e '1s,/usr/bin/python$,%{__python},' Tables/Contraction/latex-access.ctb
280
281 %build
282 %{__aclocal} -I m4
283 %{__autoconf}
284 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
285 %configure \
286         %{?with_java:JAVA_HOME=%{java_home}} \
287         --with-install-root="$RPM_BUILD_ROOT" \
288         %{!?with_libbraille:--without-libbraille} \
289         %{!?with_espeak:--without-espeak} \
290         %{!?with_espeak_ng:--without-espeak_ng} \
291         %{!?with_flite:--without-flite} \
292         %{!?with_speech_dispatcher:--without-speechd} \
293         %{!?with_ocaml:--disable-caml-bindings} \
294         %{!?with_gpm:--disable-gpm} \
295         %{!?with_java:--disable-java-bindings} \
296         %{!?with_liblouis:--disable-liblouis} \
297         --enable-lisp-bindings \
298         %{!?with_python:--disable-python-bindings} \
299         %{!?with_tcl:--disable-tcl-bindings} \
300         %{!?with_x:--disable-x} \
301         --enable-api
302
303 %{__make} -j1
304
305 %if %{with python}
306 cd Bindings/Python
307 %py_build
308 cd ../..
309 %endif
310
311 %if %{with python3}
312 cd Bindings/Python
313 %py3_build
314 cd ../..
315 %endif
316
317 %install
318 rm -rf $RPM_BUILD_ROOT
319 install -d $RPM_BUILD_ROOT/var/lib/brltty
320
321 %{__make} -j1 install install-appstream install-dracut install-polkit install-systemd install-udev \
322         OCAML_INSTALL_TARGET=install-without-findlib
323
324 # findlib-specific, useless in rpm
325 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
326
327 %if %{with python}
328 cd Bindings/Python
329 %py_install
330 cd ../..
331 %endif
332
333 %if %{with python3}
334 cd Bindings/Python
335 %py3_install
336 cd ../..
337 %endif
338
339 %if "%{_lib}" != "lib"
340         # Fix java plugin install path on 64-bit archs
341         install -d $RPM_BUILD_ROOT%{_libdir}/java
342         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
343 %endif
344
345 install Bootdisks/bp2cf $RPM_BUILD_ROOT%{_bindir}/brltty-bp2cf
346 cp -p Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
347
348 # no sign in source wheter it is zh_CN or zh_TW
349 # but seems to contain Traditional Chinese characters
350 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_TW}
351
352 # packaged as %doc
353 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/dracut/modules.d/99brltty/README
354
355 %find_lang %{name}
356
357 %clean
358 rm -rf $RPM_BUILD_ROOT
359
360 %pre
361 # The pre-install scriptlet.
362
363 # If a configuration file already exists then rpm installs the new one as
364 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
365 # already exists.
366
367 # There's no explicit way to tell if a configuration file has been installed
368 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
369 # erasing the .rpmnew file now so that we can see if it gets created later.
370 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
371
372 %post
373 # If BRLTTY's boot parameter has been specified then update the just installed
374 # configuration file template to reflect the options supplied thereby.
375
376 # First, we need to determine which file to update. If there's a .rpmnew file
377 # then update it since a previous configuration file must already have existed.
378 file="%{_sysconfdir}/brltty.conf"
379 new="${file}.rpmnew"
380 [ -f "${new}" ] && file="${new}"
381
382 # Update the configuration file template via the Bootdisks/bp2cf script.
383 %{_bindir}/brltty-bp2cf -u -f "${file}" >/dev/null 2>&1 || :
384
385 %post   -n brlapi -p /sbin/ldconfig
386 %postun -n brlapi -p /sbin/ldconfig
387
388 %files -f %{name}.lang
389 %defattr(644,root,root,755)
390 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
391 %attr(755,root,root) %{_bindir}/brltty
392 %attr(755,root,root) %{_bindir}/brltty-atb
393 %attr(755,root,root) %{_bindir}/brltty-bp2cf
394 %{_bindir}/brltty-config.sh
395 %attr(755,root,root) %{_bindir}/brltty-clip
396 %attr(755,root,root) %{_bindir}/brltty-cldr
397 %attr(755,root,root) %{_bindir}/brltty-ctb
398 %attr(755,root,root) %{_bindir}/brltty-genkey
399 %attr(755,root,root) %{_bindir}/brltty-ktb
400 %attr(755,root,root) %{_bindir}/brltty-lscmds
401 %attr(755,root,root) %{_bindir}/brltty-lsinc
402 %attr(755,root,root) %{_bindir}/brltty-mkuser
403 %attr(755,root,root) %{_bindir}/brltty-morse
404 %{_bindir}/brltty-prologue.sh
405 %attr(755,root,root) %{_bindir}/brltty-setcaps
406 %attr(755,root,root) %{_bindir}/brltty-trtxt
407 %attr(755,root,root) %{_bindir}/brltty-ttb
408 %attr(755,root,root) %{_bindir}/brltty-tune
409 %attr(755,root,root) %{_bindir}/eutp
410 %attr(755,root,root) %{_bindir}/vstp
411 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
412 %dir %{_libdir}/brltty
413 # Braille drivers
414 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
415 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
416 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
417 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
418 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
419 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
420 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
421 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
422 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
423 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
424 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
425 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcn.so
426 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
427 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
428 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfa.so
429 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
430 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
431 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
432 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
433 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
434 %attr(755,root,root) %{_libdir}/brltty/libbrlttybic.so
435 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
436 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
437 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
438 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
439 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
440 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
441 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
442 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
443 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
444 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
445 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
446 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
447 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
448 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
449 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
450 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
451 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
452 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
453 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
454 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
455 # speech synthesizer drivers
456 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
457 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
458 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
459 %{?with_espeak_ng:%attr(755,root,root) %{_libdir}/brltty/libbrlttysen.so}
460 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
461 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
462 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
463 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
464 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
465 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
466 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
467 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
468 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
469 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
470 # screen drivers
471 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
472 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
473 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
474 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
475 %if "%{_libexecdir}" != "%{_libdir}"
476 %dir %{_libexecdir}/brltty
477 %endif
478 %attr(755,root,root) %{_libexecdir}/brltty/systemd-wrapper
479 %attr(755,root,root) %{_libexecdir}/brltty/udev-wrapper
480 %{_sysconfdir}/brltty
481 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
482 /lib/udev/rules.d/90-brltty-device.rules
483 /lib/udev/rules.d/90-brltty-uinput.rules
484 %{systemdunitdir}/brltty.path
485 %{systemdunitdir}/brltty@.path
486 %{systemdunitdir}/brltty@.service
487 %{systemdunitdir}/brltty-device@.service
488 %{systemdtmpfilesdir}/brltty.conf
489 #%{_prefix}/lib/sysusers.d/brltty.conf
490 #%attr(3777,brltty,brltty)
491 %dir /var/lib/BrlAPI
492 #%attr(2770,brltty,brltty)
493 %dir /var/lib/brltty
494 %{_mandir}/man1/brltty.1*
495 %{_mandir}/man1/eutp.1*
496 %{_mandir}/man1/vstp.1*
497 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
498
499 %if %{with x}
500 # gdm autostart - subpackage?
501 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
502 #/etc/X11/Xsession.d/90xbrlapi
503 %{_datadir}/metainfo/org.a11y.brltty.metainfo.xml
504 %endif
505 %{_datadir}/polkit-1/actions/org.a11y.brlapi.policy
506 %{_datadir}/polkit-1/rules.d/org.a11y.brlapi.rules
507
508 %files -n dracut-brltty
509 %defattr(644,root,root,755)
510 %doc Initramfs/Dracut/README
511 %dir %{_prefix}/lib/dracut/modules.d/99brltty
512 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/alsa-start.sh
513 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/bluetooth-start.sh
514 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-start.sh
515 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/brltty-stop.sh
516 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/dbus-start.sh
517 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/module-setup.sh
518 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-start.sh
519 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/pulse-stop.sh
520 %attr(755,root,root) %{_prefix}/lib/dracut/modules.d/99brltty/speechd-start.sh
521
522 %files -n brlapi
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
525 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.8
526
527 %files -n brlapi-devel
528 %defattr(644,root,root,755)
529 %doc Documents/Manual-BrlAPI/English/BrlAPI*
530 %attr(755,root,root) %{_libdir}/libbrlapi.so
531 %{_includedir}/brltty
532 %{_includedir}/brlapi*.h
533 %{_pkgconfigdir}/brltty.pc
534 %{_mandir}/man3/brlapi_*.3*
535
536 %files -n brlapi-static
537 %defattr(644,root,root,755)
538 %{_libdir}/libbrlapi.a
539
540 %if %{with apidocs}
541 %files -n brlapi-apidocs
542 %defattr(644,root,root,755)
543 %doc Documents/BrlAPIref/html/*
544 %endif
545
546 %if %{with java}
547 %files -n java-brlapi
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
550 %{_javadir}/brlapi.jar
551 %endif
552
553 %if %{with ocaml}
554 %files -n ocaml-brlapi
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
557
558 %files -n ocaml-brlapi-devel
559 %defattr(644,root,root,755)
560 %dir %{_libdir}/ocaml/brlapi
561 %{_libdir}/ocaml/brlapi/META
562 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
563 %{_libdir}/ocaml/brlapi/brlapi.mli
564 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
565 %endif
566
567 %if %{with python}
568 %files -n python-brlapi
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{py_sitedir}/brlapi.so
571 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
572
573 %if %{with python3}
574 %files -n python3-brlapi
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
577 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
578 %endif
579 %endif
580
581 %if %{with tcl}
582 %files -n brlapi-tcl
583 %defattr(644,root,root,755)
584 %dir %{_libdir}/brlapi-%{brlapi_ver}
585 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
586 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
587 %endif
This page took 0.101433 seconds and 3 git commands to generate.