]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- release 2 (by relup.sh)
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  tcl                     # Tcl bindings
10 %bcond_without  x                       # X11-based utilities
11 %bcond_without  gpm                     # mouse tracking via GPM
12 %bcond_without  libbraille              # libbraille Braille driver
13 %bcond_without  espeak                  # eSpeak synthesizer driver
14 %bcond_without  flite                   # Flite synthesizer driver
15 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
16 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
17 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
18 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
19 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
20 %bcond_without  at_spi                  # AtSpi screen driver
21 %bcond_without  at_spi2                 # AtSpi2 screen driver
22 #
23 %define         brlapi_ver      0.5.7
24 #
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        4.4
30 Release:        2
31 Group:          Daemons
32 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
33 Source0:        http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
34 # Source0-md5:  8ebe96efe679f5f6ccff08928fec5b26
35 Patch0:         %{name}-stat.patch
36 URL:            http://mielke.cc/brltty/
37 BuildRequires:  alsa-lib-devel
38 %{?with_at_spi:BuildRequires:   at-spi-devel}
39 BuildRequires:  autoconf >= 2.62
40 BuildRequires:  automake
41 BuildRequires:  bison
42 # just headers
43 BuildRequires:  bluez-libs-devel
44 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
45 %{?with_apidocs:BuildRequires:  doxygen}
46 %{?with_espeak:BuildRequires:   espeak-devel}
47 %{?with_flite:BuildRequires:    flite-devel}
48 %{?with_gpm:BuildRequires:      gpm-devel}
49 %{?with_java:BuildRequires:     jdk}
50 %{?with_libbraille:BuildRequires:       libbraille-devel}
51 BuildRequires:  libicu-devel
52 BuildRequires:  ncurses-devel
53 %{?with_ocaml:BuildRequires:    ocaml}
54 BuildRequires:  pkgconfig
55 %{?with_python:BuildRequires:   python-Pyrex}
56 %{?with_java:BuildRequires:     rpm-javaprov}
57 %{?with_python:BuildRequires:   rpm-pythonprov}
58 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel}
59 %{?with_tcl:BuildRequires:      tcl-devel}
60 %if %{with x}
61 BuildRequires:  xorg-lib-libX11-devel
62 BuildRequires:  xorg-lib-libXaw-devel
63 BuildRequires:  xorg-lib-libXext-devel
64 BuildRequires:  xorg-lib-libXt-devel
65 BuildRequires:  xorg-lib-libXtst-devel
66 %endif
67 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
68 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
69 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
70 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 BRLTTY is a background process (daemon) which provides access to the
75 Linux/Unix console (when in text mode) for a blind person using a
76 refreshable Braille display. It drives the Braille display, and
77 provides complete screen review functionality. Some speech capability
78 has also been incorporated.
79
80 %description -l pl.UTF-8
81 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
82 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
83 odświeżaniem (refreshable Braille display). BRLTTY steruje
84 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
85 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
86 mowy.
87
88 %package -n brlapi
89 Summary:        Application Programming Interface for BRLTTY
90 Summary(pl.UTF-8):      API do BRLTTY
91 License:        LGPL v2.1+
92 Group:          Libraries
93
94 %description -n brlapi
95 This package provides the run-time support for the Application
96 Programming Interface to BRLTTY.
97
98 Install this package if you have an application which directly
99 accesses a refreshable Braille display.
100
101 %description -n brlapi -l pl.UTF-8
102 Ten pakiet zawiera środowisko uruchomieniowe dla programów
103 korzystających z API BRLTTY.
104
105 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
106 wyświetlacza Braille'a z odświeżaniem.
107
108 %package -n brlapi-devel
109 Summary:        Headers and documentation for BrlAPI
110 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
111 License:        LGPL v2.1+
112 Group:          Development/Libraries
113 Requires:       brlapi = %{version}-%{release}
114
115 %description -n brlapi-devel
116 This package provides the header files, shared object linker
117 reference, and reference documentation for BrlAPI (the Application
118 Programming Interface to BRLTTY). It enables the implementation of
119 applications which take direct advantage of a refreshable Braille
120 display in order to present information in ways which are more
121 appropriate for blind users and/or to provide user interfaces which
122 are more specifically atuned to their needs.
123
124 Install this package if you're developing or maintaining an
125 application which directly accesses a refreshable Braille display.
126
127 %description -n brlapi-devel -l pl.UTF-8
128 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
129 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
130 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
131 bardziej przystosowany dla osób niewidomych.
132
133 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
134 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
135
136 %package -n brlapi-static
137 Summary:        Static BrlAPI library
138 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
139 License:        LGPL v2.1+
140 Group:          Development/Libraries
141 Requires:       brlapi-devel = %{version}-%{release}
142
143 %description -n brlapi-static
144 This is package with static BrlAPI library.
145
146 %description -n brlapi-static -l pl.UTF-8
147 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
148
149 %package -n brlapi-apidocs
150 Summary:        BrlAPI documentation
151 Summary(pl.UTF-8):      Documentacja BrlAPI
152 Group:          Documentation
153
154 %description -n brlapi-apidocs
155 Documentation for BrlAPI in HTML format generated from brltty
156 sources by doxygen.
157
158 %description -n brlapi-apidocs -l pl.UTF-8
159 Dokumentacja BrlAPI w formacie HTML generowane ze
160 źrodeł brltty przez doxygen.
161
162 %package -n java-brlapi
163 Summary:        BrlAPI library for Java
164 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
165 License:        LGPL v2.1+
166 Group:          Libraries
167 Requires:       brlapi = %{version}-%{release}
168
169 %description -n java-brlapi
170 BrlAPI library for Java.
171
172 %description -n java-brlapi -l pl.UTF-8
173 Biblioteka BrlAPI dla Javy.
174
175 %package -n ocaml-brlapi
176 Summary:        OCaml binding for BrlAPI
177 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
178 License:        LGPL v2.1+
179 Group:          Libraries
180 Requires:       brlapi = %{version}-%{release}
181 %requires_eq    ocaml-runtime
182
183 %description -n ocaml-brlapi
184 OCaml binding for BrlAPI.
185
186 %description -n ocaml-brlapi -l pl.UTF-8
187 Wiązania OCamla do BrlAPI.
188
189 %package -n ocaml-brlapi-devel
190 Summary:        OCaml binding for BrlAPI - development files
191 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
192 License:        LGPL v2.1+
193 Group:          Libraries
194 Requires:       ocaml-brlapi = %{version}-%{release}
195 %requires_eq    ocaml
196
197 %description -n ocaml-brlapi-devel
198 OCaml binding for BrlAPI - development files.
199
200 %description -n ocaml-brlapi-devel -l pl.UTF-8
201 Wiązania OCamla do BrlAPI - pliki programistyczne.
202
203 %package -n python-brlapi
204 Summary:        Python interface to BrlAPI
205 Summary(pl.UTF-8):      Pythonowy interfejs do BrlAPI
206 License:        LGPL v2.1+
207 Group:          Libraries
208 Requires:       brlapi = %{version}-%{release}
209
210 %description -n python-brlapi
211 Python interface to BrlAPI.
212
213 %description -n python-brlapi -l pl.UTF-8
214 Pythonowy interfejs do BrlAPI.
215
216 %package -n brlapi-tcl
217 Summary:        BrlAPI library for Tcl
218 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
219 License:        LGPL v2.1+
220 Group:          Libraries
221 Requires:       brlapi = %{version}-%{release}
222
223 %description -n brlapi-tcl
224 BrlAPI library for Tcl.
225
226 %description -n brlapi-tcl -l pl.UTF-8
227 Biblioteka BrlAPI dla Tcl.
228
229 %prep
230 %setup -q
231 %patch0 -p1
232
233 %build
234 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
235 %configure \
236         --with-install-root="$RPM_BUILD_ROOT" \
237         %{!?with_libbraille:--without-libbraille} \
238         %{!?with_espeak:--without-espeak} \
239         %{!?with_flite:--without-flite} \
240         %{!?with_speech_dispatcher:--without-speechd} \
241         %{!?with_ocaml:--disable-caml-bindings} \
242         %{!?with_gpm:--disable-gpm} \
243         %{!?with_java:--disable-java-bindings} \
244         %{!?with_python:--disable-python-bindings} \
245         %{!?with_tcl:--disable-tcl-bindings} \
246         %{!?with_x:--disable-x} \
247         --enable-api
248
249 %{__make} -j1
250
251 directory="doc"
252 mkdir -p "$directory"
253 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
254 do
255         mkdir -p "$directory/${file%/*}"
256         cp -rp "$file" "$directory/$file"
257 done
258
259 %install
260 rm -rf $RPM_BUILD_ROOT
261
262 %{__make} -j1 install \
263         OCAML_INSTALL_TARGET=install-without-findlib
264
265 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
266
267 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
268 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
269 d /var/run/brltty 0755 root root -
270 EOF
271
272 %clean
273 rm -rf $RPM_BUILD_ROOT
274
275 %pre
276 # The pre-install scriptlet.
277
278 # If a configuration file already exists then rpm installs the new one as
279 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
280 # already exists.
281
282 # There's no explicit way to tell if a configuration file has been installed
283 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
284 # erasing the .rpmnew file now so that we can see if it gets created later.
285 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
286
287 %post
288 # The post-install scriptlet.
289
290 # If BRLTTY's boot parameter has been specified then update the just installed
291 # configuration file template to reflect the options supplied thereby.
292
293 # First, we need to determine which file to update. If there's a .rpmnew file
294 # then update it since a previous configuration file must already have existed.
295 file="%{_sysconfdir}/brltty.conf"
296 new="${file}.rpmnew"
297 [ -f "${new}" ] && file="${new}"
298
299 # Update the configuration file template via the Bootdisks/bp2cf script.
300 # Include it right within this scriptlet so that it needn't be installed.
301 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
302 (
303         # First, set bp2cf's command line arguments.
304         set -- -u -f "${file}"
305
306 #!/bin/sh
307 ###############################################################################
308 # BRLTTY - A background process providing access to the Linux console (when in
309 #          text mode) for a blind person using a refreshable Braille display.
310 #
311 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
312 #
313 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
314 #
315 # This is free software, placed under the terms of the
316 # GNU General Public License, as published by the Free Software
317 # Foundation.  Please see the file COPYING for details.
318 #
319 # Web Page: http://mielke.cc/brltty/
320 #
321 # This software is maintained by Dave Mielke <dave@mielke.cc>.
322 ###############################################################################
323
324 # Convert the boot parameter to configuration file directives.
325 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
326 # If /proc is not mounted then use the brltty environment variable.
327 # Invoke with -h for usage information.
328
329 programName="${0##*/}"
330 programMessage()
331 {
332         echo 2>&1 "${programName}: ${1}"
333 }
334 syntaxError()
335 {
336         programMessage "${1}"
337         exit 2
338 }
339 internalError()
340 {
341         programMessage "${1}"
342         exit 3
343 }
344
345 configurationFile=""
346 requestedAction=create
347 deviceTranslation=none
348 requestedParameter=""
349 OPTIND=1
350 while getopts ":f:cundop:h" option
351 do
352         case "${option}" in
353             f) configurationFile="${OPTARG}";;
354             c) requestedAction=create;;
355             u) requestedAction=update;;
356             n) deviceTranslation=none;;
357             d) deviceTranslation=devfs;;
358             o) deviceTranslation=old;;
359             p) requestedParameter="${OPTARG}";;
360             h)
361                 cat <<EOF
362 Usage: ${programName} [option ...]
363 -f file  The configuration file to create/update.
364 -c       Create the configuration file (write to stdout if no -f).
365 -u       Update the configuration file (copying from stdin to stdout if no -f).
366 -n       Do not translate device paths.
367 -d       Do old-style to devfs device path translation.
368 -o       Do devfs to old-style device path translation.
369 -p [driver][,[device][,[table]]]
370          Explicitly specify the boot parameter.
371 -h       Display this usage summary.
372 EOF
373                 exit 0
374                 ;;
375             \?) syntaxError "unknown option: -${OPTARG}";;
376             :) syntaxError "missing value: -${OPTARG}";;
377             *) internalError "unimplemented option: -${option}";;
378         esac
379 done
380 shift "`expr $OPTIND - 1`"
381 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
382
383 case "${requestedAction}" in
384     create)
385         putConfigurationLine()
386         {
387                 echo "${1}" || exit 4
388         }
389         startConfigurationFile()
390         {
391                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
392                 putConfigurationLine "`makeHeaderLine Created`"
393                 putConfigurationLine "`makeParameterLine`"
394                 putConfigurationLine ""
395         }
396         putConfigurationDirective()
397         {
398                 putConfigurationLine "${1} ${2}"
399         }
400         finalizeConfigurationFile()
401         {
402                 :
403         }
404         ;;
405     update)
406         putSedCommand()
407         {
408                 sedScript="${sedScript}
409 ${1}"
410         }
411         startConfigurationFile()
412         {
413                 if [ -n "${configurationFile}" ]; then
414                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
415                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
416                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
417                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
418                         outputFile="${configurationFile}.new"
419                         exec <"${configurationFile}" >"${outputFile}"
420                 fi
421                 sedScript=""
422                 putSedCommand "1i\\
423 `makeHeaderLine Updated`\\
424 `makeParameterLine`\\
425 "
426         }
427         putConfigurationDirective()
428         {
429                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
430                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
431                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
432         }
433         finalizeConfigurationFile()
434         {
435                 sed -e "${sedScript}"
436                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
437         }
438         ;;
439     *) internalError "unimplemented action: ${requestedAction}";;
440 esac
441
442 translateDevice_none()
443 {
444         :
445 }
446 translateDevice_devfs()
447 {
448         minor="${device#ttyS}"
449         if [ "${minor}" != "${device}" ]; then
450                 device="tts/${minor}"
451                 return 0
452         fi
453         minor="${device#lp}"
454         if [ "${minor}" != "${device}" ]; then
455                 device="printers/${minor}"
456                 return 0
457         fi
458         programMessage "unsupported old-style device: ${device}"
459 }
460 translateDevice_old()
461 {
462         major="${device%%/*}"
463         if [ "${major}" != "${device}" ]; then
464                 minor="${device#*/}"
465                 case "${major}" in
466                     tts) devfs="ttyS${minor}";;
467                     printers) devfs="lp${minor}";;
468                 esac
469         fi
470         if [ -n "${devfs}" ]; then
471                 device="${devfs}"
472         else
473                 programMessage "unsupported devfs device: ${device}"
474         fi
475 }
476
477 makeHeaderLine()
478 {
479         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
480 }
481 makeParameterLine()
482 {
483         echo "# Boot Parameter:${bootParameter}"
484 }
485 putConfigurationFile()
486 {
487         startConfigurationFile
488         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
489         [ -n "${brailleDevice}" ] && {
490         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
491         if [ "${device#/}" = "${device}" ]; then
492                 translateDevice_${deviceTranslation}
493         fi
494         putConfigurationDirective "braille-device" "${device}"
495         }
496         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
497         finalizeConfigurationFile
498 }
499 parseBootParameter()
500 {
501         bootParameter="${bootParameter} ${1}"
502         number=1
503         while [ "${number}" -le 3 ]; do
504                 cut="cut -d, -f${number}"
505                 [ "${number}" -gt 1 ] && cut="${cut} -s"
506                 operand="`echo ${1} | ${cut}`"
507                 if [ -n "${operand}" ]; then
508                         case "${number}" in
509                             1) brailleDriver="${operand}";;
510                             2) brailleDevice="${operand}";;
511                             3) textTable="${operand}";;
512                         esac
513                 fi
514                 number="`expr ${number} + 1`"
515         done
516 }
517 putBootParameter()
518 {
519         parseBootParameter "${1}"
520         putConfigurationFile
521 }
522 parseBootCommand()
523 {
524         found=false
525         while [ "${#}" -gt 0 ]; do
526                 case "${1}" in
527                     "brltty="*)
528                         found=true
529                         parseBootParameter "${1#*=}"
530                         ;;
531                 esac
532                 shift
533         done
534         "${found}" && putConfigurationFile
535 }
536
537 brailleDriver=""
538 brailleDevice=""
539 textTable=""
540 bootCommandFile="/proc/cmdline"
541 if [ -n "${requestedParameter}" ]; then
542         putBootParameter "${requestedParameter}"
543 elif [ -f "${bootCommandFile}" ]; then
544         parseBootCommand `cat "${bootCommandFile}"`
545 elif [ -n "${brltty}" ]; then
546         putBootParameter "${brltty}"
547 fi
548 exit 0
549 )
550
551 %post   -n brlapi -p /sbin/ldconfig
552 %postun -n brlapi -p /sbin/ldconfig
553
554 %files
555 %defattr(644,root,root,755)
556 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
557 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
558 %attr(755,root,root) %{_bindir}/brltty
559 %attr(755,root,root) %{_bindir}/brltty-config
560 %attr(755,root,root) %{_bindir}/brltty-ctb
561 %attr(755,root,root) %{_bindir}/brltty-install
562 %attr(755,root,root) %{_bindir}/brltty-trtxt
563 %attr(755,root,root) %{_bindir}/brltty-ttb
564 %attr(755,root,root) %{_bindir}/vstp
565 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
566 %dir %{_libdir}/brltty
567 # Braille drivers
568 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
569 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
570 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
571 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
572 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
573 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
574 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
575 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
576 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
577 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
578 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
579 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
580 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
581 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
582 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
583 %attr(755,root,root) %{_libdir}/brltty/libbrlttybil.so
584 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
585 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
586 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
587 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
588 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
589 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
590 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
591 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
592 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
593 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
594 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
595 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
596 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
597 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
598 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
599 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
600 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
601 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
602 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
603 # speech synthesizer drivers
604 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
605 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
606 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
607 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
608 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
609 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
610 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
611 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
612 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
613 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
614 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
615 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
616 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
617 # screen drivers
618 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
619 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
620 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
621 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
622 %{_sysconfdir}/brltty
623 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
624 /usr/lib/tmpfiles.d/brltty.conf
625 %dir /var/lib/BrlAPI
626 %dir /var/run/brltty
627 %{_mandir}/man1/brltty.1*
628 %{_mandir}/man1/vstp.1*
629 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
630
631 %files -n brlapi
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.5
635
636 %files -n brlapi-devel
637 %defattr(644,root,root,755)
638 %doc Documents/Manual-BrlAPI/English/BrlAPI*
639 %attr(755,root,root) %{_libdir}/libbrlapi.so
640 %{_includedir}/brltty
641 %{_includedir}/brlapi*.h
642 %{_mandir}/man3/brlapi_*.3*
643
644 %files -n brlapi-static
645 %defattr(644,root,root,755)
646 %{_libdir}/libbrlapi.a
647
648 %if %{with apidocs}
649 %files -n brlapi-apidocs
650 %defattr(644,root,root,755)
651 %doc Documents/BrlAPIref/html/*
652 %endif
653
654 %if %{with java}
655 %files -n java-brlapi
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
658 %{_javadir}/brlapi.jar
659 %endif
660
661 %if %{with ocaml}
662 %files -n ocaml-brlapi
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
665 %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
666
667 %files -n ocaml-brlapi-devel
668 %defattr(644,root,root,755)
669 %dir %{_libdir}/ocaml/brlapi
670 %{_libdir}/ocaml/brlapi/META
671 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
672 %{_libdir}/ocaml/brlapi/brlapi.mli
673 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
674 %endif
675
676 %if %{with python}
677 %files -n python-brlapi
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{py_sitedir}/brlapi.so
680 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
681 %endif
682
683 %if %{with tcl}
684 %files -n brlapi-tcl
685 %defattr(644,root,root,755)
686 %dir %{_libdir}/brlapi-%{brlapi_ver}
687 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
688 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
689 %endif
This page took 0.090238 seconds and 3 git commands to generate.