]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
- updated to 5.3 (brlapi 0.6.4)
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  python3                 # Python 3.x bindings
10 %bcond_without  tcl                     # Tcl bindings
11 %bcond_without  x                       # X11-based utilities
12 %bcond_without  gpm                     # mouse tracking via GPM
13 %bcond_without  libbraille              # libbraille Braille driver
14 %bcond_without  espeak                  # eSpeak synthesizer driver
15 %bcond_without  flite                   # Flite synthesizer driver
16 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
17 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
18 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
19 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
20 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
21 %bcond_with     at_spi                  # AtSpi screen driver
22 %bcond_without  at_spi2                 # AtSpi2 screen driver
23
24 %define         brlapi_ver      0.6.4
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        5.3
30 Release:        1
31 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
32 Group:          Daemons
33 Source0:        http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
34 # Source0-md5:  19fbcb1fefc42cea81f560de0a1f539f
35 Patch0:         %{name}-format.patch
36 Patch1:         %{name}-speech-dispatcher.patch
37 Patch2:         %{name}-python.patch
38 URL:            http://mielke.cc/brltty/
39 BuildRequires:  alsa-lib-devel
40 %{?with_at_spi:BuildRequires:   at-spi-devel}
41 BuildRequires:  autoconf >= 2.64
42 BuildRequires:  automake
43 BuildRequires:  bison
44 BuildRequires:  rpmbuild(macros) >= 1.710
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_flite:BuildRequires:    flite-devel}
51 %{?with_gpm:BuildRequires:      gpm-devel}
52 %{?with_java:BuildRequires:     jdk}
53 %{?with_java:BuildRequires:     jpackage-utils}
54 %{?with_libbraille:BuildRequires:       libbraille-devel}
55 BuildRequires:  libicu-devel
56 BuildRequires:  ncurses-devel
57 %{?with_ocaml:BuildRequires:    ocaml}
58 BuildRequires:  pkgconfig
59 %{?with_python:BuildRequires:   python-Cython}
60 %{?with_python3:BuildRequires:  python3-Cython}
61 %{?with_java:BuildRequires:     rpm-javaprov}
62 %{?with_python:BuildRequires:   rpm-pythonprov}
63 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
64 BuildRequires:  tar >= 1:1.22
65 %{?with_tcl:BuildRequires:      tcl-devel >= 8.5}
66 %if %{with x}
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXaw-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXt-devel
71 BuildRequires:  xorg-lib-libXtst-devel
72 %endif
73 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
74 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
75 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
76 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
77 BuildRequires:  xz
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 BRLTTY is a background process (daemon) which provides access to the
82 Linux/Unix console (when in text mode) for a blind person using a
83 refreshable Braille display. It drives the Braille display, and
84 provides complete screen review functionality. Some speech capability
85 has also been incorporated.
86
87 %description -l pl.UTF-8
88 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
89 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
90 odświeżaniem (refreshable Braille display). BRLTTY steruje
91 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
92 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
93 mowy.
94
95 %package -n brlapi
96 Summary:        Application Programming Interface for BRLTTY
97 Summary(pl.UTF-8):      API do BRLTTY
98 License:        LGPL v2.1+
99 Group:          Libraries
100
101 %description -n brlapi
102 This package provides the run-time support for the Application
103 Programming Interface to BRLTTY.
104
105 Install this package if you have an application which directly
106 accesses a refreshable Braille display.
107
108 %description -n brlapi -l pl.UTF-8
109 Ten pakiet zawiera środowisko uruchomieniowe dla programów
110 korzystających z API BRLTTY.
111
112 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
113 wyświetlacza Braille'a z odświeżaniem.
114
115 %package -n brlapi-devel
116 Summary:        Headers and documentation for BrlAPI
117 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
118 License:        LGPL v2.1+
119 Group:          Development/Libraries
120 Requires:       brlapi = %{version}-%{release}
121
122 %description -n brlapi-devel
123 This package provides the header files, shared object linker
124 reference, and reference documentation for BrlAPI (the Application
125 Programming Interface to BRLTTY). It enables the implementation of
126 applications which take direct advantage of a refreshable Braille
127 display in order to present information in ways which are more
128 appropriate for blind users and/or to provide user interfaces which
129 are more specifically atuned to their needs.
130
131 Install this package if you're developing or maintaining an
132 application which directly accesses a refreshable Braille display.
133
134 %description -n brlapi-devel -l pl.UTF-8
135 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
136 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
137 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
138 bardziej przystosowany dla osób niewidomych.
139
140 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
141 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
142
143 %package -n brlapi-static
144 Summary:        Static BrlAPI library
145 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
146 License:        LGPL v2.1+
147 Group:          Development/Libraries
148 Requires:       brlapi-devel = %{version}-%{release}
149
150 %description -n brlapi-static
151 This is package with static BrlAPI library.
152
153 %description -n brlapi-static -l pl.UTF-8
154 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
155
156 %package -n brlapi-apidocs
157 Summary:        BrlAPI documentation
158 Summary(pl.UTF-8):      Documentacja BrlAPI
159 Group:          Documentation
160 %if "%{_rpmversion}" >= "5"
161 BuildArch:      noarch
162 %endif
163
164 %description -n brlapi-apidocs
165 Documentation for BrlAPI in HTML format generated from brltty sources
166 by doxygen.
167
168 %description -n brlapi-apidocs -l pl.UTF-8
169 Dokumentacja BrlAPI w formacie HTML generowane ze źrodeł brltty przez
170 doxygen.
171
172 %package -n java-brlapi
173 Summary:        BrlAPI library for Java
174 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
175 License:        LGPL v2.1+
176 Group:          Libraries
177 Requires:       brlapi = %{version}-%{release}
178
179 %description -n java-brlapi
180 BrlAPI library for Java.
181
182 %description -n java-brlapi -l pl.UTF-8
183 Biblioteka BrlAPI dla Javy.
184
185 %package -n ocaml-brlapi
186 Summary:        OCaml binding for BrlAPI
187 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
188 License:        LGPL v2.1+
189 Group:          Libraries
190 Requires:       brlapi = %{version}-%{release}
191 %requires_eq    ocaml-runtime
192
193 %description -n ocaml-brlapi
194 OCaml binding for BrlAPI.
195
196 %description -n ocaml-brlapi -l pl.UTF-8
197 Wiązania OCamla do BrlAPI.
198
199 %package -n ocaml-brlapi-devel
200 Summary:        OCaml binding for BrlAPI - development files
201 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
202 License:        LGPL v2.1+
203 Group:          Libraries
204 Requires:       ocaml-brlapi = %{version}-%{release}
205 %requires_eq    ocaml
206
207 %description -n ocaml-brlapi-devel
208 OCaml binding for BrlAPI - development files.
209
210 %description -n ocaml-brlapi-devel -l pl.UTF-8
211 Wiązania OCamla do BrlAPI - pliki programistyczne.
212
213 %package -n python-brlapi
214 Summary:        Python 2.x interface to BrlAPI
215 Summary(pl.UTF-8):      Interfejs Pythona 2.x do BrlAPI
216 License:        LGPL v2.1+
217 Group:          Libraries
218 Requires:       brlapi = %{version}-%{release}
219
220 %description -n python-brlapi
221 Python 2.x interface to BrlAPI.
222
223 %description -n python-brlapi -l pl.UTF-8
224 Interfejs Pythona 2.x do BrlAPI.
225
226 %package -n python3-brlapi
227 Summary:        Python 3.x interface to BrlAPI
228 Summary(pl.UTF-8):      Interfejs Pythona 3.x do BrlAPI
229 License:        LGPL v2.1+
230 Group:          Libraries
231 Requires:       brlapi = %{version}-%{release}
232
233 %description -n python3-brlapi
234 Python 3.x interface to BrlAPI.
235
236 %description -n python3-brlapi -l pl.UTF-8
237 Interfejs Pythona 3.x do BrlAPI.
238
239 %package -n brlapi-tcl
240 Summary:        BrlAPI library for Tcl
241 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
242 License:        LGPL v2.1+
243 Group:          Libraries
244 Requires:       brlapi = %{version}-%{release}
245
246 %description -n brlapi-tcl
247 BrlAPI library for Tcl.
248
249 %description -n brlapi-tcl -l pl.UTF-8
250 Biblioteka BrlAPI dla Tcl.
251
252 %prep
253 %setup -q
254 %patch0 -p1
255 %patch1 -p1
256 %patch2 -p1
257
258 %build
259 %{__autoconf}
260 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
261 %configure \
262         %{?with_java:JAVA_HOME=%{java_home}} \
263         --with-install-root="$RPM_BUILD_ROOT" \
264         %{!?with_libbraille:--without-libbraille} \
265         %{!?with_espeak:--without-espeak} \
266         %{!?with_flite:--without-flite} \
267         %{!?with_speech_dispatcher:--without-speechd} \
268         %{!?with_ocaml:--disable-caml-bindings} \
269         %{!?with_gpm:--disable-gpm} \
270         %{!?with_java:--disable-java-bindings} \
271         %{!?with_python:--disable-python-bindings} \
272         %{!?with_tcl:--disable-tcl-bindings} \
273         %{!?with_x:--disable-x} \
274         --enable-api
275
276 %{__make} -j1
277
278 %if %{with python}
279 cd Bindings/Python
280 %py_build
281 cd ../..
282 %endif
283
284 %if %{with python3}
285 cd Bindings/Python
286 %py3_build
287 cd ../..
288 %endif
289
290 directory="doc"
291 mkdir -p "$directory"
292 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
293 do
294         mkdir -p "$directory/${file%/*}"
295         cp -rp "$file" "$directory/$file"
296 done
297
298 %install
299 rm -rf $RPM_BUILD_ROOT
300
301 %{__make} -j1 install \
302         OCAML_INSTALL_TARGET=install-without-findlib
303
304 # findlib-specific, useless in rpm
305 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
306
307 %if %{with python}
308 cd Bindings/Python
309 %py_install
310 cd ../..
311 %endif
312
313 %if %{with python3}
314 cd Bindings/Python
315 %py3_install
316 cd ../..
317 %endif
318
319 %if %{_lib} != "lib"
320         # Fix java plugin install path on 64-bit archs
321         install -d $RPM_BUILD_ROOT%{_libdir}/java
322         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
323 %endif
324
325 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
326
327 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
328 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
329 d /var/run/brltty 0755 root root -
330 EOF
331
332 # no sign in source wheter it is zh_CN or zh_TW so just remove it
333 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
334
335 %find_lang %{name}
336
337 %clean
338 rm -rf $RPM_BUILD_ROOT
339
340 %pre
341 # The pre-install scriptlet.
342
343 # If a configuration file already exists then rpm installs the new one as
344 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
345 # already exists.
346
347 # There's no explicit way to tell if a configuration file has been installed
348 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
349 # erasing the .rpmnew file now so that we can see if it gets created later.
350 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
351
352 %post
353 # The post-install scriptlet.
354
355 # If BRLTTY's boot parameter has been specified then update the just installed
356 # configuration file template to reflect the options supplied thereby.
357
358 # First, we need to determine which file to update. If there's a .rpmnew file
359 # then update it since a previous configuration file must already have existed.
360 file="%{_sysconfdir}/brltty.conf"
361 new="${file}.rpmnew"
362 [ -f "${new}" ] && file="${new}"
363
364 # Update the configuration file template via the Bootdisks/bp2cf script.
365 # Include it right within this scriptlet so that it needn't be installed.
366 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
367 (
368         # First, set bp2cf's command line arguments.
369         set -- -u -f "${file}"
370
371 #!/bin/sh
372 ###############################################################################
373 # BRLTTY - A background process providing access to the Linux console (when in
374 #          text mode) for a blind person using a refreshable Braille display.
375 #
376 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
377 #
378 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
379 #
380 # This is free software, placed under the terms of the
381 # GNU General Public License, as published by the Free Software
382 # Foundation.  Please see the file COPYING for details.
383 #
384 # Web Page: http://mielke.cc/brltty/
385 #
386 # This software is maintained by Dave Mielke <dave@mielke.cc>.
387 ###############################################################################
388
389 # Convert the boot parameter to configuration file directives.
390 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
391 # If /proc is not mounted then use the brltty environment variable.
392 # Invoke with -h for usage information.
393
394 programName="${0##*/}"
395 programMessage()
396 {
397         echo 2>&1 "${programName}: ${1}"
398 }
399 syntaxError()
400 {
401         programMessage "${1}"
402         exit 2
403 }
404 internalError()
405 {
406         programMessage "${1}"
407         exit 3
408 }
409
410 configurationFile=""
411 requestedAction=create
412 deviceTranslation=none
413 requestedParameter=""
414 OPTIND=1
415 while getopts ":f:cundop:h" option
416 do
417         case "${option}" in
418             f) configurationFile="${OPTARG}";;
419             c) requestedAction=create;;
420             u) requestedAction=update;;
421             n) deviceTranslation=none;;
422             d) deviceTranslation=devfs;;
423             o) deviceTranslation=old;;
424             p) requestedParameter="${OPTARG}";;
425             h)
426                 cat <<EOF
427 Usage: ${programName} [option ...]
428 -f file  The configuration file to create/update.
429 -c       Create the configuration file (write to stdout if no -f).
430 -u       Update the configuration file (copying from stdin to stdout if no -f).
431 -n       Do not translate device paths.
432 -d       Do old-style to devfs device path translation.
433 -o       Do devfs to old-style device path translation.
434 -p [driver][,[device][,[table]]]
435          Explicitly specify the boot parameter.
436 -h       Display this usage summary.
437 EOF
438                 exit 0
439                 ;;
440             \?) syntaxError "unknown option: -${OPTARG}";;
441             :) syntaxError "missing value: -${OPTARG}";;
442             *) internalError "unimplemented option: -${option}";;
443         esac
444 done
445 shift "`expr $OPTIND - 1`"
446 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
447
448 case "${requestedAction}" in
449     create)
450         putConfigurationLine()
451         {
452                 echo "${1}" || exit 4
453         }
454         startConfigurationFile()
455         {
456                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
457                 putConfigurationLine "`makeHeaderLine Created`"
458                 putConfigurationLine "`makeParameterLine`"
459                 putConfigurationLine ""
460         }
461         putConfigurationDirective()
462         {
463                 putConfigurationLine "${1} ${2}"
464         }
465         finalizeConfigurationFile()
466         {
467                 :
468         }
469         ;;
470     update)
471         putSedCommand()
472         {
473                 sedScript="${sedScript}
474 ${1}"
475         }
476         startConfigurationFile()
477         {
478                 if [ -n "${configurationFile}" ]; then
479                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
480                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
481                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
482                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
483                         outputFile="${configurationFile}.new"
484                         exec <"${configurationFile}" >"${outputFile}"
485                 fi
486                 sedScript=""
487                 putSedCommand "1i\\
488 `makeHeaderLine Updated`\\
489 `makeParameterLine`\\
490 "
491         }
492         putConfigurationDirective()
493         {
494                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
495                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
496                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
497         }
498         finalizeConfigurationFile()
499         {
500                 sed -e "${sedScript}"
501                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
502         }
503         ;;
504     *) internalError "unimplemented action: ${requestedAction}";;
505 esac
506
507 translateDevice_none()
508 {
509         :
510 }
511 translateDevice_devfs()
512 {
513         minor="${device#ttyS}"
514         if [ "${minor}" != "${device}" ]; then
515                 device="tts/${minor}"
516                 return 0
517         fi
518         minor="${device#lp}"
519         if [ "${minor}" != "${device}" ]; then
520                 device="printers/${minor}"
521                 return 0
522         fi
523         programMessage "unsupported old-style device: ${device}"
524 }
525 translateDevice_old()
526 {
527         major="${device%%/*}"
528         if [ "${major}" != "${device}" ]; then
529                 minor="${device#*/}"
530                 case "${major}" in
531                     tts) devfs="ttyS${minor}";;
532                     printers) devfs="lp${minor}";;
533                 esac
534         fi
535         if [ -n "${devfs}" ]; then
536                 device="${devfs}"
537         else
538                 programMessage "unsupported devfs device: ${device}"
539         fi
540 }
541
542 makeHeaderLine()
543 {
544         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
545 }
546 makeParameterLine()
547 {
548         echo "# Boot Parameter:${bootParameter}"
549 }
550 putConfigurationFile()
551 {
552         startConfigurationFile
553         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
554         [ -n "${brailleDevice}" ] && {
555         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
556         if [ "${device#/}" = "${device}" ]; then
557                 translateDevice_${deviceTranslation}
558         fi
559         putConfigurationDirective "braille-device" "${device}"
560         }
561         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
562         finalizeConfigurationFile
563 }
564 parseBootParameter()
565 {
566         bootParameter="${bootParameter} ${1}"
567         number=1
568         while [ "${number}" -le 3 ]; do
569                 cut="cut -d, -f${number}"
570                 [ "${number}" -gt 1 ] && cut="${cut} -s"
571                 operand="`echo ${1} | ${cut}`"
572                 if [ -n "${operand}" ]; then
573                         case "${number}" in
574                             1) brailleDriver="${operand}";;
575                             2) brailleDevice="${operand}";;
576                             3) textTable="${operand}";;
577                         esac
578                 fi
579                 number="`expr ${number} + 1`"
580         done
581 }
582 putBootParameter()
583 {
584         parseBootParameter "${1}"
585         putConfigurationFile
586 }
587 parseBootCommand()
588 {
589         found=false
590         while [ "${#}" -gt 0 ]; do
591                 case "${1}" in
592                     "brltty="*)
593                         found=true
594                         parseBootParameter "${1#*=}"
595                         ;;
596                 esac
597                 shift
598         done
599         "${found}" && putConfigurationFile
600 }
601
602 brailleDriver=""
603 brailleDevice=""
604 textTable=""
605 bootCommandFile="/proc/cmdline"
606 if [ -n "${requestedParameter}" ]; then
607         putBootParameter "${requestedParameter}"
608 elif [ -f "${bootCommandFile}" ]; then
609         parseBootCommand `cat "${bootCommandFile}"`
610 elif [ -n "${brltty}" ]; then
611         putBootParameter "${brltty}"
612 fi
613 exit 0
614 )
615
616 %post   -n brlapi -p /sbin/ldconfig
617 %postun -n brlapi -p /sbin/ldconfig
618
619 %files -f %{name}.lang
620 %defattr(644,root,root,755)
621 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
622 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README}
623 %attr(755,root,root) %{_bindir}/brltty
624 %attr(755,root,root) %{_bindir}/brltty-atb
625 %attr(755,root,root) %{_bindir}/brltty-config
626 %attr(755,root,root) %{_bindir}/brltty-ctb
627 %attr(755,root,root) %{_bindir}/brltty-ktb
628 %attr(755,root,root) %{_bindir}/brltty-trtxt
629 %attr(755,root,root) %{_bindir}/brltty-ttb
630 %attr(755,root,root) %{_bindir}/brltty-tune
631 %attr(755,root,root) %{_bindir}/eutp
632 %attr(755,root,root) %{_bindir}/vstp
633 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
634 %dir %{_libdir}/brltty
635 # Braille drivers
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
637 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
638 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
639 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
640 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
641 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbg.so
642 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
643 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
644 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
645 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
646 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
647 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
648 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
649 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
650 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
651 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
652 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
653 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
654 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
655 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
656 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
657 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
658 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
659 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
660 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
661 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
662 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
663 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
664 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
665 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
666 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
667 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
668 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
669 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
670 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
671 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
672 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
673 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
674 # speech synthesizer drivers
675 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
676 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
677 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
678 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
679 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
680 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
681 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
682 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
683 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
684 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
685 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
686 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
687 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
688 # screen drivers
689 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
690 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
691 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
692 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
693 %{_sysconfdir}/brltty
694 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
695 %{systemdtmpfilesdir}/brltty.conf
696 %dir /var/lib/BrlAPI
697 %dir /var/run/brltty
698 %{_mandir}/man1/brltty.1*
699 %{_mandir}/man1/eutp.1*
700 %{_mandir}/man1/vstp.1*
701 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
702
703 %if %{with x}
704 # gdm autostart - subpackage?
705 #%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
706 %endif
707
708 %files -n brlapi
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
712
713 %files -n brlapi-devel
714 %defattr(644,root,root,755)
715 %doc Documents/Manual-BrlAPI/English/BrlAPI*
716 %attr(755,root,root) %{_libdir}/libbrlapi.so
717 %{_includedir}/brltty
718 %{_includedir}/brlapi*.h
719 %{_mandir}/man3/brlapi_*.3*
720
721 %files -n brlapi-static
722 %defattr(644,root,root,755)
723 %{_libdir}/libbrlapi.a
724
725 %if %{with apidocs}
726 %files -n brlapi-apidocs
727 %defattr(644,root,root,755)
728 %doc Documents/BrlAPIref/html/*
729 %endif
730
731 %if %{with java}
732 %files -n java-brlapi
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
735 %{_javadir}/brlapi.jar
736 %endif
737
738 %if %{with ocaml}
739 %files -n ocaml-brlapi
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
742
743 %files -n ocaml-brlapi-devel
744 %defattr(644,root,root,755)
745 %dir %{_libdir}/ocaml/brlapi
746 %{_libdir}/ocaml/brlapi/META
747 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
748 %{_libdir}/ocaml/brlapi/brlapi.mli
749 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
750 %endif
751
752 %if %{with python}
753 %files -n python-brlapi
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{py_sitedir}/brlapi.so
756 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
757
758 %if %{with python3}
759 %files -n python3-brlapi
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
762 %{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
763 %endif
764 %endif
765
766 %if %{with tcl}
767 %files -n brlapi-tcl
768 %defattr(644,root,root,755)
769 %dir %{_libdir}/brlapi-%{brlapi_ver}
770 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
771 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
772 %endif
This page took 0.098774 seconds and 3 git commands to generate.