]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
noarch doc subpackage, drop R-devel
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #       - fix building context and corouting on x32 (patch1)
6 #
7 # Conditional build:
8 %bcond_without  python2         # without boost-python2 support
9 %bcond_without  python3         # without boost-python3 support
10
11 %define         fver    %(echo %{version} | tr . _)
12 Summary:        The Boost C++ Libraries
13 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
14 Name:           boost
15 Version:        1.57.0
16 Release:        5
17 License:        Boost Software License and others
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  1be49befbdd9a5ce9def2983ba3e7b76
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8870
27 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
28 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
29 # https://svn.boost.org/trac/boost/ticket/8878
30 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
31 # https://svn.boost.org/trac/boost/ticket/8881
32 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
33 # https://svn.boost.org/trac/boost/ticket/8888
34 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
35 # https://svn.boost.org/trac/boost/ticket/9038
36 Patch224:       %{name}-1.54.0-pool-test_linking.patch
37 URL:            http://www.boost.org/
38 BuildRequires:  bzip2-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  libicu-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  perl-base
43 %{?with_python:BuildRequires:   python-devel >= 2.2}
44 %{?with_python3:BuildRequires:  python3-devel}
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  zlib-devel
47 BuildConflicts: gcc = 5:3.3.1
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
51
52 %description
53 The Boost web site provides free peer-reviewed portable C++ source
54 libraries. The emphasis is on libraries which work well with the C++
55 Standard Library. One goal is to establish "existing practice" and
56 provide reference implementations so that the Boost libraries are
57 suitable for eventual standardization. Some of the libraries have
58 already been proposed for inclusion in the C++ Standards Committee's
59 upcoming C++ Standard Library Technical Report.
60
61 %description -l pl.UTF-8
62 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
63 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
64 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
65 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
66 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
67 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
68 Raporcie Technicznym Biblioteki Standardowej C++.
69
70 %package devel
71 Summary:        Boost C++ development headers
72 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       %{name}-chrono = %{version}-%{release}
76 %ifnarch x32
77 Requires:       %{name}-context = %{version}-%{release}
78 %endif
79 Requires:       %{name}-date_time = %{version}-%{release}
80 Requires:       %{name}-filesystem = %{version}-%{release}
81 Requires:       %{name}-graph = %{version}-%{release}
82 Requires:       %{name}-locale = %{version}-%{release}
83 Requires:       %{name}-log = %{version}-%{release}
84 Requires:       %{name}-program_options = %{version}-%{release}
85 Requires:       %{name}-regex = %{version}-%{release}
86 Requires:       %{name}-signals = %{version}-%{release}
87 Requires:       %{name}-system = %{version}-%{release}
88 Requires:       %{name}-test = %{version}-%{release}
89 Requires:       %{name}-thread = %{version}-%{release}
90 Requires:       %{name}-timer = %{version}-%{release}
91 Requires:       %{name}-wave = %{version}-%{release}
92 Requires:       libstdc++-devel
93 Obsoletes:      boost-any-devel
94 Obsoletes:      boost-array-devel
95 Obsoletes:      boost-asio
96 Obsoletes:      boost-bind-devel
97 Obsoletes:      boost-call_traits-devel
98 Obsoletes:      boost-compatibility-devel
99 Obsoletes:      boost-compose-devel
100 Obsoletes:      boost-compressed_pair-devel
101 Obsoletes:      boost-concept_check-devel
102 Obsoletes:      boost-conversion-devel
103 Obsoletes:      boost-crc-devel
104 Obsoletes:      boost-date_time-devel
105 Obsoletes:      boost-filesystem-devel
106 Obsoletes:      boost-graph-devel
107 Obsoletes:      boost-mem_fn-devel
108 Obsoletes:      boost-mpl-devel
109 Obsoletes:      boost-preprocessor-devel
110 Obsoletes:      boost-program_options-devel
111 Obsoletes:      boost-ref-devel
112 Obsoletes:      boost-regex-devel
113 Obsoletes:      boost-signals-devel
114 Obsoletes:      boost-spirit-devel
115 Obsoletes:      boost-statechart-devel
116 Obsoletes:      boost-static_assert-devel
117 Obsoletes:      boost-test-devel
118 Obsoletes:      boost-thread-devel
119 Obsoletes:      boost-tr1-devel
120 Obsoletes:      boost-type_traits-devel
121 Obsoletes:      boost-typeof-devel
122 Obsoletes:      boost-uBLAS-devel
123 Obsoletes:      boost-utility-devel
124 Obsoletes:      boost-wave-devel
125 Obsoletes:      boost-xpressive-devel
126
127 %description devel
128 Header files for the Boost C++ libraries.
129
130 %description devel -l pl.UTF-8
131 Pliki nagłówkowe bibliotek C++ Boost.
132
133 %package static
134 Summary:        Static version of base Boost C++ libraries
135 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138 Obsoletes:      boost-static < 1.33
139
140 %description static
141 Static version of base Boost C++ libraries.
142
143 %description static -l pl.UTF-8
144 Statyczne wersje podstawowych bibliotek C++ Boost.
145
146 %package python-devel-common
147 Summary:        Boost.Python development headers
148 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151
152 %description python-devel-common
153 Headers for the Boost.Python library.
154
155 %description python-devel-common -l pl.UTF-8
156 Pliki nagłówkowe dla biblioteki Boost.Python.
157
158 %package python
159 Summary:        Boost.Python library
160 Summary(pl.UTF-8):      biblioteka Boost.Python
161 Group:          Libraries
162 Requires:       python
163
164 %description python
165 Use the Boost Python Library to quickly and easily export a C++
166 library to Python such that the Python interface is very similar to
167 the C++ interface. It is designed to be minimally intrusive on your
168 C++ design. In most cases, you should not have to alter your C++
169 classes in any way in order to use them with Boost.Python. The system
170 should simply ``reflect'' your C++ classes and functions into Python.
171
172 %description python -l pl.UTF-8
173 Biblioteka Boost Python służy do szybkiego i prostego eksportu
174 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
175 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
176 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
177 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
178 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
179 klasy C++ i funkcje do Pythona.
180
181 %package python-devel
182 Summary:        Boost.Python development library
183 Summary(pl.UTF-8):      Biblioteka developerska Boost.Python
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186 Requires:       %{name}-python = %{version}-%{release}
187 Requires:       %{name}-python-devel-common = %{version}-%{release}
188
189 %description python-devel
190 Boost.Python development library.
191
192 %description python-devel -l pl.UTF-8
193 Biblioteka developerska Boost.Python.
194
195 %package python-static
196 Summary:        Static version of Boost.Python library
197 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
198 Group:          Development/Libraries
199 Requires:       %{name}-python-devel = %{version}-%{release}
200
201 %description python-static
202 Static version of Boost.Python library.
203
204 %description python-static -l pl.UTF-8
205 Statyczna wersja biblioteki Boost.Python.
206
207 %package python3
208 Summary:        Boost.Python library
209 Summary(pl.UTF-8):      biblioteka Boost.Python
210 Group:          Libraries
211 Requires:       python3
212
213 %description python3
214 Use the Boost Python Library to quickly and easily export a C++
215 library to Python 3 such that the Python 3 interface is very similar
216 to the C++ interface. It is designed to be minimally intrusive on your
217 C++ design. In most cases, you should not have to alter your C++
218 classes in any way in order to use them with Boost.Python. The system
219 should simply ``reflect'' your C++ classes and functions into Python 3.
220
221 %description python3 -l pl.UTF-8
222 Biblioteka Boost Python służy do szybkiego i prostego eksportu
223 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
224 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
225 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
226 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
227 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
228 klasy C++ i funkcje do Pythona 3.
229
230 %package python3-devel
231 Summary:        Boost.Python development library
232 Summary(pl.UTF-8):      Biblioteka developerska Boost.Python
233 Group:          Development/Libraries
234 Requires:       %{name}-devel = %{version}-%{release}
235 Requires:       %{name}-python3 = %{version}-%{release}
236 Requires:       %{name}-python-devel-common = %{version}-%{release}
237
238 %description python3-devel
239 Boost.Python development library.
240
241 %description python3-devel -l pl.UTF-8
242 Biblioteka developerska Boost.Python.
243
244 %package python3-static
245 Summary:        Static version of Boost.Python library
246 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
247 Group:          Development/Libraries
248 Requires:       %{name}-python3-devel = %{version}-%{release}
249
250 %description python3-static
251 Static version of Boost.Python library.
252
253 %description python3-static -l pl.UTF-8
254 Statyczna wersja biblioteki Boost.Python.
255
256 %package chrono
257 Summary:        Useful time utilities
258 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
259 Group:          Libraries
260 Obsoletes:      boost < 1.33
261
262 %description chrono
263 Useful time utilities.
264
265 %description chrono -l pl.UTF-8
266 Przydatne funkcje związane z czasem.
267
268 %package context
269 Summary:        Boost.Context - context switching library
270 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
271 Group:          Libraries
272
273 %description context
274 Boost.Context - context switching library, providing a sort of
275 cooperative multitasking on a single thread.
276
277 %description context -l pl.UTF-8
278 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
279 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
280
281 %package date_time
282 Summary:        Date-Time library
283 Summary(pl.UTF-8):      Biblioteka daty-czasu
284 Group:          Libraries
285 Obsoletes:      boost < 1.33
286
287 %description date_time
288 A set of date-time libraries.
289
290 %description date_time -l pl.UTF-8
291 Zbiór bibliotek daty-czasu.
292
293 %package filesystem
294 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
295 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
296 Group:          Libraries
297 Requires:       %{name}-system = %{version}-%{release}
298 Obsoletes:      boost < 1.33
299
300 %description filesystem
301 The boost::filesystem library provides portable facilities to query
302 and manipulate paths, files, and directories.
303
304 %description filesystem -l pl.UTF-8
305 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
306 operacjach na ścieżkach, plikach i katalogach.
307
308 %package graph
309 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
310 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
311 Group:          Libraries
312
313 %description graph
314 The boost::graph library provides portable facilities to operate on
315 graph data structures using graph algorithms.
316
317 %description graph -l pl.UTF-8
318 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
319 strukturach danych typu graf za pomocą algorytmów związanych z
320 grafami.
321
322 %package locale
323 Summary:        Provide localization and Unicode handling tools for C++
324 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
325 Group:          Libraries
326
327 %description locale
328 Provide localization and Unicode handling tools for C++.
329
330 %description locale -l pl.UTF-8
331 Narzędzia do obsługi lokalizacji i Unikodu w C++.
332
333 %package log
334 Summary:        Provide logging tools for C++
335 Summary(pl.UTF-8):      Narzędzia do logowania w C++
336 Group:          Libraries
337
338 %description log
339 Provide logging tools for C++.
340
341 %description log -l pl.UTF-8
342 Narzędzia do logowania w C++.
343
344 %package program_options
345 Summary:        Access to program options, via conventional methods such as command line and config file
346 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
347 Group:          Libraries
348
349 %description program_options
350 The program_options library allows program developers to obtain
351 program options, that is (name, value) pairs from the user, via
352 conventional methods such as command line and config file.
353
354 %description program_options -l pl.UTF-8
355 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
356 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
357 jak linia poleceń, czy plik konfiguracyjny.
358
359 %package regex
360 Summary:        Boost C++ regular expressions library
361 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
362 Group:          Libraries
363
364 %description regex
365 Shared library for Boost C++ regular expressions.
366
367 %description regex -l pl.UTF-8
368 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
369
370 %package signals
371 Summary:        Signals & slots callback implementation
372 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
373 Group:          Libraries
374 Obsoletes:      boost < 1.33
375
376 %description signals
377 The boost::signals library is an implementation of a signals and slots
378 system.
379
380 %description signals -l pl.UTF-8
381 Biblioteka boost::signals jest implementacją systemu sygnałów i
382 slotów.
383
384 %package system
385 Summary:        Support for getting system specific error codes
386 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
387 Group:          Libraries
388
389 %description system
390 The Boost System library provides simple, light-weight error_code
391 objects that encapsulate system-specific error code values, yet also
392 provide access to more abstract and portable error conditions objects.
393
394 %description system -l pl.UTF-8
395 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
396 obudowujące wartości kodów błędów specyficznych dla systemu, dając
397 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
398 błędów.
399
400 %package test
401 Summary:        Support for program testing and execution monitoring
402 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
403 Group:          Libraries
404 Obsoletes:      boost < 1.33
405
406 %description test
407 Support for simple program testing, full unit testing, and for program
408 execution monitoring.
409
410 %description test -l pl.UTF-8
411 Wsparcie dla prostego testowania programu, pełnego testowania i
412 monitorowania wykonania programu.
413
414 %package thread
415 Summary:        Portable C++ threads library
416 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
417 Group:          Libraries
418 Obsoletes:      boost < 1.33
419
420 %description thread
421 Portable C++ threads library - shared library.
422
423 %description thread -l pl.UTF-8
424 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
425
426 %package timer
427 Summary:        Event timer, progress timer, and progress display classes
428 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
429 Group:          Libraries
430 Obsoletes:      boost < 1.33
431
432 %description timer
433 Event timer, progress timer, and progress display classes.
434
435 %description timer -l pl.UTF-8
436 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
437
438 %package wave
439 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
440 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
441 Group:          Development/Libraries
442
443 %description wave
444 Boost.Wave - a standard compliant C++ preprocessor library.
445
446 %description wave -l pl.UTF-8
447 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
448
449 %package doc
450 Summary:        Boost C++ Library documentation
451 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
452 Group:          Documentation
453 %if "%{_rpmversion}" >= "5"
454 BuildArch:      noarch
455 %endif
456
457 %description doc
458 Documentation for the Boost C++ Library.
459
460 %description doc -l pl.UTF-8
461 Dokumentacja dla biblioteki Boost C++.
462
463 %prep
464 %setup -q -n %{name}_%{fver}
465 %patch0 -p1
466 #patch1 -p0
467
468 %patch203 -p0
469 %patch211 -p1
470 %patch212 -p1
471 %patch218 -p1
472 %patch221 -p1
473 %patch222 -p1
474 %patch224 -p1
475
476 # - don't know how to pass it through (b)jam -s (no way?)
477 #   due to oversophisticated build flags system.
478 # - pass -fPIC due to <shared-linkable> removal.
479 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/src/tools/gcc.jam
480
481 # cleanup -g switch to avoid override debuginfocflags.
482 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/src/tools/gcc.jam
483 # link against shared expat library.
484 #%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
485
486 cat << EOF > tools/build/src/user-config.jam
487 using gcc : %{cxx_version} : %{__cxx} ;
488 EOF
489
490 # cleanup backups after patching
491 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
492
493 %build
494 EXPAT_INCLUDE=%{_includedir} \
495 EXPAT_LIBPATH=%{_libdir} \
496 ICU_PATH=%{_prefix} \
497 ./bootstrap.sh \
498         --prefix=%{_prefix} \
499         -without-libraries=python
500
501 ./b2 \
502 %ifarch x32
503         --without-context \
504         --without-coroutine \
505 %endif
506         -d2 --toolset=gcc \
507         variant=release \
508         debug-symbols=on \
509         inlining=on \
510         link=static,shared \
511         threading=multi
512
513 %if %{with python3}
514 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
515 ./b2 \
516         --with-python python=%{py3_ver}m \
517         -a -d2 --toolset=gcc \
518         variant=release \
519         debug-symbols=on \
520         inlining=on \
521         link=static,shared \
522         threading=multi
523 %endif
524
525 %if %{with python2}
526 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
527 ./b2 \
528         --with-python python=%{py_ver} \
529         -a -d2 --toolset=gcc \
530         variant=release \
531         debug-symbols=on \
532         inlining=on \
533         link=static,shared \
534         threading=multi
535 %endif
536
537 %install
538 rm -rf $RPM_BUILD_ROOT
539 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
540
541 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
542
543 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
544 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
545 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
546
547 # documentation
548 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
549
550 # as the documentation doesn't completely reside in a directory of its
551 # own, we need to find out ourselves... this looks for HTML files and
552 # then collects everything linked from those.  this is certainly quite
553 # unoptimized wrt mkdir calls, but does it really matter?
554 installdocs() {
555 for i in $(find -type f -name '*.htm*'); do
556         # bjam docu is included in the boost-jam RPM
557         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
558                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
559                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
560                         sub rewrite_link
561                         {
562                                 my $link = shift;
563                                 # rewrite links from boost/* to %{_includedir}/boost/* and
564                                 # ignore external links as well as document-internal ones.
565                                 # HTML files are also ignored as they get installed anyway.
566                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
567                                 {
568                                         (my $file = $link) =~ s/\#.*//;
569                                         print "$file\n";
570                                 }
571                                 $link;
572                         }
573                         open IN, @ARGV[0];
574                         open OUT, ">@ARGV[1]";
575                         my $in_link;
576                         while (<IN>)
577                         {
578                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
579                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
580                                 print OUT;
581                                 $in_link = /href|src=\s*$/;
582                         }
583 EOT`; do
584                         TARGET=${i%/*}/$LINKED
585                         # ignore non-existant linked files
586                         if test -f $TARGET; then
587                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
588                         fi
589                 done
590         fi
591 done
592 }; installdocs
593
594 %clean
595 rm -rf $RPM_BUILD_ROOT
596
597 %post   -p /sbin/ldconfig
598 %postun -p /sbin/ldconfig
599
600 %post   chrono -p /sbin/ldconfig
601 %postun chrono -p /sbin/ldconfig
602
603 %post   context -p /sbin/ldconfig
604 %postun context -p /sbin/ldconfig
605
606 %post   date_time -p /sbin/ldconfig
607 %postun date_time -p /sbin/ldconfig
608
609 %post   filesystem -p /sbin/ldconfig
610 %postun filesystem -p /sbin/ldconfig
611
612 %post   graph -p /sbin/ldconfig
613 %postun graph -p /sbin/ldconfig
614
615 %post   locale -p /sbin/ldconfig
616 %postun locale -p /sbin/ldconfig
617
618 %post   python -p /sbin/ldconfig
619 %postun python -p /sbin/ldconfig
620
621 %post   python3 -p /sbin/ldconfig
622 %postun python3 -p /sbin/ldconfig
623
624 %post   program_options -p /sbin/ldconfig
625 %postun program_options -p /sbin/ldconfig
626
627 %post   regex -p /sbin/ldconfig
628 %postun regex -p /sbin/ldconfig
629
630 %post   signals -p /sbin/ldconfig
631 %postun signals -p /sbin/ldconfig
632
633 %post   system -p /sbin/ldconfig
634 %postun system -p /sbin/ldconfig
635
636 %post   test -p /sbin/ldconfig
637 %postun test -p /sbin/ldconfig
638
639 %post   thread -p /sbin/ldconfig
640 %postun thread -p /sbin/ldconfig
641
642 %post   timer -p /sbin/ldconfig
643 %postun timer -p /sbin/ldconfig
644
645 %post   wave -p /sbin/ldconfig
646 %postun wave -p /sbin/ldconfig
647
648 %files
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
651 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
652 %ifnarch x32
653 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
654 %endif
655 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
656 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
657 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
658 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
659 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
660
661 %files devel
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libboost_atomic.so
664 %attr(755,root,root) %{_libdir}/libboost_chrono.so
665 %attr(755,root,root) %{_libdir}/libboost_container.so
666 %ifnarch x32
667 %attr(755,root,root) %{_libdir}/libboost_context.so
668 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
669 %endif
670 %attr(755,root,root) %{_libdir}/libboost_date_time.so
671 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
672 %attr(755,root,root) %{_libdir}/libboost_graph.so
673 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
674 %attr(755,root,root) %{_libdir}/libboost_locale.so
675 %attr(755,root,root) %{_libdir}/libboost_log.so
676 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
677 %attr(755,root,root) %{_libdir}/libboost_math_*.so
678 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
679 %attr(755,root,root) %{_libdir}/libboost_program_options.so
680 %attr(755,root,root) %{_libdir}/libboost_regex.so
681 %attr(755,root,root) %{_libdir}/libboost_random.so
682 %attr(755,root,root) %{_libdir}/libboost_serialization.so
683 %attr(755,root,root) %{_libdir}/libboost_signals.so
684 %attr(755,root,root) %{_libdir}/libboost_system.so
685 %attr(755,root,root) %{_libdir}/libboost_thread.so
686 %attr(755,root,root) %{_libdir}/libboost_timer.so
687 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
688 %attr(755,root,root) %{_libdir}/libboost_wave.so
689 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
690 %{_includedir}/boost
691 %exclude %{_includedir}/boost/python
692 %exclude %{_includedir}/boost/python.hpp
693
694 %files static
695 %defattr(644,root,root,755)
696 %{_libdir}/libboost_atomic.a
697 %{_libdir}/libboost_chrono.a
698 %{_libdir}/libboost_container.a
699 %ifnarch x32
700 %{_libdir}/libboost_context.a
701 %{_libdir}/libboost_coroutine.a
702 %endif
703 %{_libdir}/libboost_date_time.a
704 %{_libdir}/libboost_exception.a
705 %{_libdir}/libboost_filesystem.a
706 %{_libdir}/libboost_graph.a
707 %{_libdir}/libboost_iostreams.a
708 %{_libdir}/libboost_locale.a
709 %{_libdir}/libboost_log.a
710 %{_libdir}/libboost_log_setup.a
711 %{_libdir}/libboost_math_*.a
712 %{_libdir}/libboost_prg_exec_monitor.a
713 %{_libdir}/libboost_program_options.a
714 %{_libdir}/libboost_random.a
715 %{_libdir}/libboost_regex.a
716 %{_libdir}/libboost_serialization.a
717 %{_libdir}/libboost_signals.a
718 %{_libdir}/libboost_system.a
719 %{_libdir}/libboost_test_exec_monitor.a
720 %{_libdir}/libboost_timer.a
721 %{_libdir}/libboost_thread.a
722 %{_libdir}/libboost_unit_test_framework.a
723 %{_libdir}/libboost_wave.a
724 %{_libdir}/libboost_wserialization.a
725
726 %if %{with python2} || %{with python3}
727 %files python-devel-common
728 %defattr(644,root,root,755)
729 %{_includedir}/boost/python
730 %{_includedir}/boost/python.hpp
731 %endif
732
733 %if %{with python2}
734 %files python
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
737
738 %files python-devel
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libboost_python.so
741
742 %files python-static
743 %defattr(644,root,root,755)
744 %{_libdir}/libboost_python.a
745 %endif
746
747 %if %{with python3}
748 %files python3
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
751
752 %files python3-devel
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/libboost_python3.so
755
756 %files python3-static
757 %defattr(644,root,root,755)
758 %{_libdir}/libboost_python3.a
759 %endif
760
761 %files chrono
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
764
765 %ifnarch x32
766 %files context
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
769 %endif
770
771 %files date_time
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
774
775 %files filesystem
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
778
779 %files graph
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
782
783 %files locale
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
786
787 %files log
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
790 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
791
792 %files program_options
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
795
796 %files regex
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
799
800 %files signals
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
803
804 %files system
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
807
808 %files test
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
811 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
812
813 %files thread
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
816
817 %files timer
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
820
821 %files wave
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
824
825 %files doc
826 %defattr(644,root,root,755)
827 %{_docdir}/%{name}-%{version}
This page took 0.354045 seconds and 4 git commands to generate.