]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- python 3.6
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.61.0
15 Release:        3
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  6095876341956f65f9d35939ccea1a9f
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 Patch2:         %{name}-clean-gcc-flags.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8881
27 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
28 URL:            http://www.boost.org/
29 BuildRequires:  bzip2-devel
30 BuildRequires:  expat-devel
31 BuildRequires:  libicu-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  perl-base
34 %{?with_python:BuildRequires:   python-devel >= 2.2}
35 %{?with_python3:BuildRequires:  python3-devel}
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  zlib-devel
38 BuildConflicts: gcc = 5:3.3.1
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
42
43 %description
44 The Boost web site provides free peer-reviewed portable C++ source
45 libraries. The emphasis is on libraries which work well with the C++
46 Standard Library. One goal is to establish "existing practice" and
47 provide reference implementations so that the Boost libraries are
48 suitable for eventual standardization. Some of the libraries have
49 already been proposed for inclusion in the C++ Standards Committee's
50 upcoming C++ Standard Library Technical Report.
51
52 %description -l pl.UTF-8
53 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
54 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
55 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
56 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
57 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
58 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
59 Raporcie Technicznym Biblioteki Standardowej C++.
60
61 %package devel
62 Summary:        Boost C++ development headers
63 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       %{name}-chrono = %{version}-%{release}
67 Requires:       %{name}-context = %{version}-%{release}
68 Requires:       %{name}-date_time = %{version}-%{release}
69 Requires:       %{name}-filesystem = %{version}-%{release}
70 Requires:       %{name}-graph = %{version}-%{release}
71 Requires:       %{name}-locale = %{version}-%{release}
72 Requires:       %{name}-log = %{version}-%{release}
73 Requires:       %{name}-program_options = %{version}-%{release}
74 Requires:       %{name}-regex = %{version}-%{release}
75 Requires:       %{name}-signals = %{version}-%{release}
76 Requires:       %{name}-system = %{version}-%{release}
77 Requires:       %{name}-test = %{version}-%{release}
78 Requires:       %{name}-thread = %{version}-%{release}
79 Requires:       %{name}-timer = %{version}-%{release}
80 Requires:       %{name}-wave = %{version}-%{release}
81 Requires:       libstdc++-devel
82 Obsoletes:      boost-any-devel
83 Obsoletes:      boost-array-devel
84 Obsoletes:      boost-asio
85 Obsoletes:      boost-bind-devel
86 Obsoletes:      boost-call_traits-devel
87 Obsoletes:      boost-compatibility-devel
88 Obsoletes:      boost-compose-devel
89 Obsoletes:      boost-compressed_pair-devel
90 Obsoletes:      boost-concept_check-devel
91 Obsoletes:      boost-conversion-devel
92 Obsoletes:      boost-crc-devel
93 Obsoletes:      boost-date_time-devel
94 Obsoletes:      boost-filesystem-devel
95 Obsoletes:      boost-graph-devel
96 Obsoletes:      boost-mem_fn-devel
97 Obsoletes:      boost-mpl-devel
98 Obsoletes:      boost-preprocessor-devel
99 Obsoletes:      boost-program_options-devel
100 Obsoletes:      boost-ref-devel
101 Obsoletes:      boost-regex-devel
102 Obsoletes:      boost-signals-devel
103 Obsoletes:      boost-spirit-devel
104 Obsoletes:      boost-statechart-devel
105 Obsoletes:      boost-static_assert-devel
106 Obsoletes:      boost-test-devel
107 Obsoletes:      boost-thread-devel
108 Obsoletes:      boost-tr1-devel
109 Obsoletes:      boost-type_traits-devel
110 Obsoletes:      boost-typeof-devel
111 Obsoletes:      boost-uBLAS-devel
112 Obsoletes:      boost-utility-devel
113 Obsoletes:      boost-wave-devel
114 Obsoletes:      boost-xpressive-devel
115
116 %description devel
117 Header files for the Boost C++ libraries.
118
119 %description devel -l pl.UTF-8
120 Pliki nagłówkowe bibliotek C++ Boost.
121
122 %package static
123 Summary:        Static version of base Boost C++ libraries
124 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127 Obsoletes:      boost-static < 1.33
128
129 %description static
130 Static version of base Boost C++ libraries.
131
132 %description static -l pl.UTF-8
133 Statyczne wersje podstawowych bibliotek C++ Boost.
134
135 %package python-devel-common
136 Summary:        Boost.Python development headers
137 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140
141 %description python-devel-common
142 Headers for the Boost.Python library.
143
144 %description python-devel-common -l pl.UTF-8
145 Pliki nagłówkowe biblioteki Boost.Python.
146
147 %package python
148 Summary:        Boost.Python library for Python 2
149 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
150 Group:          Libraries
151 Requires:       python-libs
152
153 %description python
154 Use the Boost Python Library to quickly and easily export a C++
155 library to Python 2 such that the Python 2 interface is very similar
156 to the C++ interface. It is designed to be minimally intrusive on your
157 C++ design. In most cases, you should not have to alter your C++
158 classes in any way in order to use them with Boost.Python. The system
159 should simply ``reflect'' your C++ classes and functions into Python
160 3.
161
162 %description python -l pl.UTF-8
163 Biblioteka Boost Python służy do szybkiego i prostego eksportu
164 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
165 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
166 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
167 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
168 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
169 klasy C++ i funkcje do Pythona 3.
170
171 %package python-devel
172 Summary:        Boost.Python development files for Python 2
173 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176 Requires:       %{name}-python = %{version}-%{release}
177 Requires:       %{name}-python-devel-common = %{version}-%{release}
178
179 %description python-devel
180 Boost.Python development files for Python 2.
181
182 %description python-devel -l pl.UTF-8
183 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
184
185 %package python-static
186 Summary:        Static version of Boost.Python library for Python 2
187 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
188 Group:          Development/Libraries
189 Requires:       %{name}-python-devel = %{version}-%{release}
190
191 %description python-static
192 Static version of Boost.Python library for Python 2.
193
194 %description python-static -l pl.UTF-8
195 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
196
197 %package python3
198 Summary:        Boost.Python library for Python 3
199 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
200 Group:          Libraries
201 Requires:       python3-libs
202
203 %description python3
204 Use the Boost Python Library to quickly and easily export a C++
205 library to Python 3 such that the Python 3 interface is very similar
206 to the C++ interface. It is designed to be minimally intrusive on your
207 C++ design. In most cases, you should not have to alter your C++
208 classes in any way in order to use them with Boost.Python. The system
209 should simply ``reflect'' your C++ classes and functions into Python
210 3.
211
212 %description python3 -l pl.UTF-8
213 Biblioteka Boost Python służy do szybkiego i prostego eksportu
214 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
215 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
216 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
217 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
218 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
219 klasy C++ i funkcje do Pythona 3.
220
221 %package python3-devel
222 Summary:        Boost.Python development files for Python 3
223 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
224 Group:          Development/Libraries
225 Requires:       %{name}-devel = %{version}-%{release}
226 Requires:       %{name}-python-devel-common = %{version}-%{release}
227 Requires:       %{name}-python3 = %{version}-%{release}
228
229 %description python3-devel
230 Boost.Python development files for Python 3.
231
232 %description python3-devel -l pl.UTF-8
233 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
234
235 %package python3-static
236 Summary:        Static version of Boost.Python library for Python 3
237 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
238 Group:          Development/Libraries
239 Requires:       %{name}-python3-devel = %{version}-%{release}
240
241 %description python3-static
242 Static version of Boost.Python library for Python 3.
243
244 %description python3-static -l pl.UTF-8
245 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
246
247 %package chrono
248 Summary:        Useful time utilities
249 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
250 Group:          Libraries
251 Obsoletes:      boost < 1.33
252
253 %description chrono
254 Useful time utilities.
255
256 %description chrono -l pl.UTF-8
257 Przydatne funkcje związane z czasem.
258
259 %package context
260 Summary:        Boost.Context - context switching library
261 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
262 Group:          Libraries
263
264 %description context
265 Boost.Context - context switching library, providing a sort of
266 cooperative multitasking on a single thread.
267
268 %description context -l pl.UTF-8
269 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
270 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
271
272 %package date_time
273 Summary:        Date-Time library
274 Summary(pl.UTF-8):      Biblioteka daty-czasu
275 Group:          Libraries
276 Obsoletes:      boost < 1.33
277
278 %description date_time
279 A set of date-time libraries.
280
281 %description date_time -l pl.UTF-8
282 Zbiór bibliotek daty-czasu.
283
284 %package filesystem
285 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
286 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
287 Group:          Libraries
288 Requires:       %{name}-system = %{version}-%{release}
289 Obsoletes:      boost < 1.33
290
291 %description filesystem
292 The boost::filesystem library provides portable facilities to query
293 and manipulate paths, files, and directories.
294
295 %description filesystem -l pl.UTF-8
296 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
297 operacjach na ścieżkach, plikach i katalogach.
298
299 %package graph
300 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
301 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
302 Group:          Libraries
303
304 %description graph
305 The boost::graph library provides portable facilities to operate on
306 graph data structures using graph algorithms.
307
308 %description graph -l pl.UTF-8
309 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
310 strukturach danych typu graf za pomocą algorytmów związanych z
311 grafami.
312
313 %package locale
314 Summary:        Provide localization and Unicode handling tools for C++
315 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
316 Group:          Libraries
317
318 %description locale
319 Provide localization and Unicode handling tools for C++.
320
321 %description locale -l pl.UTF-8
322 Narzędzia do obsługi lokalizacji i Unikodu w C++.
323
324 %package log
325 Summary:        Provide logging tools for C++
326 Summary(pl.UTF-8):      Narzędzia do logowania w C++
327 Group:          Libraries
328
329 %description log
330 Provide logging tools for C++.
331
332 %description log -l pl.UTF-8
333 Narzędzia do logowania w C++.
334
335 %package program_options
336 Summary:        Access to program options, via conventional methods such as command line and config file
337 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
338 Group:          Libraries
339
340 %description program_options
341 The program_options library allows program developers to obtain
342 program options, that is (name, value) pairs from the user, via
343 conventional methods such as command line and config file.
344
345 %description program_options -l pl.UTF-8
346 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
347 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
348 jak linia poleceń, czy plik konfiguracyjny.
349
350 %package regex
351 Summary:        Boost C++ regular expressions library
352 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
353 Group:          Libraries
354
355 %description regex
356 Shared library for Boost C++ regular expressions.
357
358 %description regex -l pl.UTF-8
359 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
360
361 %package signals
362 Summary:        Signals & slots callback implementation
363 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
364 Group:          Libraries
365 Obsoletes:      boost < 1.33
366
367 %description signals
368 The boost::signals library is an implementation of a signals and slots
369 system.
370
371 %description signals -l pl.UTF-8
372 Biblioteka boost::signals jest implementacją systemu sygnałów i
373 slotów.
374
375 %package system
376 Summary:        Support for getting system specific error codes
377 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
378 Group:          Libraries
379
380 %description system
381 The Boost System library provides simple, light-weight error_code
382 objects that encapsulate system-specific error code values, yet also
383 provide access to more abstract and portable error conditions objects.
384
385 %description system -l pl.UTF-8
386 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
387 obudowujące wartości kodów błędów specyficznych dla systemu, dając
388 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
389 błędów.
390
391 %package test
392 Summary:        Support for program testing and execution monitoring
393 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
394 Group:          Libraries
395 Obsoletes:      boost < 1.33
396
397 %description test
398 Support for simple program testing, full unit testing, and for program
399 execution monitoring.
400
401 %description test -l pl.UTF-8
402 Wsparcie dla prostego testowania programu, pełnego testowania i
403 monitorowania wykonania programu.
404
405 %package thread
406 Summary:        Portable C++ threads library
407 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
408 Group:          Libraries
409 Obsoletes:      boost < 1.33
410
411 %description thread
412 Portable C++ threads library - shared library.
413
414 %description thread -l pl.UTF-8
415 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
416
417 %package timer
418 Summary:        Event timer, progress timer, and progress display classes
419 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
420 Group:          Libraries
421 Obsoletes:      boost < 1.33
422
423 %description timer
424 Event timer, progress timer, and progress display classes.
425
426 %description timer -l pl.UTF-8
427 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
428
429 %package wave
430 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
431 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
432 Group:          Development/Libraries
433
434 %description wave
435 Boost.Wave - a standard compliant C++ preprocessor library.
436
437 %description wave -l pl.UTF-8
438 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
439
440 %package doc
441 Summary:        Boost C++ Library documentation
442 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
443 Group:          Documentation
444 %if "%{_rpmversion}" >= "5"
445 BuildArch:      noarch
446 %endif
447
448 %description doc
449 Documentation for the Boost C++ Library.
450
451 %description doc -l pl.UTF-8
452 Dokumentacja dla biblioteki Boost C++.
453
454 %prep
455 %setup -q -n %{name}_%{fver}
456 %patch0 -p1
457 %patch1 -p1
458 %patch2 -p1
459
460 %patch203 -p0
461 %patch221 -p1
462
463 cat << EOF > tools/build/src/user-config.jam
464 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
465 EOF
466
467 # cleanup backups after patching
468 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
469
470 %build
471 EXPAT_INCLUDE=%{_includedir} \
472 EXPAT_LIBPATH=%{_libdir} \
473 ICU_PATH=%{_prefix} \
474 ./bootstrap.sh \
475         --prefix=%{_prefix} \
476         -without-libraries=python
477
478 ./b2 \
479         -d2 --toolset=gcc \
480         variant=release \
481         debug-symbols=on \
482         inlining=on \
483         link=static,shared \
484         threading=multi
485
486 %if %{with python3}
487 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
488 ./b2 \
489         --with-python python=%{py3_ver}m \
490         -a -d2 --toolset=gcc \
491         variant=release \
492         debug-symbols=on \
493         inlining=on \
494         link=static,shared \
495         threading=multi
496 %endif
497
498 %if %{with python2}
499 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
500 ./b2 \
501         --with-python python=%{py_ver} \
502         -a -d2 --toolset=gcc \
503         variant=release \
504         debug-symbols=on \
505         inlining=on \
506         link=static,shared \
507         threading=multi
508 %endif
509
510 %install
511 rm -rf $RPM_BUILD_ROOT
512 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
513
514 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
515
516 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
517 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
518 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
519
520 # documentation
521 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
522
523 # as the documentation doesn't completely reside in a directory of its
524 # own, we need to find out ourselves... this looks for HTML files and
525 # then collects everything linked from those.  this is certainly quite
526 # unoptimized wrt mkdir calls, but does it really matter?
527 installdocs() {
528 for i in $(find -type f -name '*.htm*'); do
529         # bjam docu is included in the boost-jam RPM
530         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
531                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
532                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
533                         sub rewrite_link
534                         {
535                                 my $link = shift;
536                                 # rewrite links from boost/* to %{_includedir}/boost/* and
537                                 # ignore external links as well as document-internal ones.
538                                 # HTML files are also ignored as they get installed anyway.
539                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
540                                 {
541                                         (my $file = $link) =~ s/\#.*//;
542                                         print "$file\n";
543                                 }
544                                 $link;
545                         }
546                         open IN, @ARGV[0];
547                         open OUT, ">@ARGV[1]";
548                         my $in_link;
549                         while (<IN>)
550                         {
551                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
552                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
553                                 print OUT;
554                                 $in_link = /href|src=\s*$/;
555                         }
556 EOT`; do
557                         TARGET=${i%/*}/$LINKED
558                         # ignore non-existant linked files
559                         if test -f $TARGET; then
560                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
561                         fi
562                 done
563         fi
564 done
565 }; installdocs
566
567 %clean
568 rm -rf $RPM_BUILD_ROOT
569
570 %post   -p /sbin/ldconfig
571 %postun -p /sbin/ldconfig
572
573 %post   chrono -p /sbin/ldconfig
574 %postun chrono -p /sbin/ldconfig
575
576 %post   context -p /sbin/ldconfig
577 %postun context -p /sbin/ldconfig
578
579 %post   date_time -p /sbin/ldconfig
580 %postun date_time -p /sbin/ldconfig
581
582 %post   filesystem -p /sbin/ldconfig
583 %postun filesystem -p /sbin/ldconfig
584
585 %post   graph -p /sbin/ldconfig
586 %postun graph -p /sbin/ldconfig
587
588 %post   locale -p /sbin/ldconfig
589 %postun locale -p /sbin/ldconfig
590
591 %post   python -p /sbin/ldconfig
592 %postun python -p /sbin/ldconfig
593
594 %post   python3 -p /sbin/ldconfig
595 %postun python3 -p /sbin/ldconfig
596
597 %post   program_options -p /sbin/ldconfig
598 %postun program_options -p /sbin/ldconfig
599
600 %post   regex -p /sbin/ldconfig
601 %postun regex -p /sbin/ldconfig
602
603 %post   signals -p /sbin/ldconfig
604 %postun signals -p /sbin/ldconfig
605
606 %post   system -p /sbin/ldconfig
607 %postun system -p /sbin/ldconfig
608
609 %post   test -p /sbin/ldconfig
610 %postun test -p /sbin/ldconfig
611
612 %post   thread -p /sbin/ldconfig
613 %postun thread -p /sbin/ldconfig
614
615 %post   timer -p /sbin/ldconfig
616 %postun timer -p /sbin/ldconfig
617
618 %post   wave -p /sbin/ldconfig
619 %postun wave -p /sbin/ldconfig
620
621 %files
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
624 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
625 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
626 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
627 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
628 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
629 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
630 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so.*.*.*
631 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
632
633 %files devel
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/libboost_atomic.so
636 %attr(755,root,root) %{_libdir}/libboost_chrono.so
637 %attr(755,root,root) %{_libdir}/libboost_container.so
638 %attr(755,root,root) %{_libdir}/libboost_context.so
639 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
640 %attr(755,root,root) %{_libdir}/libboost_date_time.so
641 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
642 %attr(755,root,root) %{_libdir}/libboost_graph.so
643 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
644 %attr(755,root,root) %{_libdir}/libboost_locale.so
645 %attr(755,root,root) %{_libdir}/libboost_log.so
646 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
647 %attr(755,root,root) %{_libdir}/libboost_math_*.so
648 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
649 %attr(755,root,root) %{_libdir}/libboost_program_options.so
650 %attr(755,root,root) %{_libdir}/libboost_regex.so
651 %attr(755,root,root) %{_libdir}/libboost_random.so
652 %attr(755,root,root) %{_libdir}/libboost_serialization.so
653 %attr(755,root,root) %{_libdir}/libboost_signals.so
654 %attr(755,root,root) %{_libdir}/libboost_system.so
655 %attr(755,root,root) %{_libdir}/libboost_thread.so
656 %attr(755,root,root) %{_libdir}/libboost_timer.so
657 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
658 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
659 %attr(755,root,root) %{_libdir}/libboost_wave.so
660 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
661 %{_includedir}/boost
662 %exclude %{_includedir}/boost/python
663 %exclude %{_includedir}/boost/python.hpp
664
665 %files static
666 %defattr(644,root,root,755)
667 %{_libdir}/libboost_atomic.a
668 %{_libdir}/libboost_chrono.a
669 %{_libdir}/libboost_container.a
670 %{_libdir}/libboost_context.a
671 %{_libdir}/libboost_coroutine.a
672 %{_libdir}/libboost_date_time.a
673 %{_libdir}/libboost_exception.a
674 %{_libdir}/libboost_filesystem.a
675 %{_libdir}/libboost_graph.a
676 %{_libdir}/libboost_iostreams.a
677 %{_libdir}/libboost_locale.a
678 %{_libdir}/libboost_log.a
679 %{_libdir}/libboost_log_setup.a
680 %{_libdir}/libboost_math_*.a
681 %{_libdir}/libboost_prg_exec_monitor.a
682 %{_libdir}/libboost_program_options.a
683 %{_libdir}/libboost_random.a
684 %{_libdir}/libboost_regex.a
685 %{_libdir}/libboost_serialization.a
686 %{_libdir}/libboost_signals.a
687 %{_libdir}/libboost_system.a
688 %{_libdir}/libboost_test_exec_monitor.a
689 %{_libdir}/libboost_timer.a
690 %{_libdir}/libboost_thread.a
691 %{_libdir}/libboost_type_erasure.a
692 %{_libdir}/libboost_unit_test_framework.a
693 %{_libdir}/libboost_wave.a
694 %{_libdir}/libboost_wserialization.a
695
696 %if %{with python2} || %{with python3}
697 %files python-devel-common
698 %defattr(644,root,root,755)
699 %{_includedir}/boost/python
700 %{_includedir}/boost/python.hpp
701 %endif
702
703 %if %{with python2}
704 %files python
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
707
708 %files python-devel
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libboost_python.so
711
712 %files python-static
713 %defattr(644,root,root,755)
714 %{_libdir}/libboost_python.a
715 %endif
716
717 %if %{with python3}
718 %files python3
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
721
722 %files python3-devel
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libboost_python3.so
725
726 %files python3-static
727 %defattr(644,root,root,755)
728 %{_libdir}/libboost_python3.a
729 %endif
730
731 %files chrono
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
734
735 %files context
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
738
739 %files date_time
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
742
743 %files filesystem
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
746
747 %files graph
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
750
751 %files locale
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
754
755 %files log
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
758 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
759
760 %files program_options
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
763
764 %files regex
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
767
768 %files signals
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
771
772 %files system
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
775
776 %files test
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
779 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
780
781 %files thread
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
784
785 %files timer
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
788
789 %files wave
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
792
793 %files doc
794 %defattr(644,root,root,755)
795 %{_docdir}/%{name}-%{version}
This page took 0.096819 seconds and 4 git commands to generate.