]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- indicate python version in summaries/descriptions
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #       - fix building context and corouting on x32 (patch1)
6 #
7 # Conditional build:
8 %bcond_without  python2         # without boost-python2 support
9 %bcond_without  python3         # without boost-python3 support
10
11 %define         fver    %(echo %{version} | tr . _)
12 Summary:        The Boost C++ Libraries
13 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
14 Name:           boost
15 Version:        1.57.0
16 Release:        5
17 License:        Boost Software License and others
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  1be49befbdd9a5ce9def2983ba3e7b76
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8870
27 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
28 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
29 # https://svn.boost.org/trac/boost/ticket/8878
30 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
31 # https://svn.boost.org/trac/boost/ticket/8881
32 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
33 # https://svn.boost.org/trac/boost/ticket/8888
34 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
35 # https://svn.boost.org/trac/boost/ticket/9038
36 Patch224:       %{name}-1.54.0-pool-test_linking.patch
37 URL:            http://www.boost.org/
38 BuildRequires:  bzip2-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  libicu-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  perl-base
43 %{?with_python:BuildRequires:   python-devel >= 2.2}
44 %{?with_python3:BuildRequires:  python3-devel}
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  zlib-devel
47 BuildConflicts: gcc = 5:3.3.1
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
51
52 %description
53 The Boost web site provides free peer-reviewed portable C++ source
54 libraries. The emphasis is on libraries which work well with the C++
55 Standard Library. One goal is to establish "existing practice" and
56 provide reference implementations so that the Boost libraries are
57 suitable for eventual standardization. Some of the libraries have
58 already been proposed for inclusion in the C++ Standards Committee's
59 upcoming C++ Standard Library Technical Report.
60
61 %description -l pl.UTF-8
62 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
63 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
64 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
65 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
66 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
67 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
68 Raporcie Technicznym Biblioteki Standardowej C++.
69
70 %package devel
71 Summary:        Boost C++ development headers
72 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       %{name}-chrono = %{version}-%{release}
76 %ifnarch x32
77 Requires:       %{name}-context = %{version}-%{release}
78 %endif
79 Requires:       %{name}-date_time = %{version}-%{release}
80 Requires:       %{name}-filesystem = %{version}-%{release}
81 Requires:       %{name}-graph = %{version}-%{release}
82 Requires:       %{name}-locale = %{version}-%{release}
83 Requires:       %{name}-log = %{version}-%{release}
84 Requires:       %{name}-program_options = %{version}-%{release}
85 Requires:       %{name}-regex = %{version}-%{release}
86 Requires:       %{name}-signals = %{version}-%{release}
87 Requires:       %{name}-system = %{version}-%{release}
88 Requires:       %{name}-test = %{version}-%{release}
89 Requires:       %{name}-thread = %{version}-%{release}
90 Requires:       %{name}-timer = %{version}-%{release}
91 Requires:       %{name}-wave = %{version}-%{release}
92 Requires:       libstdc++-devel
93 Obsoletes:      boost-any-devel
94 Obsoletes:      boost-array-devel
95 Obsoletes:      boost-asio
96 Obsoletes:      boost-bind-devel
97 Obsoletes:      boost-call_traits-devel
98 Obsoletes:      boost-compatibility-devel
99 Obsoletes:      boost-compose-devel
100 Obsoletes:      boost-compressed_pair-devel
101 Obsoletes:      boost-concept_check-devel
102 Obsoletes:      boost-conversion-devel
103 Obsoletes:      boost-crc-devel
104 Obsoletes:      boost-date_time-devel
105 Obsoletes:      boost-filesystem-devel
106 Obsoletes:      boost-graph-devel
107 Obsoletes:      boost-mem_fn-devel
108 Obsoletes:      boost-mpl-devel
109 Obsoletes:      boost-preprocessor-devel
110 Obsoletes:      boost-program_options-devel
111 Obsoletes:      boost-ref-devel
112 Obsoletes:      boost-regex-devel
113 Obsoletes:      boost-signals-devel
114 Obsoletes:      boost-spirit-devel
115 Obsoletes:      boost-statechart-devel
116 Obsoletes:      boost-static_assert-devel
117 Obsoletes:      boost-test-devel
118 Obsoletes:      boost-thread-devel
119 Obsoletes:      boost-tr1-devel
120 Obsoletes:      boost-type_traits-devel
121 Obsoletes:      boost-typeof-devel
122 Obsoletes:      boost-uBLAS-devel
123 Obsoletes:      boost-utility-devel
124 Obsoletes:      boost-wave-devel
125 Obsoletes:      boost-xpressive-devel
126
127 %description devel
128 Header files for the Boost C++ libraries.
129
130 %description devel -l pl.UTF-8
131 Pliki nagłówkowe bibliotek C++ Boost.
132
133 %package static
134 Summary:        Static version of base Boost C++ libraries
135 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138 Obsoletes:      boost-static < 1.33
139
140 %description static
141 Static version of base Boost C++ libraries.
142
143 %description static -l pl.UTF-8
144 Statyczne wersje podstawowych bibliotek C++ Boost.
145
146 %package python-devel-common
147 Summary:        Boost.Python development headers
148 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151
152 %description python-devel-common
153 Headers for the Boost.Python library.
154
155 %description python-devel-common -l pl.UTF-8
156 Pliki nagłówkowe biblioteki Boost.Python.
157
158 %package python
159 Summary:        Boost.Python library for Python 2
160 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
161 Group:          Libraries
162 Requires:       python-libs
163
164 %description python
165 Use the Boost Python Library to quickly and easily export a C++
166 library to Python 2 such that the Python 2 interface is very similar
167 to the C++ interface. It is designed to be minimally intrusive on your
168 C++ design. In most cases, you should not have to alter your C++
169 classes in any way in order to use them with Boost.Python. The system
170 should simply ``reflect'' your C++ classes and functions into Python
171 3.
172
173 %description python -l pl.UTF-8
174 Biblioteka Boost Python służy do szybkiego i prostego eksportu
175 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
176 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
177 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
178 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
179 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
180 klasy C++ i funkcje do Pythona 3.
181
182 %package python-devel
183 Summary:        Boost.Python development files for Python 2
184 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}-%{release}
187 Requires:       %{name}-python = %{version}-%{release}
188 Requires:       %{name}-python-devel-common = %{version}-%{release}
189
190 %description python-devel
191 Boost.Python development files for Python 2.
192
193 %description python-devel -l pl.UTF-8
194 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
195
196 %package python-static
197 Summary:        Static version of Boost.Python library for Python 2
198 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
199 Group:          Development/Libraries
200 Requires:       %{name}-python-devel = %{version}-%{release}
201
202 %description python-static
203 Static version of Boost.Python library for Python 2.
204
205 %description python-static -l pl.UTF-8
206 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
207
208 %package python3
209 Summary:        Boost.Python library for Python 3
210 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
211 Group:          Libraries
212 Requires:       python3-libs
213
214 %description python3
215 Use the Boost Python Library to quickly and easily export a C++
216 library to Python 3 such that the Python 3 interface is very similar
217 to the C++ interface. It is designed to be minimally intrusive on your
218 C++ design. In most cases, you should not have to alter your C++
219 classes in any way in order to use them with Boost.Python. The system
220 should simply ``reflect'' your C++ classes and functions into Python
221 3.
222
223 %description python3 -l pl.UTF-8
224 Biblioteka Boost Python służy do szybkiego i prostego eksportu
225 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
226 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
227 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
228 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
229 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
230 klasy C++ i funkcje do Pythona 3.
231
232 %package python3-devel
233 Summary:        Boost.Python development files for Python 3
234 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
235 Group:          Development/Libraries
236 Requires:       %{name}-devel = %{version}-%{release}
237 Requires:       %{name}-python3 = %{version}-%{release}
238 Requires:       %{name}-python-devel-common = %{version}-%{release}
239
240 %description python3-devel
241 Boost.Python development files for Python 3.
242
243 %description python3-devel -l pl.UTF-8
244 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
245
246 %package python3-static
247 Summary:        Static version of Boost.Python library for Python 3
248 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
249 Group:          Development/Libraries
250 Requires:       %{name}-python3-devel = %{version}-%{release}
251
252 %description python3-static
253 Static version of Boost.Python library for Python 3.
254
255 %description python3-static -l pl.UTF-8
256 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
257
258 %package chrono
259 Summary:        Useful time utilities
260 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
261 Group:          Libraries
262 Obsoletes:      boost < 1.33
263
264 %description chrono
265 Useful time utilities.
266
267 %description chrono -l pl.UTF-8
268 Przydatne funkcje związane z czasem.
269
270 %package context
271 Summary:        Boost.Context - context switching library
272 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
273 Group:          Libraries
274
275 %description context
276 Boost.Context - context switching library, providing a sort of
277 cooperative multitasking on a single thread.
278
279 %description context -l pl.UTF-8
280 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
281 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
282
283 %package date_time
284 Summary:        Date-Time library
285 Summary(pl.UTF-8):      Biblioteka daty-czasu
286 Group:          Libraries
287 Obsoletes:      boost < 1.33
288
289 %description date_time
290 A set of date-time libraries.
291
292 %description date_time -l pl.UTF-8
293 Zbiór bibliotek daty-czasu.
294
295 %package filesystem
296 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
297 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
298 Group:          Libraries
299 Requires:       %{name}-system = %{version}-%{release}
300 Obsoletes:      boost < 1.33
301
302 %description filesystem
303 The boost::filesystem library provides portable facilities to query
304 and manipulate paths, files, and directories.
305
306 %description filesystem -l pl.UTF-8
307 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
308 operacjach na ścieżkach, plikach i katalogach.
309
310 %package graph
311 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
312 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
313 Group:          Libraries
314
315 %description graph
316 The boost::graph library provides portable facilities to operate on
317 graph data structures using graph algorithms.
318
319 %description graph -l pl.UTF-8
320 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
321 strukturach danych typu graf za pomocą algorytmów związanych z
322 grafami.
323
324 %package locale
325 Summary:        Provide localization and Unicode handling tools for C++
326 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
327 Group:          Libraries
328
329 %description locale
330 Provide localization and Unicode handling tools for C++.
331
332 %description locale -l pl.UTF-8
333 Narzędzia do obsługi lokalizacji i Unikodu w C++.
334
335 %package log
336 Summary:        Provide logging tools for C++
337 Summary(pl.UTF-8):      Narzędzia do logowania w C++
338 Group:          Libraries
339
340 %description log
341 Provide logging tools for C++.
342
343 %description log -l pl.UTF-8
344 Narzędzia do logowania w C++.
345
346 %package program_options
347 Summary:        Access to program options, via conventional methods such as command line and config file
348 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
349 Group:          Libraries
350
351 %description program_options
352 The program_options library allows program developers to obtain
353 program options, that is (name, value) pairs from the user, via
354 conventional methods such as command line and config file.
355
356 %description program_options -l pl.UTF-8
357 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
358 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
359 jak linia poleceń, czy plik konfiguracyjny.
360
361 %package regex
362 Summary:        Boost C++ regular expressions library
363 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
364 Group:          Libraries
365
366 %description regex
367 Shared library for Boost C++ regular expressions.
368
369 %description regex -l pl.UTF-8
370 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
371
372 %package signals
373 Summary:        Signals & slots callback implementation
374 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
375 Group:          Libraries
376 Obsoletes:      boost < 1.33
377
378 %description signals
379 The boost::signals library is an implementation of a signals and slots
380 system.
381
382 %description signals -l pl.UTF-8
383 Biblioteka boost::signals jest implementacją systemu sygnałów i
384 slotów.
385
386 %package system
387 Summary:        Support for getting system specific error codes
388 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
389 Group:          Libraries
390
391 %description system
392 The Boost System library provides simple, light-weight error_code
393 objects that encapsulate system-specific error code values, yet also
394 provide access to more abstract and portable error conditions objects.
395
396 %description system -l pl.UTF-8
397 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
398 obudowujące wartości kodów błędów specyficznych dla systemu, dając
399 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
400 błędów.
401
402 %package test
403 Summary:        Support for program testing and execution monitoring
404 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
405 Group:          Libraries
406 Obsoletes:      boost < 1.33
407
408 %description test
409 Support for simple program testing, full unit testing, and for program
410 execution monitoring.
411
412 %description test -l pl.UTF-8
413 Wsparcie dla prostego testowania programu, pełnego testowania i
414 monitorowania wykonania programu.
415
416 %package thread
417 Summary:        Portable C++ threads library
418 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
419 Group:          Libraries
420 Obsoletes:      boost < 1.33
421
422 %description thread
423 Portable C++ threads library - shared library.
424
425 %description thread -l pl.UTF-8
426 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
427
428 %package timer
429 Summary:        Event timer, progress timer, and progress display classes
430 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
431 Group:          Libraries
432 Obsoletes:      boost < 1.33
433
434 %description timer
435 Event timer, progress timer, and progress display classes.
436
437 %description timer -l pl.UTF-8
438 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
439
440 %package wave
441 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
442 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
443 Group:          Development/Libraries
444
445 %description wave
446 Boost.Wave - a standard compliant C++ preprocessor library.
447
448 %description wave -l pl.UTF-8
449 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
450
451 %package doc
452 Summary:        Boost C++ Library documentation
453 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
454 Group:          Documentation
455 %if "%{_rpmversion}" >= "5"
456 BuildArch:      noarch
457 %endif
458
459 %description doc
460 Documentation for the Boost C++ Library.
461
462 %description doc -l pl.UTF-8
463 Dokumentacja dla biblioteki Boost C++.
464
465 %prep
466 %setup -q -n %{name}_%{fver}
467 %patch0 -p1
468 #patch1 -p0
469
470 %patch203 -p0
471 %patch211 -p1
472 %patch212 -p1
473 %patch218 -p1
474 %patch221 -p1
475 %patch222 -p1
476 %patch224 -p1
477
478 # - don't know how to pass it through (b)jam -s (no way?)
479 #   due to oversophisticated build flags system.
480 # - pass -fPIC due to <shared-linkable> removal.
481 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/src/tools/gcc.jam
482
483 # cleanup -g switch to avoid override debuginfocflags.
484 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/src/tools/gcc.jam
485 # link against shared expat library.
486 #%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
487
488 cat << EOF > tools/build/src/user-config.jam
489 using gcc : %{cxx_version} : %{__cxx} ;
490 EOF
491
492 # cleanup backups after patching
493 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
494
495 %build
496 EXPAT_INCLUDE=%{_includedir} \
497 EXPAT_LIBPATH=%{_libdir} \
498 ICU_PATH=%{_prefix} \
499 ./bootstrap.sh \
500         --prefix=%{_prefix} \
501         -without-libraries=python
502
503 ./b2 \
504 %ifarch x32
505         --without-context \
506         --without-coroutine \
507 %endif
508         -d2 --toolset=gcc \
509         variant=release \
510         debug-symbols=on \
511         inlining=on \
512         link=static,shared \
513         threading=multi
514
515 %if %{with python3}
516 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
517 ./b2 \
518         --with-python python=%{py3_ver}m \
519         -a -d2 --toolset=gcc \
520         variant=release \
521         debug-symbols=on \
522         inlining=on \
523         link=static,shared \
524         threading=multi
525 %endif
526
527 %if %{with python2}
528 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
529 ./b2 \
530         --with-python python=%{py_ver} \
531         -a -d2 --toolset=gcc \
532         variant=release \
533         debug-symbols=on \
534         inlining=on \
535         link=static,shared \
536         threading=multi
537 %endif
538
539 %install
540 rm -rf $RPM_BUILD_ROOT
541 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
542
543 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
544
545 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
546 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
547 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
548
549 # documentation
550 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
551
552 # as the documentation doesn't completely reside in a directory of its
553 # own, we need to find out ourselves... this looks for HTML files and
554 # then collects everything linked from those.  this is certainly quite
555 # unoptimized wrt mkdir calls, but does it really matter?
556 installdocs() {
557 for i in $(find -type f -name '*.htm*'); do
558         # bjam docu is included in the boost-jam RPM
559         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
560                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
561                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
562                         sub rewrite_link
563                         {
564                                 my $link = shift;
565                                 # rewrite links from boost/* to %{_includedir}/boost/* and
566                                 # ignore external links as well as document-internal ones.
567                                 # HTML files are also ignored as they get installed anyway.
568                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
569                                 {
570                                         (my $file = $link) =~ s/\#.*//;
571                                         print "$file\n";
572                                 }
573                                 $link;
574                         }
575                         open IN, @ARGV[0];
576                         open OUT, ">@ARGV[1]";
577                         my $in_link;
578                         while (<IN>)
579                         {
580                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
581                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
582                                 print OUT;
583                                 $in_link = /href|src=\s*$/;
584                         }
585 EOT`; do
586                         TARGET=${i%/*}/$LINKED
587                         # ignore non-existant linked files
588                         if test -f $TARGET; then
589                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
590                         fi
591                 done
592         fi
593 done
594 }; installdocs
595
596 %clean
597 rm -rf $RPM_BUILD_ROOT
598
599 %post   -p /sbin/ldconfig
600 %postun -p /sbin/ldconfig
601
602 %post   chrono -p /sbin/ldconfig
603 %postun chrono -p /sbin/ldconfig
604
605 %post   context -p /sbin/ldconfig
606 %postun context -p /sbin/ldconfig
607
608 %post   date_time -p /sbin/ldconfig
609 %postun date_time -p /sbin/ldconfig
610
611 %post   filesystem -p /sbin/ldconfig
612 %postun filesystem -p /sbin/ldconfig
613
614 %post   graph -p /sbin/ldconfig
615 %postun graph -p /sbin/ldconfig
616
617 %post   locale -p /sbin/ldconfig
618 %postun locale -p /sbin/ldconfig
619
620 %post   python -p /sbin/ldconfig
621 %postun python -p /sbin/ldconfig
622
623 %post   python3 -p /sbin/ldconfig
624 %postun python3 -p /sbin/ldconfig
625
626 %post   program_options -p /sbin/ldconfig
627 %postun program_options -p /sbin/ldconfig
628
629 %post   regex -p /sbin/ldconfig
630 %postun regex -p /sbin/ldconfig
631
632 %post   signals -p /sbin/ldconfig
633 %postun signals -p /sbin/ldconfig
634
635 %post   system -p /sbin/ldconfig
636 %postun system -p /sbin/ldconfig
637
638 %post   test -p /sbin/ldconfig
639 %postun test -p /sbin/ldconfig
640
641 %post   thread -p /sbin/ldconfig
642 %postun thread -p /sbin/ldconfig
643
644 %post   timer -p /sbin/ldconfig
645 %postun timer -p /sbin/ldconfig
646
647 %post   wave -p /sbin/ldconfig
648 %postun wave -p /sbin/ldconfig
649
650 %files
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
653 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
654 %ifnarch x32
655 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
656 %endif
657 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
658 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
659 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
660 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
661 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
662
663 %files devel
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/libboost_atomic.so
666 %attr(755,root,root) %{_libdir}/libboost_chrono.so
667 %attr(755,root,root) %{_libdir}/libboost_container.so
668 %ifnarch x32
669 %attr(755,root,root) %{_libdir}/libboost_context.so
670 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
671 %endif
672 %attr(755,root,root) %{_libdir}/libboost_date_time.so
673 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
674 %attr(755,root,root) %{_libdir}/libboost_graph.so
675 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
676 %attr(755,root,root) %{_libdir}/libboost_locale.so
677 %attr(755,root,root) %{_libdir}/libboost_log.so
678 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
679 %attr(755,root,root) %{_libdir}/libboost_math_*.so
680 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
681 %attr(755,root,root) %{_libdir}/libboost_program_options.so
682 %attr(755,root,root) %{_libdir}/libboost_regex.so
683 %attr(755,root,root) %{_libdir}/libboost_random.so
684 %attr(755,root,root) %{_libdir}/libboost_serialization.so
685 %attr(755,root,root) %{_libdir}/libboost_signals.so
686 %attr(755,root,root) %{_libdir}/libboost_system.so
687 %attr(755,root,root) %{_libdir}/libboost_thread.so
688 %attr(755,root,root) %{_libdir}/libboost_timer.so
689 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
690 %attr(755,root,root) %{_libdir}/libboost_wave.so
691 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
692 %{_includedir}/boost
693 %exclude %{_includedir}/boost/python
694 %exclude %{_includedir}/boost/python.hpp
695
696 %files static
697 %defattr(644,root,root,755)
698 %{_libdir}/libboost_atomic.a
699 %{_libdir}/libboost_chrono.a
700 %{_libdir}/libboost_container.a
701 %ifnarch x32
702 %{_libdir}/libboost_context.a
703 %{_libdir}/libboost_coroutine.a
704 %endif
705 %{_libdir}/libboost_date_time.a
706 %{_libdir}/libboost_exception.a
707 %{_libdir}/libboost_filesystem.a
708 %{_libdir}/libboost_graph.a
709 %{_libdir}/libboost_iostreams.a
710 %{_libdir}/libboost_locale.a
711 %{_libdir}/libboost_log.a
712 %{_libdir}/libboost_log_setup.a
713 %{_libdir}/libboost_math_*.a
714 %{_libdir}/libboost_prg_exec_monitor.a
715 %{_libdir}/libboost_program_options.a
716 %{_libdir}/libboost_random.a
717 %{_libdir}/libboost_regex.a
718 %{_libdir}/libboost_serialization.a
719 %{_libdir}/libboost_signals.a
720 %{_libdir}/libboost_system.a
721 %{_libdir}/libboost_test_exec_monitor.a
722 %{_libdir}/libboost_timer.a
723 %{_libdir}/libboost_thread.a
724 %{_libdir}/libboost_unit_test_framework.a
725 %{_libdir}/libboost_wave.a
726 %{_libdir}/libboost_wserialization.a
727
728 %if %{with python2} || %{with python3}
729 %files python-devel-common
730 %defattr(644,root,root,755)
731 %{_includedir}/boost/python
732 %{_includedir}/boost/python.hpp
733 %endif
734
735 %if %{with python2}
736 %files python
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
739
740 %files python-devel
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/libboost_python.so
743
744 %files python-static
745 %defattr(644,root,root,755)
746 %{_libdir}/libboost_python.a
747 %endif
748
749 %if %{with python3}
750 %files python3
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
753
754 %files python3-devel
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libboost_python3.so
757
758 %files python3-static
759 %defattr(644,root,root,755)
760 %{_libdir}/libboost_python3.a
761 %endif
762
763 %files chrono
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
766
767 %ifnarch x32
768 %files context
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
771 %endif
772
773 %files date_time
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
776
777 %files filesystem
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
780
781 %files graph
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
784
785 %files locale
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
788
789 %files log
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
792 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
793
794 %files program_options
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
797
798 %files regex
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
801
802 %files signals
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
805
806 %files system
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
809
810 %files test
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
813 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
814
815 %files thread
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
818
819 %files timer
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
822
823 %files wave
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
826
827 %files doc
828 %defattr(644,root,root,755)
829 %{_docdir}/%{name}-%{version}
This page took 0.139618 seconds and 4 git commands to generate.