]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- release 5 (by relup.sh)
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.59.0
15 Release:        5
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  6aa9a5c6a4ca1016edd0ed1178e3cb87
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 Patch2:         %{name}-clean-gcc-flags.patch
23 # https://svn.boost.org/trac/boost/ticket/11549
24 Patch3:         Boost.Log-regression.patch
25 # FC Patches:
26 # https://svn.boost.org/trac/boost/ticket/5637
27 Patch203:       %{name}-1.54.0-mpl-print.patch
28 # https://svn.boost.org/trac/boost/ticket/8870
29 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
30 # https://svn.boost.org/trac/boost/ticket/8878
31 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
32 # https://svn.boost.org/trac/boost/ticket/8881
33 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
34 URL:            http://www.boost.org/
35 BuildRequires:  bzip2-devel
36 BuildRequires:  expat-devel
37 BuildRequires:  libicu-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  perl-base
40 %{?with_python:BuildRequires:   python-devel >= 2.2}
41 %{?with_python3:BuildRequires:  python3-devel}
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  zlib-devel
44 BuildConflicts: gcc = 5:3.3.1
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
48
49 %description
50 The Boost web site provides free peer-reviewed portable C++ source
51 libraries. The emphasis is on libraries which work well with the C++
52 Standard Library. One goal is to establish "existing practice" and
53 provide reference implementations so that the Boost libraries are
54 suitable for eventual standardization. Some of the libraries have
55 already been proposed for inclusion in the C++ Standards Committee's
56 upcoming C++ Standard Library Technical Report.
57
58 %description -l pl.UTF-8
59 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
60 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
61 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
62 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
63 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
64 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
65 Raporcie Technicznym Biblioteki Standardowej C++.
66
67 %package devel
68 Summary:        Boost C++ development headers
69 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       %{name}-chrono = %{version}-%{release}
73 Requires:       %{name}-context = %{version}-%{release}
74 Requires:       %{name}-date_time = %{version}-%{release}
75 Requires:       %{name}-filesystem = %{version}-%{release}
76 Requires:       %{name}-graph = %{version}-%{release}
77 Requires:       %{name}-locale = %{version}-%{release}
78 Requires:       %{name}-log = %{version}-%{release}
79 Requires:       %{name}-program_options = %{version}-%{release}
80 Requires:       %{name}-regex = %{version}-%{release}
81 Requires:       %{name}-signals = %{version}-%{release}
82 Requires:       %{name}-system = %{version}-%{release}
83 Requires:       %{name}-test = %{version}-%{release}
84 Requires:       %{name}-thread = %{version}-%{release}
85 Requires:       %{name}-timer = %{version}-%{release}
86 Requires:       %{name}-wave = %{version}-%{release}
87 Requires:       libstdc++-devel
88 Obsoletes:      boost-any-devel
89 Obsoletes:      boost-array-devel
90 Obsoletes:      boost-asio
91 Obsoletes:      boost-bind-devel
92 Obsoletes:      boost-call_traits-devel
93 Obsoletes:      boost-compatibility-devel
94 Obsoletes:      boost-compose-devel
95 Obsoletes:      boost-compressed_pair-devel
96 Obsoletes:      boost-concept_check-devel
97 Obsoletes:      boost-conversion-devel
98 Obsoletes:      boost-crc-devel
99 Obsoletes:      boost-date_time-devel
100 Obsoletes:      boost-filesystem-devel
101 Obsoletes:      boost-graph-devel
102 Obsoletes:      boost-mem_fn-devel
103 Obsoletes:      boost-mpl-devel
104 Obsoletes:      boost-preprocessor-devel
105 Obsoletes:      boost-program_options-devel
106 Obsoletes:      boost-ref-devel
107 Obsoletes:      boost-regex-devel
108 Obsoletes:      boost-signals-devel
109 Obsoletes:      boost-spirit-devel
110 Obsoletes:      boost-statechart-devel
111 Obsoletes:      boost-static_assert-devel
112 Obsoletes:      boost-test-devel
113 Obsoletes:      boost-thread-devel
114 Obsoletes:      boost-tr1-devel
115 Obsoletes:      boost-type_traits-devel
116 Obsoletes:      boost-typeof-devel
117 Obsoletes:      boost-uBLAS-devel
118 Obsoletes:      boost-utility-devel
119 Obsoletes:      boost-wave-devel
120 Obsoletes:      boost-xpressive-devel
121
122 %description devel
123 Header files for the Boost C++ libraries.
124
125 %description devel -l pl.UTF-8
126 Pliki nagłówkowe bibliotek C++ Boost.
127
128 %package static
129 Summary:        Static version of base Boost C++ libraries
130 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
131 Group:          Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133 Obsoletes:      boost-static < 1.33
134
135 %description static
136 Static version of base Boost C++ libraries.
137
138 %description static -l pl.UTF-8
139 Statyczne wersje podstawowych bibliotek C++ Boost.
140
141 %package python-devel-common
142 Summary:        Boost.Python development headers
143 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}-%{release}
146
147 %description python-devel-common
148 Headers for the Boost.Python library.
149
150 %description python-devel-common -l pl.UTF-8
151 Pliki nagłówkowe biblioteki Boost.Python.
152
153 %package python
154 Summary:        Boost.Python library for Python 2
155 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
156 Group:          Libraries
157 Requires:       python-libs
158
159 %description python
160 Use the Boost Python Library to quickly and easily export a C++
161 library to Python 2 such that the Python 2 interface is very similar
162 to the C++ interface. It is designed to be minimally intrusive on your
163 C++ design. In most cases, you should not have to alter your C++
164 classes in any way in order to use them with Boost.Python. The system
165 should simply ``reflect'' your C++ classes and functions into Python
166 3.
167
168 %description python -l pl.UTF-8
169 Biblioteka Boost Python służy do szybkiego i prostego eksportu
170 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
171 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
172 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
173 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
174 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
175 klasy C++ i funkcje do Pythona 3.
176
177 %package python-devel
178 Summary:        Boost.Python development files for Python 2
179 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182 Requires:       %{name}-python = %{version}-%{release}
183 Requires:       %{name}-python-devel-common = %{version}-%{release}
184
185 %description python-devel
186 Boost.Python development files for Python 2.
187
188 %description python-devel -l pl.UTF-8
189 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
190
191 %package python-static
192 Summary:        Static version of Boost.Python library for Python 2
193 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
194 Group:          Development/Libraries
195 Requires:       %{name}-python-devel = %{version}-%{release}
196
197 %description python-static
198 Static version of Boost.Python library for Python 2.
199
200 %description python-static -l pl.UTF-8
201 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
202
203 %package python3
204 Summary:        Boost.Python library for Python 3
205 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
206 Group:          Libraries
207 Requires:       python3-libs
208
209 %description python3
210 Use the Boost Python Library to quickly and easily export a C++
211 library to Python 3 such that the Python 3 interface is very similar
212 to the C++ interface. It is designed to be minimally intrusive on your
213 C++ design. In most cases, you should not have to alter your C++
214 classes in any way in order to use them with Boost.Python. The system
215 should simply ``reflect'' your C++ classes and functions into Python
216 3.
217
218 %description python3 -l pl.UTF-8
219 Biblioteka Boost Python służy do szybkiego i prostego eksportu
220 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
221 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
222 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
223 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
224 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
225 klasy C++ i funkcje do Pythona 3.
226
227 %package python3-devel
228 Summary:        Boost.Python development files for Python 3
229 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
230 Group:          Development/Libraries
231 Requires:       %{name}-devel = %{version}-%{release}
232 Requires:       %{name}-python3 = %{version}-%{release}
233 Requires:       %{name}-python-devel-common = %{version}-%{release}
234
235 %description python3-devel
236 Boost.Python development files for Python 3.
237
238 %description python3-devel -l pl.UTF-8
239 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
240
241 %package python3-static
242 Summary:        Static version of Boost.Python library for Python 3
243 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
244 Group:          Development/Libraries
245 Requires:       %{name}-python3-devel = %{version}-%{release}
246
247 %description python3-static
248 Static version of Boost.Python library for Python 3.
249
250 %description python3-static -l pl.UTF-8
251 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
252
253 %package chrono
254 Summary:        Useful time utilities
255 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
256 Group:          Libraries
257 Obsoletes:      boost < 1.33
258
259 %description chrono
260 Useful time utilities.
261
262 %description chrono -l pl.UTF-8
263 Przydatne funkcje związane z czasem.
264
265 %package context
266 Summary:        Boost.Context - context switching library
267 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
268 Group:          Libraries
269
270 %description context
271 Boost.Context - context switching library, providing a sort of
272 cooperative multitasking on a single thread.
273
274 %description context -l pl.UTF-8
275 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
276 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
277
278 %package date_time
279 Summary:        Date-Time library
280 Summary(pl.UTF-8):      Biblioteka daty-czasu
281 Group:          Libraries
282 Obsoletes:      boost < 1.33
283
284 %description date_time
285 A set of date-time libraries.
286
287 %description date_time -l pl.UTF-8
288 Zbiór bibliotek daty-czasu.
289
290 %package filesystem
291 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
292 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
293 Group:          Libraries
294 Requires:       %{name}-system = %{version}-%{release}
295 Obsoletes:      boost < 1.33
296
297 %description filesystem
298 The boost::filesystem library provides portable facilities to query
299 and manipulate paths, files, and directories.
300
301 %description filesystem -l pl.UTF-8
302 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
303 operacjach na ścieżkach, plikach i katalogach.
304
305 %package graph
306 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
307 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
308 Group:          Libraries
309
310 %description graph
311 The boost::graph library provides portable facilities to operate on
312 graph data structures using graph algorithms.
313
314 %description graph -l pl.UTF-8
315 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
316 strukturach danych typu graf za pomocą algorytmów związanych z
317 grafami.
318
319 %package locale
320 Summary:        Provide localization and Unicode handling tools for C++
321 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
322 Group:          Libraries
323
324 %description locale
325 Provide localization and Unicode handling tools for C++.
326
327 %description locale -l pl.UTF-8
328 Narzędzia do obsługi lokalizacji i Unikodu w C++.
329
330 %package log
331 Summary:        Provide logging tools for C++
332 Summary(pl.UTF-8):      Narzędzia do logowania w C++
333 Group:          Libraries
334
335 %description log
336 Provide logging tools for C++.
337
338 %description log -l pl.UTF-8
339 Narzędzia do logowania w C++.
340
341 %package program_options
342 Summary:        Access to program options, via conventional methods such as command line and config file
343 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
344 Group:          Libraries
345
346 %description program_options
347 The program_options library allows program developers to obtain
348 program options, that is (name, value) pairs from the user, via
349 conventional methods such as command line and config file.
350
351 %description program_options -l pl.UTF-8
352 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
353 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
354 jak linia poleceń, czy plik konfiguracyjny.
355
356 %package regex
357 Summary:        Boost C++ regular expressions library
358 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
359 Group:          Libraries
360
361 %description regex
362 Shared library for Boost C++ regular expressions.
363
364 %description regex -l pl.UTF-8
365 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
366
367 %package signals
368 Summary:        Signals & slots callback implementation
369 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
370 Group:          Libraries
371 Obsoletes:      boost < 1.33
372
373 %description signals
374 The boost::signals library is an implementation of a signals and slots
375 system.
376
377 %description signals -l pl.UTF-8
378 Biblioteka boost::signals jest implementacją systemu sygnałów i
379 slotów.
380
381 %package system
382 Summary:        Support for getting system specific error codes
383 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
384 Group:          Libraries
385
386 %description system
387 The Boost System library provides simple, light-weight error_code
388 objects that encapsulate system-specific error code values, yet also
389 provide access to more abstract and portable error conditions objects.
390
391 %description system -l pl.UTF-8
392 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
393 obudowujące wartości kodów błędów specyficznych dla systemu, dając
394 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
395 błędów.
396
397 %package test
398 Summary:        Support for program testing and execution monitoring
399 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
400 Group:          Libraries
401 Obsoletes:      boost < 1.33
402
403 %description test
404 Support for simple program testing, full unit testing, and for program
405 execution monitoring.
406
407 %description test -l pl.UTF-8
408 Wsparcie dla prostego testowania programu, pełnego testowania i
409 monitorowania wykonania programu.
410
411 %package thread
412 Summary:        Portable C++ threads library
413 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
414 Group:          Libraries
415 Obsoletes:      boost < 1.33
416
417 %description thread
418 Portable C++ threads library - shared library.
419
420 %description thread -l pl.UTF-8
421 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
422
423 %package timer
424 Summary:        Event timer, progress timer, and progress display classes
425 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
426 Group:          Libraries
427 Obsoletes:      boost < 1.33
428
429 %description timer
430 Event timer, progress timer, and progress display classes.
431
432 %description timer -l pl.UTF-8
433 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
434
435 %package wave
436 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
437 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
438 Group:          Development/Libraries
439
440 %description wave
441 Boost.Wave - a standard compliant C++ preprocessor library.
442
443 %description wave -l pl.UTF-8
444 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
445
446 %package doc
447 Summary:        Boost C++ Library documentation
448 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
449 Group:          Documentation
450 %if "%{_rpmversion}" >= "5"
451 BuildArch:      noarch
452 %endif
453
454 %description doc
455 Documentation for the Boost C++ Library.
456
457 %description doc -l pl.UTF-8
458 Dokumentacja dla biblioteki Boost C++.
459
460 %prep
461 %setup -q -n %{name}_%{fver}
462 %patch0 -p1
463 %patch1 -p1
464 %patch2 -p1
465 %patch3 -p1
466
467 %patch203 -p0
468 %patch212 -p1
469 %patch218 -p1
470 %patch221 -p1
471
472 cat << EOF > tools/build/src/user-config.jam
473 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
474 EOF
475
476 # cleanup backups after patching
477 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
478
479 %build
480 EXPAT_INCLUDE=%{_includedir} \
481 EXPAT_LIBPATH=%{_libdir} \
482 ICU_PATH=%{_prefix} \
483 ./bootstrap.sh \
484         --prefix=%{_prefix} \
485         -without-libraries=python
486
487 ./b2 \
488         -d2 --toolset=gcc \
489         variant=release \
490         debug-symbols=on \
491         inlining=on \
492         link=static,shared \
493         threading=multi
494
495 %if %{with python3}
496 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
497 ./b2 \
498         --with-python python=%{py3_ver}m \
499         -a -d2 --toolset=gcc \
500         variant=release \
501         debug-symbols=on \
502         inlining=on \
503         link=static,shared \
504         threading=multi
505 %endif
506
507 %if %{with python2}
508 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
509 ./b2 \
510         --with-python python=%{py_ver} \
511         -a -d2 --toolset=gcc \
512         variant=release \
513         debug-symbols=on \
514         inlining=on \
515         link=static,shared \
516         threading=multi
517 %endif
518
519 %install
520 rm -rf $RPM_BUILD_ROOT
521 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
522
523 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
524
525 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
526 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
527 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
528
529 # documentation
530 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
531
532 # as the documentation doesn't completely reside in a directory of its
533 # own, we need to find out ourselves... this looks for HTML files and
534 # then collects everything linked from those.  this is certainly quite
535 # unoptimized wrt mkdir calls, but does it really matter?
536 installdocs() {
537 for i in $(find -type f -name '*.htm*'); do
538         # bjam docu is included in the boost-jam RPM
539         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
540                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
541                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
542                         sub rewrite_link
543                         {
544                                 my $link = shift;
545                                 # rewrite links from boost/* to %{_includedir}/boost/* and
546                                 # ignore external links as well as document-internal ones.
547                                 # HTML files are also ignored as they get installed anyway.
548                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
549                                 {
550                                         (my $file = $link) =~ s/\#.*//;
551                                         print "$file\n";
552                                 }
553                                 $link;
554                         }
555                         open IN, @ARGV[0];
556                         open OUT, ">@ARGV[1]";
557                         my $in_link;
558                         while (<IN>)
559                         {
560                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
561                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
562                                 print OUT;
563                                 $in_link = /href|src=\s*$/;
564                         }
565 EOT`; do
566                         TARGET=${i%/*}/$LINKED
567                         # ignore non-existant linked files
568                         if test -f $TARGET; then
569                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
570                         fi
571                 done
572         fi
573 done
574 }; installdocs
575
576 %clean
577 rm -rf $RPM_BUILD_ROOT
578
579 %post   -p /sbin/ldconfig
580 %postun -p /sbin/ldconfig
581
582 %post   chrono -p /sbin/ldconfig
583 %postun chrono -p /sbin/ldconfig
584
585 %post   context -p /sbin/ldconfig
586 %postun context -p /sbin/ldconfig
587
588 %post   date_time -p /sbin/ldconfig
589 %postun date_time -p /sbin/ldconfig
590
591 %post   filesystem -p /sbin/ldconfig
592 %postun filesystem -p /sbin/ldconfig
593
594 %post   graph -p /sbin/ldconfig
595 %postun graph -p /sbin/ldconfig
596
597 %post   locale -p /sbin/ldconfig
598 %postun locale -p /sbin/ldconfig
599
600 %post   python -p /sbin/ldconfig
601 %postun python -p /sbin/ldconfig
602
603 %post   python3 -p /sbin/ldconfig
604 %postun python3 -p /sbin/ldconfig
605
606 %post   program_options -p /sbin/ldconfig
607 %postun program_options -p /sbin/ldconfig
608
609 %post   regex -p /sbin/ldconfig
610 %postun regex -p /sbin/ldconfig
611
612 %post   signals -p /sbin/ldconfig
613 %postun signals -p /sbin/ldconfig
614
615 %post   system -p /sbin/ldconfig
616 %postun system -p /sbin/ldconfig
617
618 %post   test -p /sbin/ldconfig
619 %postun test -p /sbin/ldconfig
620
621 %post   thread -p /sbin/ldconfig
622 %postun thread -p /sbin/ldconfig
623
624 %post   timer -p /sbin/ldconfig
625 %postun timer -p /sbin/ldconfig
626
627 %post   wave -p /sbin/ldconfig
628 %postun wave -p /sbin/ldconfig
629
630 %files
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
633 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
634 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
635 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
636 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
637 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
638 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
639 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
640
641 %files devel
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libboost_atomic.so
644 %attr(755,root,root) %{_libdir}/libboost_chrono.so
645 %attr(755,root,root) %{_libdir}/libboost_container.so
646 %attr(755,root,root) %{_libdir}/libboost_context.so
647 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
648 %attr(755,root,root) %{_libdir}/libboost_date_time.so
649 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
650 %attr(755,root,root) %{_libdir}/libboost_graph.so
651 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
652 %attr(755,root,root) %{_libdir}/libboost_locale.so
653 %attr(755,root,root) %{_libdir}/libboost_log.so
654 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
655 %attr(755,root,root) %{_libdir}/libboost_math_*.so
656 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
657 %attr(755,root,root) %{_libdir}/libboost_program_options.so
658 %attr(755,root,root) %{_libdir}/libboost_regex.so
659 %attr(755,root,root) %{_libdir}/libboost_random.so
660 %attr(755,root,root) %{_libdir}/libboost_serialization.so
661 %attr(755,root,root) %{_libdir}/libboost_signals.so
662 %attr(755,root,root) %{_libdir}/libboost_system.so
663 %attr(755,root,root) %{_libdir}/libboost_thread.so
664 %attr(755,root,root) %{_libdir}/libboost_timer.so
665 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
666 %attr(755,root,root) %{_libdir}/libboost_wave.so
667 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
668 %{_includedir}/boost
669 %exclude %{_includedir}/boost/python
670 %exclude %{_includedir}/boost/python.hpp
671
672 %files static
673 %defattr(644,root,root,755)
674 %{_libdir}/libboost_atomic.a
675 %{_libdir}/libboost_chrono.a
676 %{_libdir}/libboost_container.a
677 %{_libdir}/libboost_context.a
678 %{_libdir}/libboost_coroutine.a
679 %{_libdir}/libboost_date_time.a
680 %{_libdir}/libboost_exception.a
681 %{_libdir}/libboost_filesystem.a
682 %{_libdir}/libboost_graph.a
683 %{_libdir}/libboost_iostreams.a
684 %{_libdir}/libboost_locale.a
685 %{_libdir}/libboost_log.a
686 %{_libdir}/libboost_log_setup.a
687 %{_libdir}/libboost_math_*.a
688 %{_libdir}/libboost_prg_exec_monitor.a
689 %{_libdir}/libboost_program_options.a
690 %{_libdir}/libboost_random.a
691 %{_libdir}/libboost_regex.a
692 %{_libdir}/libboost_serialization.a
693 %{_libdir}/libboost_signals.a
694 %{_libdir}/libboost_system.a
695 %{_libdir}/libboost_test_exec_monitor.a
696 %{_libdir}/libboost_timer.a
697 %{_libdir}/libboost_thread.a
698 %{_libdir}/libboost_unit_test_framework.a
699 %{_libdir}/libboost_wave.a
700 %{_libdir}/libboost_wserialization.a
701
702 %if %{with python2} || %{with python3}
703 %files python-devel-common
704 %defattr(644,root,root,755)
705 %{_includedir}/boost/python
706 %{_includedir}/boost/python.hpp
707 %endif
708
709 %if %{with python2}
710 %files python
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
713
714 %files python-devel
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libboost_python.so
717
718 %files python-static
719 %defattr(644,root,root,755)
720 %{_libdir}/libboost_python.a
721 %endif
722
723 %if %{with python3}
724 %files python3
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
727
728 %files python3-devel
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/libboost_python3.so
731
732 %files python3-static
733 %defattr(644,root,root,755)
734 %{_libdir}/libboost_python3.a
735 %endif
736
737 %files chrono
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
740
741 %files context
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
744
745 %files date_time
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
748
749 %files filesystem
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
752
753 %files graph
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
756
757 %files locale
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
760
761 %files log
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
764 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
765
766 %files program_options
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
769
770 %files regex
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
773
774 %files signals
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
777
778 %files system
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
781
782 %files test
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
785 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
786
787 %files thread
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
790
791 %files timer
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
794
795 %files wave
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
798
799 %files doc
800 %defattr(644,root,root,755)
801 %{_docdir}/%{name}-%{version}
This page took 0.087226 seconds and 4 git commands to generate.