]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- disable .so symbol check for libboost_context
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.61.0
15 Release:        5
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  6095876341956f65f9d35939ccea1a9f
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 Patch2:         %{name}-clean-gcc-flags.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8881
27 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
28 URL:            http://www.boost.org/
29 BuildRequires:  bzip2-devel
30 BuildRequires:  expat-devel
31 BuildRequires:  libicu-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  perl-base
34 %{?with_python:BuildRequires:   python-devel >= 2.2}
35 %{?with_python3:BuildRequires:  python3-devel}
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  zlib-devel
38 BuildConflicts: gcc = 5:3.3.1
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
42
43 # __once_call, __once_callable non-function symbols from libstdc++
44 %define         skip_post_check_so      libboost_context.so.*
45
46 %description
47 The Boost web site provides free peer-reviewed portable C++ source
48 libraries. The emphasis is on libraries which work well with the C++
49 Standard Library. One goal is to establish "existing practice" and
50 provide reference implementations so that the Boost libraries are
51 suitable for eventual standardization. Some of the libraries have
52 already been proposed for inclusion in the C++ Standards Committee's
53 upcoming C++ Standard Library Technical Report.
54
55 %description -l pl.UTF-8
56 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
57 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
58 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
59 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
60 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
61 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
62 Raporcie Technicznym Biblioteki Standardowej C++.
63
64 %package devel
65 Summary:        Boost C++ development headers
66 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       %{name}-chrono = %{version}-%{release}
70 Requires:       %{name}-context = %{version}-%{release}
71 Requires:       %{name}-date_time = %{version}-%{release}
72 Requires:       %{name}-filesystem = %{version}-%{release}
73 Requires:       %{name}-graph = %{version}-%{release}
74 Requires:       %{name}-locale = %{version}-%{release}
75 Requires:       %{name}-log = %{version}-%{release}
76 Requires:       %{name}-program_options = %{version}-%{release}
77 Requires:       %{name}-regex = %{version}-%{release}
78 Requires:       %{name}-signals = %{version}-%{release}
79 Requires:       %{name}-system = %{version}-%{release}
80 Requires:       %{name}-test = %{version}-%{release}
81 Requires:       %{name}-thread = %{version}-%{release}
82 Requires:       %{name}-timer = %{version}-%{release}
83 Requires:       %{name}-wave = %{version}-%{release}
84 Requires:       libstdc++-devel
85 Obsoletes:      boost-any-devel
86 Obsoletes:      boost-array-devel
87 Obsoletes:      boost-asio
88 Obsoletes:      boost-bind-devel
89 Obsoletes:      boost-call_traits-devel
90 Obsoletes:      boost-compatibility-devel
91 Obsoletes:      boost-compose-devel
92 Obsoletes:      boost-compressed_pair-devel
93 Obsoletes:      boost-concept_check-devel
94 Obsoletes:      boost-conversion-devel
95 Obsoletes:      boost-crc-devel
96 Obsoletes:      boost-date_time-devel
97 Obsoletes:      boost-filesystem-devel
98 Obsoletes:      boost-graph-devel
99 Obsoletes:      boost-mem_fn-devel
100 Obsoletes:      boost-mpl-devel
101 Obsoletes:      boost-preprocessor-devel
102 Obsoletes:      boost-program_options-devel
103 Obsoletes:      boost-ref-devel
104 Obsoletes:      boost-regex-devel
105 Obsoletes:      boost-signals-devel
106 Obsoletes:      boost-spirit-devel
107 Obsoletes:      boost-statechart-devel
108 Obsoletes:      boost-static_assert-devel
109 Obsoletes:      boost-test-devel
110 Obsoletes:      boost-thread-devel
111 Obsoletes:      boost-tr1-devel
112 Obsoletes:      boost-type_traits-devel
113 Obsoletes:      boost-typeof-devel
114 Obsoletes:      boost-uBLAS-devel
115 Obsoletes:      boost-utility-devel
116 Obsoletes:      boost-wave-devel
117 Obsoletes:      boost-xpressive-devel
118
119 %description devel
120 Header files for the Boost C++ libraries.
121
122 %description devel -l pl.UTF-8
123 Pliki nagłówkowe bibliotek C++ Boost.
124
125 %package static
126 Summary:        Static version of base Boost C++ libraries
127 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130 Obsoletes:      boost-static < 1.33
131
132 %description static
133 Static version of base Boost C++ libraries.
134
135 %description static -l pl.UTF-8
136 Statyczne wersje podstawowych bibliotek C++ Boost.
137
138 %package python-devel-common
139 Summary:        Boost.Python development headers
140 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description python-devel-common
145 Headers for the Boost.Python library.
146
147 %description python-devel-common -l pl.UTF-8
148 Pliki nagłówkowe biblioteki Boost.Python.
149
150 %package python
151 Summary:        Boost.Python library for Python 2
152 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
153 Group:          Libraries
154 Requires:       python-libs
155
156 %description python
157 Use the Boost Python Library to quickly and easily export a C++
158 library to Python 2 such that the Python 2 interface is very similar
159 to the C++ interface. It is designed to be minimally intrusive on your
160 C++ design. In most cases, you should not have to alter your C++
161 classes in any way in order to use them with Boost.Python. The system
162 should simply ``reflect'' your C++ classes and functions into Python
163 3.
164
165 %description python -l pl.UTF-8
166 Biblioteka Boost Python służy do szybkiego i prostego eksportu
167 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
168 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
169 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
170 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
171 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
172 klasy C++ i funkcje do Pythona 3.
173
174 %package python-devel
175 Summary:        Boost.Python development files for Python 2
176 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
177 Group:          Development/Libraries
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       %{name}-python = %{version}-%{release}
180 Requires:       %{name}-python-devel-common = %{version}-%{release}
181
182 %description python-devel
183 Boost.Python development files for Python 2.
184
185 %description python-devel -l pl.UTF-8
186 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
187
188 %package python-static
189 Summary:        Static version of Boost.Python library for Python 2
190 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
191 Group:          Development/Libraries
192 Requires:       %{name}-python-devel = %{version}-%{release}
193
194 %description python-static
195 Static version of Boost.Python library for Python 2.
196
197 %description python-static -l pl.UTF-8
198 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
199
200 %package python3
201 Summary:        Boost.Python library for Python 3
202 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
203 Group:          Libraries
204 Requires:       python3-libs
205
206 %description python3
207 Use the Boost Python Library to quickly and easily export a C++
208 library to Python 3 such that the Python 3 interface is very similar
209 to the C++ interface. It is designed to be minimally intrusive on your
210 C++ design. In most cases, you should not have to alter your C++
211 classes in any way in order to use them with Boost.Python. The system
212 should simply ``reflect'' your C++ classes and functions into Python
213 3.
214
215 %description python3 -l pl.UTF-8
216 Biblioteka Boost Python służy do szybkiego i prostego eksportu
217 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
218 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
219 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
220 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
221 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
222 klasy C++ i funkcje do Pythona 3.
223
224 %package python3-devel
225 Summary:        Boost.Python development files for Python 3
226 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
227 Group:          Development/Libraries
228 Requires:       %{name}-devel = %{version}-%{release}
229 Requires:       %{name}-python-devel-common = %{version}-%{release}
230 Requires:       %{name}-python3 = %{version}-%{release}
231
232 %description python3-devel
233 Boost.Python development files for Python 3.
234
235 %description python3-devel -l pl.UTF-8
236 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
237
238 %package python3-static
239 Summary:        Static version of Boost.Python library for Python 3
240 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
241 Group:          Development/Libraries
242 Requires:       %{name}-python3-devel = %{version}-%{release}
243
244 %description python3-static
245 Static version of Boost.Python library for Python 3.
246
247 %description python3-static -l pl.UTF-8
248 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
249
250 %package chrono
251 Summary:        Useful time utilities
252 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
253 Group:          Libraries
254 Obsoletes:      boost < 1.33
255
256 %description chrono
257 Useful time utilities.
258
259 %description chrono -l pl.UTF-8
260 Przydatne funkcje związane z czasem.
261
262 %package context
263 Summary:        Boost.Context - context switching library
264 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
265 Group:          Libraries
266
267 %description context
268 Boost.Context - context switching library, providing a sort of
269 cooperative multitasking on a single thread.
270
271 %description context -l pl.UTF-8
272 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
273 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
274
275 %package date_time
276 Summary:        Date-Time library
277 Summary(pl.UTF-8):      Biblioteka daty-czasu
278 Group:          Libraries
279 Obsoletes:      boost < 1.33
280
281 %description date_time
282 A set of date-time libraries.
283
284 %description date_time -l pl.UTF-8
285 Zbiór bibliotek daty-czasu.
286
287 %package filesystem
288 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
289 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
290 Group:          Libraries
291 Requires:       %{name}-system = %{version}-%{release}
292 Obsoletes:      boost < 1.33
293
294 %description filesystem
295 The boost::filesystem library provides portable facilities to query
296 and manipulate paths, files, and directories.
297
298 %description filesystem -l pl.UTF-8
299 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
300 operacjach na ścieżkach, plikach i katalogach.
301
302 %package graph
303 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
304 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
305 Group:          Libraries
306
307 %description graph
308 The boost::graph library provides portable facilities to operate on
309 graph data structures using graph algorithms.
310
311 %description graph -l pl.UTF-8
312 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
313 strukturach danych typu graf za pomocą algorytmów związanych z
314 grafami.
315
316 %package locale
317 Summary:        Provide localization and Unicode handling tools for C++
318 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
319 Group:          Libraries
320
321 %description locale
322 Provide localization and Unicode handling tools for C++.
323
324 %description locale -l pl.UTF-8
325 Narzędzia do obsługi lokalizacji i Unikodu w C++.
326
327 %package log
328 Summary:        Provide logging tools for C++
329 Summary(pl.UTF-8):      Narzędzia do logowania w C++
330 Group:          Libraries
331
332 %description log
333 Provide logging tools for C++.
334
335 %description log -l pl.UTF-8
336 Narzędzia do logowania w C++.
337
338 %package program_options
339 Summary:        Access to program options, via conventional methods such as command line and config file
340 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
341 Group:          Libraries
342
343 %description program_options
344 The program_options library allows program developers to obtain
345 program options, that is (name, value) pairs from the user, via
346 conventional methods such as command line and config file.
347
348 %description program_options -l pl.UTF-8
349 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
350 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
351 jak linia poleceń, czy plik konfiguracyjny.
352
353 %package regex
354 Summary:        Boost C++ regular expressions library
355 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
356 Group:          Libraries
357
358 %description regex
359 Shared library for Boost C++ regular expressions.
360
361 %description regex -l pl.UTF-8
362 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
363
364 %package signals
365 Summary:        Signals & slots callback implementation
366 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
367 Group:          Libraries
368 Obsoletes:      boost < 1.33
369
370 %description signals
371 The boost::signals library is an implementation of a signals and slots
372 system.
373
374 %description signals -l pl.UTF-8
375 Biblioteka boost::signals jest implementacją systemu sygnałów i
376 slotów.
377
378 %package system
379 Summary:        Support for getting system specific error codes
380 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
381 Group:          Libraries
382
383 %description system
384 The Boost System library provides simple, light-weight error_code
385 objects that encapsulate system-specific error code values, yet also
386 provide access to more abstract and portable error conditions objects.
387
388 %description system -l pl.UTF-8
389 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
390 obudowujące wartości kodów błędów specyficznych dla systemu, dając
391 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
392 błędów.
393
394 %package test
395 Summary:        Support for program testing and execution monitoring
396 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
397 Group:          Libraries
398 Obsoletes:      boost < 1.33
399
400 %description test
401 Support for simple program testing, full unit testing, and for program
402 execution monitoring.
403
404 %description test -l pl.UTF-8
405 Wsparcie dla prostego testowania programu, pełnego testowania i
406 monitorowania wykonania programu.
407
408 %package thread
409 Summary:        Portable C++ threads library
410 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
411 Group:          Libraries
412 Obsoletes:      boost < 1.33
413
414 %description thread
415 Portable C++ threads library - shared library.
416
417 %description thread -l pl.UTF-8
418 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
419
420 %package timer
421 Summary:        Event timer, progress timer, and progress display classes
422 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
423 Group:          Libraries
424 Obsoletes:      boost < 1.33
425
426 %description timer
427 Event timer, progress timer, and progress display classes.
428
429 %description timer -l pl.UTF-8
430 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
431
432 %package wave
433 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
434 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
435 Group:          Development/Libraries
436
437 %description wave
438 Boost.Wave - a standard compliant C++ preprocessor library.
439
440 %description wave -l pl.UTF-8
441 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
442
443 %package doc
444 Summary:        Boost C++ Library documentation
445 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
446 Group:          Documentation
447 %if "%{_rpmversion}" >= "5"
448 BuildArch:      noarch
449 %endif
450
451 %description doc
452 Documentation for the Boost C++ Library.
453
454 %description doc -l pl.UTF-8
455 Dokumentacja dla biblioteki Boost C++.
456
457 %prep
458 %setup -q -n %{name}_%{fver}
459 %patch0 -p1
460 %patch1 -p1
461 %patch2 -p1
462
463 %patch203 -p0
464 %patch221 -p1
465
466 cat << EOF > tools/build/src/user-config.jam
467 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
468 EOF
469
470 # cleanup backups after patching
471 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
472
473 %build
474 EXPAT_INCLUDE=%{_includedir} \
475 EXPAT_LIBPATH=%{_libdir} \
476 ICU_PATH=%{_prefix} \
477 ./bootstrap.sh \
478         --prefix=%{_prefix} \
479         -without-libraries=python
480
481 ./b2 \
482         -d2 --toolset=gcc \
483         variant=release \
484         debug-symbols=on \
485         inlining=on \
486         link=static,shared \
487         threading=multi
488
489 %if %{with python3}
490 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
491 ./b2 \
492         --with-python python=%{py3_ver}m \
493         -a -d2 --toolset=gcc \
494         variant=release \
495         debug-symbols=on \
496         inlining=on \
497         link=static,shared \
498         threading=multi
499 %endif
500
501 %if %{with python2}
502 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
503 ./b2 \
504         --with-python python=%{py_ver} \
505         -a -d2 --toolset=gcc \
506         variant=release \
507         debug-symbols=on \
508         inlining=on \
509         link=static,shared \
510         threading=multi
511 %endif
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
516
517 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
518
519 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
520 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
521 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
522
523 # documentation
524 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
525
526 # as the documentation doesn't completely reside in a directory of its
527 # own, we need to find out ourselves... this looks for HTML files and
528 # then collects everything linked from those.  this is certainly quite
529 # unoptimized wrt mkdir calls, but does it really matter?
530 installdocs() {
531 for i in $(find -type f -name '*.htm*'); do
532         # bjam docu is included in the boost-jam RPM
533         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
534                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
535                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
536                         sub rewrite_link
537                         {
538                                 my $link = shift;
539                                 # rewrite links from boost/* to %{_includedir}/boost/* and
540                                 # ignore external links as well as document-internal ones.
541                                 # HTML files are also ignored as they get installed anyway.
542                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
543                                 {
544                                         (my $file = $link) =~ s/\#.*//;
545                                         print "$file\n";
546                                 }
547                                 $link;
548                         }
549                         open IN, @ARGV[0];
550                         open OUT, ">@ARGV[1]";
551                         my $in_link;
552                         while (<IN>)
553                         {
554                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
555                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
556                                 print OUT;
557                                 $in_link = /href|src=\s*$/;
558                         }
559 EOT`; do
560                         TARGET=${i%/*}/$LINKED
561                         # ignore non-existant linked files
562                         if test -f $TARGET; then
563                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
564                         fi
565                 done
566         fi
567 done
568 }; installdocs
569
570 %clean
571 rm -rf $RPM_BUILD_ROOT
572
573 %post   -p /sbin/ldconfig
574 %postun -p /sbin/ldconfig
575
576 %post   chrono -p /sbin/ldconfig
577 %postun chrono -p /sbin/ldconfig
578
579 %post   context -p /sbin/ldconfig
580 %postun context -p /sbin/ldconfig
581
582 %post   date_time -p /sbin/ldconfig
583 %postun date_time -p /sbin/ldconfig
584
585 %post   filesystem -p /sbin/ldconfig
586 %postun filesystem -p /sbin/ldconfig
587
588 %post   graph -p /sbin/ldconfig
589 %postun graph -p /sbin/ldconfig
590
591 %post   locale -p /sbin/ldconfig
592 %postun locale -p /sbin/ldconfig
593
594 %post   python -p /sbin/ldconfig
595 %postun python -p /sbin/ldconfig
596
597 %post   python3 -p /sbin/ldconfig
598 %postun python3 -p /sbin/ldconfig
599
600 %post   program_options -p /sbin/ldconfig
601 %postun program_options -p /sbin/ldconfig
602
603 %post   regex -p /sbin/ldconfig
604 %postun regex -p /sbin/ldconfig
605
606 %post   signals -p /sbin/ldconfig
607 %postun signals -p /sbin/ldconfig
608
609 %post   system -p /sbin/ldconfig
610 %postun system -p /sbin/ldconfig
611
612 %post   test -p /sbin/ldconfig
613 %postun test -p /sbin/ldconfig
614
615 %post   thread -p /sbin/ldconfig
616 %postun thread -p /sbin/ldconfig
617
618 %post   timer -p /sbin/ldconfig
619 %postun timer -p /sbin/ldconfig
620
621 %post   wave -p /sbin/ldconfig
622 %postun wave -p /sbin/ldconfig
623
624 %files
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
627 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
628 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
629 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
630 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
631 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
632 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
633 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so.*.*.*
634 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
635
636 %files devel
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libboost_atomic.so
639 %attr(755,root,root) %{_libdir}/libboost_chrono.so
640 %attr(755,root,root) %{_libdir}/libboost_container.so
641 %attr(755,root,root) %{_libdir}/libboost_context.so
642 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
643 %attr(755,root,root) %{_libdir}/libboost_date_time.so
644 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
645 %attr(755,root,root) %{_libdir}/libboost_graph.so
646 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
647 %attr(755,root,root) %{_libdir}/libboost_locale.so
648 %attr(755,root,root) %{_libdir}/libboost_log.so
649 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
650 %attr(755,root,root) %{_libdir}/libboost_math_*.so
651 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
652 %attr(755,root,root) %{_libdir}/libboost_program_options.so
653 %attr(755,root,root) %{_libdir}/libboost_regex.so
654 %attr(755,root,root) %{_libdir}/libboost_random.so
655 %attr(755,root,root) %{_libdir}/libboost_serialization.so
656 %attr(755,root,root) %{_libdir}/libboost_signals.so
657 %attr(755,root,root) %{_libdir}/libboost_system.so
658 %attr(755,root,root) %{_libdir}/libboost_thread.so
659 %attr(755,root,root) %{_libdir}/libboost_timer.so
660 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
661 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
662 %attr(755,root,root) %{_libdir}/libboost_wave.so
663 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
664 %{_includedir}/boost
665 %exclude %{_includedir}/boost/python
666 %exclude %{_includedir}/boost/python.hpp
667
668 %files static
669 %defattr(644,root,root,755)
670 %{_libdir}/libboost_atomic.a
671 %{_libdir}/libboost_chrono.a
672 %{_libdir}/libboost_container.a
673 %{_libdir}/libboost_context.a
674 %{_libdir}/libboost_coroutine.a
675 %{_libdir}/libboost_date_time.a
676 %{_libdir}/libboost_exception.a
677 %{_libdir}/libboost_filesystem.a
678 %{_libdir}/libboost_graph.a
679 %{_libdir}/libboost_iostreams.a
680 %{_libdir}/libboost_locale.a
681 %{_libdir}/libboost_log.a
682 %{_libdir}/libboost_log_setup.a
683 %{_libdir}/libboost_math_*.a
684 %{_libdir}/libboost_prg_exec_monitor.a
685 %{_libdir}/libboost_program_options.a
686 %{_libdir}/libboost_random.a
687 %{_libdir}/libboost_regex.a
688 %{_libdir}/libboost_serialization.a
689 %{_libdir}/libboost_signals.a
690 %{_libdir}/libboost_system.a
691 %{_libdir}/libboost_test_exec_monitor.a
692 %{_libdir}/libboost_timer.a
693 %{_libdir}/libboost_thread.a
694 %{_libdir}/libboost_type_erasure.a
695 %{_libdir}/libboost_unit_test_framework.a
696 %{_libdir}/libboost_wave.a
697 %{_libdir}/libboost_wserialization.a
698
699 %if %{with python2} || %{with python3}
700 %files python-devel-common
701 %defattr(644,root,root,755)
702 %{_includedir}/boost/python
703 %{_includedir}/boost/python.hpp
704 %endif
705
706 %if %{with python2}
707 %files python
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
710
711 %files python-devel
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libboost_python.so
714
715 %files python-static
716 %defattr(644,root,root,755)
717 %{_libdir}/libboost_python.a
718 %endif
719
720 %if %{with python3}
721 %files python3
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
724
725 %files python3-devel
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libboost_python3.so
728
729 %files python3-static
730 %defattr(644,root,root,755)
731 %{_libdir}/libboost_python3.a
732 %endif
733
734 %files chrono
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
737
738 %files context
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
741
742 %files date_time
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
745
746 %files filesystem
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
749
750 %files graph
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
753
754 %files locale
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
757
758 %files log
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
761 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
762
763 %files program_options
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
766
767 %files regex
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
770
771 %files signals
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
774
775 %files system
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
778
779 %files test
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
782 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
783
784 %files thread
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
787
788 %files timer
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
791
792 %files wave
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
795
796 %files doc
797 %defattr(644,root,root,755)
798 %{_docdir}/%{name}-%{version}
This page took 0.123095 seconds and 4 git commands to generate.