]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- rel 3; bunch of upstream patches (taken and filtered by FC team)
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python  # without boost-python support
8 #
9 %define         fver    %(echo %{version} | tr . _)
10 Summary:        The Boost C++ Libraries
11 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
12 Name:           boost
13 Version:        1.54.0
14 Release:        3
15 License:        Boost Software License and others
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
18 # Source0-md5:  15cb8c0803064faef0c4ddf5bc5ca279
19 Patch0:         %{name}-link.patch
20 Patch1:         %{name}-stdint.patch
21
22 # Upstream patches posted as release notes:
23 # http://www.boost.org/users/history/version_1_54_0.html
24 Patch100: 001-coroutine.patch
25 Patch101: 002-date-time.patch
26 Patch102: 003-log.patch
27
28 # FC Patches:
29 # https://svn.boost.org/trac/boost/ticket/8826
30 Patch200: boost-1.54.0-context-execstack.patch
31 # https://svn.boost.org/trac/boost/ticket/8844
32 Patch201: boost-1.54.0-bind-static_assert.patch
33 # https://svn.boost.org/trac/boost/ticket/8847
34 Patch202: boost-1.54.0-concept-unused_typedef.patch
35 # https://svn.boost.org/trac/boost/ticket/5637
36 Patch203: boost-1.54.0-mpl-print.patch
37 # https://svn.boost.org/trac/boost/ticket/8859
38 Patch204: boost-1.54.0-static_warning-unused_typedef.patch
39 # https://svn.boost.org/trac/boost/ticket/8855
40 Patch205: boost-1.54.0-math-unused_typedef.patch
41 Patch206: boost-1.54.0-math-unused_typedef-2.patch
42 # https://svn.boost.org/trac/boost/ticket/8853
43 Patch207: boost-1.54.0-tuple-unused_typedef.patch
44 # https://svn.boost.org/trac/boost/ticket/8854
45 Patch208: boost-1.54.0-random-unused_typedef.patch
46 # https://svn.boost.org/trac/boost/ticket/8856
47 Patch209: boost-1.54.0-date_time-unused_typedef.patch
48 Patch210: boost-1.54.0-date_time-unused_typedef-2.patch
49 # https://svn.boost.org/trac/boost/ticket/8870
50 Patch211: boost-1.54.0-spirit-unused_typedef.patch
51 Patch212: boost-1.54.0-spirit-unused_typedef-2.patch
52 # https://svn.boost.org/trac/boost/ticket/8871
53 Patch213: boost-1.54.0-numeric-unused_typedef.patch
54 # https://svn.boost.org/trac/boost/ticket/8872
55 Patch214: boost-1.54.0-multiprecision-unused_typedef.patch
56 # https://svn.boost.org/trac/boost/ticket/8874
57 Patch215: boost-1.54.0-unordered-unused_typedef.patch
58 # https://svn.boost.org/trac/boost/ticket/8876
59 Patch216: boost-1.54.0-algorithm-unused_typedef.patch
60 # https://svn.boost.org/trac/boost/ticket/8877
61 Patch217: boost-1.54.0-graph-unused_typedef.patch
62 # https://svn.boost.org/trac/boost/ticket/8878
63 Patch218: boost-1.54.0-locale-unused_typedef.patch
64 # https://svn.boost.org/trac/boost/ticket/8879
65 Patch219: boost-1.54.0-property_tree-unused_typedef.patch
66 # https://svn.boost.org/trac/boost/ticket/8880
67 Patch220: boost-1.54.0-xpressive-unused_typedef.patch
68 # https://svn.boost.org/trac/boost/ticket/8881
69 Patch221: boost-1.54.0-mpi-unused_typedef.patch
70 # https://svn.boost.org/trac/boost/ticket/8888
71 Patch222: boost-1.54.0-python-unused_typedef.patch
72 # https://svn.boost.org/trac/boost/ticket/8941
73 Patch223: boost-1.54.0-lexical_cast-int128.patch
74 # https://svn.boost.org/trac/boost/ticket/9038
75 Patch224: boost-1.54.0-pool-test_linking.patch
76 # https://svn.boost.org/trac/boost/ticket/9037
77 Patch225: boost-1.54.0-thread-cond_variable_shadow.patch
78 # https://svn.boost.org/trac/boost/ticket/9041
79 Patch226: boost-1.54.0-thread-link_atomic.patch
80 URL:            http://www.boost.org/
81 BuildRequires:  bzip2-devel
82 BuildRequires:  expat-devel
83 BuildRequires:  libicu-devel
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  perl-base
86 %{?with_python:BuildRequires:   python-devel >= 2.2}
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  zlib-devel
89 BuildConflicts: gcc = 5:3.3.1
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
93
94 %description
95 The Boost web site provides free peer-reviewed portable C++ source
96 libraries. The emphasis is on libraries which work well with the C++
97 Standard Library. One goal is to establish "existing practice" and
98 provide reference implementations so that the Boost libraries are
99 suitable for eventual standardization. Some of the libraries have
100 already been proposed for inclusion in the C++ Standards Committee's
101 upcoming C++ Standard Library Technical Report.
102
103 %description -l pl.UTF-8
104 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
105 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
106 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
107 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
108 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
109 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
110 Raporcie Technicznym Biblioteki Standardowej C++.
111
112 %package devel
113 Summary:        Boost C++ development headers
114 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
115 Group:          Development/Libraries
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       %{name}-chrono = %{version}-%{release}
118 Requires:       %{name}-context = %{version}-%{release}
119 Requires:       %{name}-date_time = %{version}-%{release}
120 Requires:       %{name}-filesystem = %{version}-%{release}
121 Requires:       %{name}-graph = %{version}-%{release}
122 Requires:       %{name}-locale = %{version}-%{release}
123 Requires:       %{name}-program_options = %{version}-%{release}
124 Requires:       %{name}-regex = %{version}-%{release}
125 Requires:       %{name}-signals = %{version}-%{release}
126 Requires:       %{name}-system = %{version}-%{release}
127 Requires:       %{name}-test = %{version}-%{release}
128 Requires:       %{name}-thread = %{version}-%{release}
129 Requires:       %{name}-timer = %{version}-%{release}
130 Requires:       %{name}-wave = %{version}-%{release}
131 Requires:       libstdc++-devel
132 Obsoletes:      boost-any-devel
133 Obsoletes:      boost-array-devel
134 Obsoletes:      boost-asio
135 Obsoletes:      boost-bind-devel
136 Obsoletes:      boost-call_traits-devel
137 Obsoletes:      boost-compatibility-devel
138 Obsoletes:      boost-compose-devel
139 Obsoletes:      boost-compressed_pair-devel
140 Obsoletes:      boost-concept_check-devel
141 Obsoletes:      boost-conversion-devel
142 Obsoletes:      boost-crc-devel
143 Obsoletes:      boost-date_time-devel
144 Obsoletes:      boost-filesystem-devel
145 Obsoletes:      boost-graph-devel
146 Obsoletes:      boost-mem_fn-devel
147 Obsoletes:      boost-mpl-devel
148 Obsoletes:      boost-preprocessor-devel
149 Obsoletes:      boost-program_options-devel
150 Obsoletes:      boost-ref-devel
151 Obsoletes:      boost-regex-devel
152 Obsoletes:      boost-signals-devel
153 Obsoletes:      boost-spirit-devel
154 Obsoletes:      boost-statechart-devel
155 Obsoletes:      boost-static_assert-devel
156 Obsoletes:      boost-test-devel
157 Obsoletes:      boost-thread-devel
158 Obsoletes:      boost-tr1-devel
159 Obsoletes:      boost-type_traits-devel
160 Obsoletes:      boost-typeof-devel
161 Obsoletes:      boost-uBLAS-devel
162 Obsoletes:      boost-utility-devel
163 Obsoletes:      boost-wave-devel
164 Obsoletes:      boost-xpressive-devel
165
166 %description devel
167 Header files for the Boost C++ libraries.
168
169 %description devel -l pl.UTF-8
170 Pliki nagłówkowe bibliotek C++ Boost.
171
172 %package static
173 Summary:        Static version of base Boost C++ libraries
174 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177 Obsoletes:      boost-static < 1.33
178
179 %description static
180 Static version of base Boost C++ libraries.
181
182 %description static -l pl.UTF-8
183 Statyczne wersje podstawowych bibliotek C++ Boost.
184
185 %package python
186 Summary:        Boost.Python library
187 Summary(pl.UTF-8):      biblioteka Boost.Python
188 Group:          Libraries
189 %pyrequires_eq  python
190
191 %description python
192 Use the Boost Python Library to quickly and easily export a C++
193 library to Python such that the Python interface is very similar to
194 the C++ interface. It is designed to be minimally intrusive on your
195 C++ design. In most cases, you should not have to alter your C++
196 classes in any way in order to use them with Boost.Python. The system
197 should simply ``reflect'' your C++ classes and functions into Python.
198
199 %description python -l pl.UTF-8
200 Biblioteka Boost Python służy do szybkiego i prostego eksportu
201 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
202 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
203 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
204 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
205 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
206 klasy C++ i funkcje do Pythona.
207
208 %package python-devel
209 Summary:        Boost.Python development headers
210 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
211 Group:          Development/Libraries
212 Requires:       %{name}-devel = %{version}-%{release}
213 Requires:       %{name}-python = %{version}-%{release}
214
215 %description python-devel
216 Headers for the Boost.Python library.
217
218 %description python-devel -l pl.UTF-8
219 Pliki nagłówkowe dla biblioteki Boost.Python.
220
221 %package python-static
222 Summary:        Static version of Boost.Python library
223 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
224 Group:          Development/Libraries
225 Requires:       %{name}-python-devel = %{version}-%{release}
226
227 %description python-static
228 Static version of Boost.Python library.
229
230 %description python-static -l pl.UTF-8
231 Statyczna wersja biblioteki Boost.Python.
232
233 %package chrono
234 Summary:        Useful time utilities
235 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
236 Group:          Libraries
237 Obsoletes:      boost < 1.33
238
239 %description chrono
240 Useful time utilities.
241
242 %description chrono -l pl.UTF-8
243 Przydatne funkcje związane z czasem.
244
245 %package context
246 Summary:        Boost.Context - context switching library
247 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
248 Group:          Libraries
249
250 %description context
251 Boost.Context - context switching library, providing a sort of
252 cooperative multitasking on a single thread.
253
254 %description context -l pl.UTF-8
255 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
256 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
257
258 %package date_time
259 Summary:        Date-Time library
260 Summary(pl.UTF-8):      Biblioteka daty-czasu
261 Group:          Libraries
262 Obsoletes:      boost < 1.33
263
264 %description date_time
265 A set of date-time libraries.
266
267 %description date_time -l pl.UTF-8
268 Zbiór bibliotek daty-czasu.
269
270 %package filesystem
271 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
272 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
273 Group:          Libraries
274 Requires:       %{name}-system = %{version}-%{release}
275 Obsoletes:      boost < 1.33
276
277 %description filesystem
278 The boost::filesystem library provides portable facilities to query
279 and manipulate paths, files, and directories.
280
281 %description filesystem -l pl.UTF-8
282 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
283 operacjach na ścieżkach, plikach i katalogach.
284
285 %package graph
286 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
287 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
288 Group:          Libraries
289
290 %description graph
291 The boost::graph library provides portable facilities to operate on
292 graph data structures using graph algorithms.
293
294 %description graph -l pl.UTF-8
295 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
296 strukturach danych typu graf za pomocą algorytmów związanych z
297 grafami.
298
299 %package locale
300 Summary:        Provide localization and Unicode handling tools for C++
301 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
302 Group:          Libraries
303
304 %description locale
305 Provide localization and Unicode handling tools for C++.
306
307 %description locale -l pl.UTF-8
308 Narzędzia do obsługi lokalizacji i Unikodu w C++.
309
310 %package log
311 Summary:        Provide logging tools for C++
312 Summary(pl.UTF-8):      Narzędzia do logowania w C++
313 Group:          Libraries
314
315 %description log
316 Provide logging tools for C++.
317
318 %description log -l pl.UTF-8
319 Narzędzia do logowania w C++.
320
321 %package program_options
322 Summary:        Access to program options, via conventional methods such as command line and config file
323 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
324 Group:          Libraries
325
326 %description program_options
327 The program_options library allows program developers to obtain
328 program options, that is (name, value) pairs from the user, via
329 conventional methods such as command line and config file.
330
331 %description program_options -l pl.UTF-8
332 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
333 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
334 jak linia poleceń, czy plik konfiguracyjny.
335
336 %package regex
337 Summary:        Boost C++ regular expressions library
338 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
339 Group:          Libraries
340
341 %description regex
342 Shared library for Boost C++ regular expressions.
343
344 %description regex -l pl.UTF-8
345 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
346
347 %package signals
348 Summary:        Signals & slots callback implementation
349 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
350 Group:          Libraries
351 Obsoletes:      boost < 1.33
352
353 %description signals
354 The boost::signals library is an implementation of a signals and slots
355 system.
356
357 %description signals -l pl.UTF-8
358 Biblioteka boost::signals jest implementacją systemu sygnałów i
359 slotów.
360
361 %package system
362 Summary:        Support for getting system specific error codes
363 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
364 Group:          Libraries
365
366 %description system
367 The Boost System library provides simple, light-weight error_code
368 objects that encapsulate system-specific error code values, yet also
369 provide access to more abstract and portable error conditions objects.
370
371 %description system -l pl.UTF-8
372 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
373 obudowujące wartości kodów błędów specyficznych dla systemu, dając
374 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
375 błędów.
376
377 %package test
378 Summary:        Support for program testing and execution monitoring
379 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
380 Group:          Libraries
381 Obsoletes:      boost < 1.33
382
383 %description test
384 Support for simple program testing, full unit testing, and for program
385 execution monitoring.
386
387 %description test -l pl.UTF-8
388 Wsparcie dla prostego testowania programu, pełnego testowania i
389 monitorowania wykonania programu.
390
391 %package thread
392 Summary:        Portable C++ threads library
393 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
394 Group:          Libraries
395 Obsoletes:      boost < 1.33
396
397 %description thread
398 Portable C++ threads library - shared library.
399
400 %description thread -l pl.UTF-8
401 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
402
403 %package timer
404 Summary:        Event timer, progress timer, and progress display classes
405 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
406 Group:          Libraries
407 Obsoletes:      boost < 1.33
408
409 %description timer
410 Event timer, progress timer, and progress display classes.
411
412 %description timer -l pl.UTF-8
413 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
414
415 %package wave
416 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
417 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
418 Group:          Development/Libraries
419
420 %description wave
421 Boost.Wave - a standard compliant C++ preprocessor library.
422
423 %description wave -l pl.UTF-8
424 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
425
426 %package doc
427 Summary:        Boost C++ Library documentation
428 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
429 Group:          Documentation
430 Requires:       %{name}-devel = %{version}-%{release}
431
432 %description doc
433 Documentation for the Boost C++ Library.
434
435 %description doc -l pl.UTF-8
436 Dokumentacja dla biblioteki Boost C++.
437
438 %prep
439 %setup -q -n %{name}_%{fver}
440 %patch0 -p1
441 %patch1 -p2
442
443 %patch100 -p1
444 %patch101 -p1
445 %patch102 -p1
446
447 %patch200 -p1
448 %patch201 -p1
449 %patch202 -p1
450 %patch203 -p0
451 %patch204 -p1
452 %patch205 -p1
453 %patch206 -p0
454 %patch207 -p0
455 %patch208 -p0
456 %patch209 -p0
457 %patch210 -p1
458 %patch211 -p1
459 %patch212 -p1
460 %patch213 -p1
461 %patch214 -p1
462 %patch215 -p1
463 %patch216 -p1
464 %patch217 -p1
465 %patch218 -p1
466 %patch219 -p1
467 %patch220 -p1
468 %patch221 -p1
469 %patch222 -p1
470 %patch223 -p0
471 %patch224 -p1
472 %patch225 -p1
473 %patch226 -p1
474
475 # - don't know how to pass it through (b)jam -s (no way?)
476 #   due to oversophisticated build flags system.
477 # - pass -fPIC due to <shared-linkable> removal.
478 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
479
480 # cleanup -g switch to avoid override debuginfocflags.
481 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
482 # link against shared expat library.
483 %{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
484
485 cat << EOF > tools/build/v2/user-config.jam
486 using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
487 EOF
488
489 %build
490 %if %{with python}
491 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
492 PYTHON_ROOT=%{_prefix}
493 %else
494 PYTHON_ROOT=
495 PYTHON_VERSION=
496 %endif
497 EXPAT_INCLUDE=%{_includedir} \
498 EXPAT_LIBPATH=%{_libdir} \
499 ICU_PATH=%{_prefix} \
500 ./bootstrap.sh --prefix=%{_prefix}
501 ./b2 \
502         -d2 --toolset=gcc \
503         variant=release debug-symbols=on inlining=on link=static,shared threading=multi
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
508
509 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
510
511 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
512 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
513 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
514
515 # documentation
516 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
517
518 # as the documentation doesn't completely reside in a directory of its
519 # own, we need to find out ourselves... this looks for HTML files and
520 # then collects everything linked from those.  this is certainly quite
521 # unoptimized wrt mkdir calls, but does it really matter?
522 installdocs() {
523 for i in $(find -type f -name '*.htm*'); do
524         # bjam docu is included in the boost-jam RPM
525         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
526                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
527                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
528                         sub rewrite_link
529                         {
530                                 my $link = shift;
531                                 # rewrite links from boost/* to %{_includedir}/boost/* and
532                                 # ignore external links as well as document-internal ones.
533                                 # HTML files are also ignored as they get installed anyway.
534                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
535                                 {
536                                         (my $file = $link) =~ s/\#.*//;
537                                         print "$file\n";
538                                 }
539                                 $link;
540                         }
541                         open IN, @ARGV[0];
542                         open OUT, ">@ARGV[1]";
543                         my $in_link;
544                         while (<IN>)
545                         {
546                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
547                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
548                                 print OUT;
549                                 $in_link = /href|src=\s*$/;
550                         }
551 EOT`; do
552                         TARGET=${i%/*}/$LINKED
553                         # ignore non-existant linked files
554                         if test -f $TARGET; then
555                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
556                         fi
557                 done
558         fi
559 done
560 }; installdocs
561
562 %clean
563 rm -rf $RPM_BUILD_ROOT
564
565 %post   -p /sbin/ldconfig
566 %postun -p /sbin/ldconfig
567
568 %post   chrono -p /sbin/ldconfig
569 %postun chrono -p /sbin/ldconfig
570
571 %post   context -p /sbin/ldconfig
572 %postun context -p /sbin/ldconfig
573
574 %post   date_time -p /sbin/ldconfig
575 %postun date_time -p /sbin/ldconfig
576
577 %post   filesystem -p /sbin/ldconfig
578 %postun filesystem -p /sbin/ldconfig
579
580 %post   graph -p /sbin/ldconfig
581 %postun graph -p /sbin/ldconfig
582
583 %post   locale -p /sbin/ldconfig
584 %postun locale -p /sbin/ldconfig
585
586 %post   python -p /sbin/ldconfig
587 %postun python -p /sbin/ldconfig
588
589 %post   program_options -p /sbin/ldconfig
590 %postun program_options -p /sbin/ldconfig
591
592 %post   regex -p /sbin/ldconfig
593 %postun regex -p /sbin/ldconfig
594
595 %post   signals -p /sbin/ldconfig
596 %postun signals -p /sbin/ldconfig
597
598 %post   system -p /sbin/ldconfig
599 %postun system -p /sbin/ldconfig
600
601 %post   test -p /sbin/ldconfig
602 %postun test -p /sbin/ldconfig
603
604 %post   thread -p /sbin/ldconfig
605 %postun thread -p /sbin/ldconfig
606
607 %post   timer -p /sbin/ldconfig
608 %postun timer -p /sbin/ldconfig
609
610 %post   wave -p /sbin/ldconfig
611 %postun wave -p /sbin/ldconfig
612
613 %files
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
616 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
617 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
618 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
619 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
620 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
621
622 %files devel
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/libboost_atomic.so
625 %attr(755,root,root) %{_libdir}/libboost_chrono.so
626 %attr(755,root,root) %{_libdir}/libboost_context.so
627 %attr(755,root,root) %{_libdir}/libboost_date_time.so
628 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
629 %attr(755,root,root) %{_libdir}/libboost_graph.so
630 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
631 %attr(755,root,root) %{_libdir}/libboost_locale.so
632 %attr(755,root,root) %{_libdir}/libboost_log.so
633 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
634 %attr(755,root,root) %{_libdir}/libboost_math_*.so
635 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
636 %attr(755,root,root) %{_libdir}/libboost_program_options.so
637 %attr(755,root,root) %{_libdir}/libboost_regex.so
638 %attr(755,root,root) %{_libdir}/libboost_random.so
639 %attr(755,root,root) %{_libdir}/libboost_serialization.so
640 %attr(755,root,root) %{_libdir}/libboost_signals.so
641 %attr(755,root,root) %{_libdir}/libboost_system.so
642 %attr(755,root,root) %{_libdir}/libboost_thread.so
643 %attr(755,root,root) %{_libdir}/libboost_timer.so
644 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
645 %attr(755,root,root) %{_libdir}/libboost_wave.so
646 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
647 %{_includedir}/boost
648 %exclude %{_includedir}/boost/python
649 %exclude %{_includedir}/boost/python.hpp
650
651 %files static
652 %defattr(644,root,root,755)
653 %{_libdir}/libboost_atomic.a
654 %{_libdir}/libboost_chrono.a
655 %{_libdir}/libboost_context.a
656 %{_libdir}/libboost_coroutine.a
657 %{_libdir}/libboost_date_time.a
658 %{_libdir}/libboost_exception.a
659 %{_libdir}/libboost_filesystem.a
660 %{_libdir}/libboost_graph.a
661 %{_libdir}/libboost_iostreams.a
662 %{_libdir}/libboost_locale.a
663 %{_libdir}/libboost_log.a
664 %{_libdir}/libboost_log_setup.a
665 %{_libdir}/libboost_math_*.a
666 %{_libdir}/libboost_prg_exec_monitor.a
667 %{_libdir}/libboost_program_options.a
668 %{_libdir}/libboost_random.a
669 %{_libdir}/libboost_regex.a
670 %{_libdir}/libboost_serialization.a
671 %{_libdir}/libboost_signals.a
672 %{_libdir}/libboost_system.a
673 %{_libdir}/libboost_test_exec_monitor.a
674 %{_libdir}/libboost_timer.a
675 %{_libdir}/libboost_thread.a
676 %{_libdir}/libboost_unit_test_framework.a
677 %{_libdir}/libboost_wave.a
678 %{_libdir}/libboost_wserialization.a
679
680 %if %{with python}
681 %files python
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
684
685 %files python-devel
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/libboost_python.so
688 %{_includedir}/boost/python
689 %{_includedir}/boost/python.hpp
690
691 %files python-static
692 %defattr(644,root,root,755)
693 %{_libdir}/libboost_python.a
694 %endif
695
696 %files chrono
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
699
700 %files context
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
703
704 %files date_time
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
707
708 %files filesystem
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
711
712 %files graph
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
715
716 %files locale
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
719
720 %files log
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
723 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
724
725 %files program_options
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
728
729 %files regex
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
732
733 %files signals
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
736
737 %files system
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
740
741 %files test
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
744 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
745
746 %files thread
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
749
750 %files timer
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
753
754 %files wave
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
757
758 %files doc
759 %defattr(644,root,root,755)
760 %{_docdir}/%{name}-%{version}
This page took 0.196287 seconds and 4 git commands to generate.